WinJUPOS - Table of contents

WinJUPOS

Introduction

System requirements

Preferences

Clipboard

Object positions

Command line

Lists

Lists of object positions

Editing of file information

Recording and editing of Central Meridian Timings

Recording and editing of Measurements

Modified rotational system

List of observers

Image measurement

Introduction

Image definition

Adjustment of image

Object positions

Save object positions

Object code Jupiter (JUPOS)

Object code Saturn (SAPOS)

Region code Jupiter (JUPOS)

Region code Saturn (SAPOS)

Miscellaneous

Options

Literature

Selection

Introduction

Data files

Objects to be selected

Additional filter

Sorting criteria

Drift computation

Drift conversion

Drift computation with marked data records

Positional averages

Introduction

Data files

Longitudinal shifts

Introduction

Data files

Drift charts

Introduction

Data files

Auxiliary lines

Map computation

Introduction

Page layout

Drift correction

Supplementary notes

Longitude drifts determination from image pairs

Introduction

Drift profile Jupiter

Drift profile Saturn

Computation of drift averages

Introduction

Longitudinal drift charts

Introduction

Data files

Administration

Data test

Data repair

Data conversion

Data comparison

File sorting

File export

Rename file

Update List of Observers (PC-JUPOS/SAPOS)

Macro execution

Synchronise settings files

Ephemerides

Introduction

Moon coordinates

Graphics

Options

Literature

Planning of observations

Introduction

De-rotation of images

Introduction

De-rotation of R/G/B frames

Introduction

De-rotation of video streams

Introduction

Image calibration

Computation of polarisation

Introduction

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2016


WinJUPOS - Introduction

WinJUPOS is the result of long-time work of amateur astronomers to support observation and analysis of phenomena on planets of our solar system. The core of the software is a database of positions of objects in the atmosphere, or on the surface, of the planets and the Sun.

It began with an electronic data collection, as part of the International Jupiter Voyager Telescope Observations Programme (IJVTOP), made by Holger Haug and Christian Kowalec on VAX machines in the 70's.

In 1989, Hans-Jörg Mettig developed the Central Meridian Transits Project (ZMPP, version 1) for Jupiter, which made possible a first data management and analysis on PC's under the operation system DOS.

In 1992 the author, Grischa Hahn, resumed development of this program, and later produced the DOS softwares PC-MAPOS (Mars), PC-JUPOS (Jupiter, versions 2 to 6) and PC-SAPOS (Saturn), as well as numerous utilities.

Due to the rapid technical progress, software porting to WINDOWS became more and more urgent, and finally started in 2002. WinJUPOS (to version 7) comprises all previous developments.

What can you do with JUPOS?

It helps the observer in the preparation of an observation. For that purpose, you can use the modules Ephemerides and Planning of observations.

The visual observer of Jupiter and Saturn can record his Central Meridian transits of an object (Object positions) with the module Recording of Central Meridian transit timings in the database.

Observations made with the help of digital images (CCD images or digitalized photos) require a more complex processing.

For instance, if you have monochromatic images of different wawelengths and if you want to produce from them a color image, use the module Image computation . But first, you must measure the monochromatic images in the module Image measurement ,(that is to place carefully the outline frame and to save the parameters in a file).

With the module Image measurement , you can produce Object positions and record them in the database (Measurements).

From one or several measured digital images, you can produce a map with the module Map computation . Then, these maps can be used in the module Ephemerides for texturing the surface of a celestial body.

The recorded Object positions can be be filtered with several criteria (module Selection).

The module Longitudinal shifts allows to compute personal systematic errors of an observer in C.M. transits. Then, these corrections can be used in the module Selection .

The average value of Object positions of an object can be computed in the module Positional averages .

Object positions can be displayed in a graph with Drift charts .

An average linear drift of an object for a determined time span can be computed. For that purpose, there are several possibilities: in a list of Object positions; on a graph, by using two points or building a polygon around the points (but in that case, the the module Drift charts must be activated). These drifts can be used in several modules, using the JUPOS clipboard : as modified rotational system, to draw drift lines in Drift charts or as a record in a particular drift file.

Another automatic way of computing and displaying longitudinal drifts (on Jupiter) is possible with the modules Longitude drifts determination from image pairs , Computation of drift averages and Longitudinal drift charts .

(c) Grischa Hahn, Michel Jacquesson, 2011


WinJUPOS - System requirements

To ensure that the software works as intended, the following minimum configuration is required:

  • Windows 2000 / XP / Vista / 7 / 8 / 10, x86 processor 32 / 64-bit

  • 15 or 16 bit graphics (RealColour or HiColour)

  • 1024x768 pixels

  • 256 MB - 1 GB RAM
The 64 bit version is up to two times faster than the 32 bit version of WinJUPOS.
For the installation of the 64 bit version you need administration right.
(c) Grischa Hahn, Michel Jacquesson , Hans-Jörg Mettig, 2018


WinJUPOS - Preferences

General

Drift unit

Defines the unit of angular drift velocities.

Fonts

Configures the screen fonts to be used. Changes of the standard settings may be useful in particular system environments, e.g. for displaying special language characters, or if you want to run WinJUPOS under Linux (with Wine).

Directories

Data directory

You have to identify a root directory under which all files of the chosen celestial body are stored, viz. Central Meridian transits, Measurements, configuration files, images, drift charts, maps, and so on.

All paths written to settings files are relative to this WinJUPOS Data directory. Consequently, you must not modify the relevant directories below, or relative to this Data directory. Otherwise, the stored paths become invalid.

If needed, you can quickly switch between separate environments by changing the Data directory.

Options

Always open [ Start Recording - Image measurement ] with no image displayed
Opening of an image measurement window can last a long time when an image has been defined before, correction of limb darkening, zoom, rotation, high image quality or quick move have been activated. To avoid this, you can leave the image measurement window blank, which accelerates considerably the opening. Pay attention to the fact that you must save your defined parameters before you close the window.

Save / Load

With “Save / Load” you can save or re-load a complete WinJUPOS environment. The structure of a preference file (*.wjs) corresponds to that of the WinJUPOS configuration file (WinJUPOS.INI). Thus you are able to toggle between different project environments.

(c) Grischa Hahn, Michel Jacquesson, 2012


WinJUPOS - Clipboard

The WinJUPOS Clipboard is a container required for copying and pasting (re-loading) drift data, provided at several places of the application. Drift data of an object can be its longitude drift, latitude drift, or both.

Source of such data is the Drift computation or Drift charts.

(c) Grischa Hahn, Michel Jacquesson, 2008


WinJUPOS - Object positions

Object positions on planets and the Sun can be measured in different ways:

Central Meridian transit timings are estimates of the time when an objects crosses the Central Meridian (C.M.) of the planet's disc. Then the planetographic longitude of that object can be computed fairly accurately on the base of the special position of the planet. Latitudinal positions on Jupiter and Saturn are estimated via the band / zone pattern. The advantage of that method is that it requires relatively few time and investments in equipment. It can be done with a telescope of sufficient resolution, and a precise clock only; the telescope's mounting and drive are of secondary importance. First disadvantage is, you have to wait till the object crosses the CM, and the second is, latitude estimates remain inaccurate. As Central Meridian transit can hardly be timed without a visible equator-parallel belt/zone pattern, this method is used on Jupiter and Saturn only.

Micrometer and Image measurements are more elaborate methods. The former are done visually, directly at the eyepiece, while the latter require an image of the celestial body. Photos and electronic (CCD, video) recordings but also very precise drawings can be such an image. The advantage of this method is to be able to measure longitude and latitude simultaneously, and to measure various objects. Higher demands on technology, i.e., size, mounting, drive, camera unit, and subsequent image processing are disadvantages.

WinJUPOS distinguishes groups of object positions where the groups are defined by both the observational method (transit timing or measurement), and an identifier. Actually, this identifier can be chosen arbitrarily. To make things easier, WinJUPOS interprets it as the code of an observer. However, other grouping criteria could also be possible.

PC-JUPOS and PC-SAPOS:

Transits are stored in subdirectory STAMMDAT, in files with extension ZMP or SZM. Measurements are recorded in subdirectory MESSDAT, in files with extension MES or SME. The filename with 8 characters maximum is considered as the observer's code.

Further information about all the individual data files is collected in a so-called List of Observers. This is is a file named LIST_ZMP.BEO or LIST_SZM.BEO for transits, and LIST_MES.BEO or LIST_SME.BEO for measurements, located in the same subdirectory. The List contains the full name of the observer, his address, as well as number and time limits of his objects positions.

WinJUPOS:

File names are no more restricted to 8 characters. All information is now stored in C.M. transit (*.CMT) and measurements (*.MEA) files. The observer's code corresponds to the first 16 characters of the file name. It is a primary key of the Selection. The name of the observer is limited to 30, and his address - distributed over several lines - to 90 characters. The user can use any data directories but it is strongly recommended to store all MEA files of one celestial body in one dedicated directory. The same holds true for CMT files, of course.

Following new columns are available for WinJUPOS measurements:

  • Image info, 32 characters (country-specific), used for informational purposes
  • ID, 16 ASCII characters, used as a search key in the Selection
  • Description, 32 ASCII characters, used for informational purposes

The meaning of following field has been extended:

  • Channel code, 4 ASCII characters, can be used as a search key in the Selection
(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


WinJUPOS - Command line

WinJUPOS.exe [Name of celestial body] [/GetCM:yyyy-mm-dd_hh:mm:ss] [/GetAlt] [/GeoLog:Long] [GeoLat:Lat]

Name of celestial body

Sun | Mercury | Venus | Moon | Mars | Jupiter | Saturn | Uranus | Neptune

This parameter set the celestial body for the run of WinJUPOS.

/GetCM:yyyy-mm-dd_hh:mm:ss

Computes the Central Meridians of the current celestial body at specified time in UT. The Central Meridians will be returned as ANSI text to STDOUT, but will not be displayed directly in the command line window.

Examples:

WinJUPOS.exe Jupiter /GetCM:2011-02-24_18:12:42 >cm.txt

An ANSI text file cm.txt will be created with following content:

"CM I = 86.0° CM II = 311.1° CM III = 198.6°".

WinJUPOS.exe Jupiter /GetCM:2011-02-24_18:12:42 >>cm.txt

The output will be attached to an (existing) file cm.txt.

WinJUPOS.exe Jupiter /GetCM:2011-02-24_18:12:42 |more

Following text will be displayed in the command line window:

"CM I = 86.0░ CM II = 311.1░ CM III = 198.6░"

The degree characters (°) will be displayed as ░-characters. The reason is that the command line window works with a DOS instead of the ANSI character set.

/GetAlt

Additional output of the height of the celestial body if /GetCM is specified:

WinJUPOS Moon /GetCM:1987-10-18_12:00:00 /GetAlt

"CM = -1.71° Alt. = 40°"

/GeoLong:Long

Set the geographic longitude of the place of observation for /GetCM. Standard is 0°.

/GeoLat:Lat

Set the geographic latitude of the place of observation for /GetCM. Standard is 0°.

WinJUPOS Moon /GetCM:1987-10-18_12:00:00 /GetAlt /GeoLong:+15.0 /GeoLat:+50.0

"CM = -2.76° Alt. = 25°"

(c) Grischa Hahn, 2011


Lists - Lists of object positions

You can find general indications on the use of the data with WinJUPOS in the chapter Lists of Objects positions.

When you open an objects positions file, a window is opened with a list of all recorded objects positions.

There are two modules for the objects lists. In the first, you can only display the content of the file (read only). In the second, on the contrary, you can modify and add ( read and write). The first window has a cream background and the second a white one.

In the read/write mode, a file is created automatically if it does not still exists.

File

A submenu is opened with following commands:

File-Info

Opens a window with detailed information about the file (Editing of file information)

Sorting

WinJUPOS standard sorting;

Date + time, latitude/region, object code (CM transits)

Date + time, latitude/Region, longitude (measurements)

Modified rotational system

You can define the parameters of a Modified rotational system, which can be used to display an objects list.

Print

Printing of the whole list.

Export

Export the whole file.

Selected data recordings

A submenu is opened with following commands (also with the right mouse button) concerning the selected records (black or red background):

Edit

Editing of the selected data records. In case of a multiple selection, the fields containing different data are marked with *. You can change the contents of several records at the same time. When they are saved, the changes are definitive.

Delete

After a warning question, deletes definitively the selected records.

Insert a new record

Inserts a new record before the selected record.

Add new record

Appends a new record.

Select all records

Selects all (active) records.

Print

Prints the selected records.

Save as

Saves the selected records in a chosen objects positions file. The order of the records remains unchanged.

Append to others file...

Appends the selected records to a chosen objects positions file. The order of the records remains unchanged.

Export

Export of the selected records.

Drift computation

When you have selected several recordings with a time span of more than 12 hours, you can make a Drift computation.

Start original image measurement (measurements in WinJUPOS format only)

If the object position has been computed from an image measurement with WinJUPOS, you can display the measurement window with the object position. The parameters are saved in a separate file [measurements data file].IMR placed in the directory of the measurements file. These parameters are available only if the image is available. In case of a multiple selection, this option is not available.

Ephemerides

Opens the ephemerides window at the date and time of the recording. In case of a multiple selection, this option is not available.

Change time of observation (measurements only)

If you have entered a false observation time, you can correct it within certain limits. The longitude, latitude and phase angle of the selected records are computed again from the new observation time.

Record (F9)

In this data capture field, you can get directly a record if you enter its number. To stop this function, strike the key [Enter] or [ESC].

Date (F10)

In this data capture field, you can enter a date to get the first record with that date. To stop this function, strike the key [Enter] or [ESC].

Following key combinations are available :

[Ctrl]+[A] | Selects all (active) records.
[F9] | The data capture field Record is selected.
[F10] | The data capture field Date is selected.

Changing the list aspect:

With the Zoom button [image] you can display different aspect of the data list with different information.

(c) Grischa Hahn, Michel Jacquesson 2008


Lists - Editing of file information

You can get in the chapter Objects positions general information about the data processing.

For each object positions file, the number of recordings and the first and last observation dates are displayed.

Central meridian transits and measurements files (original observations) contain further information:

PC-JUPOS and PC-SAPOS:

File name | 8 characters, ASCII
Observer's code | = File name
Observer's name | 30 characters, ASCII
Address | 3 x 30 characters, ASCII

The observer information are recorded in a separate observers file in the directory of the objects positions files (*.beo).

WinJUPOS:

File name | recommended: 16 characters
Observer's code | = File name, 16 characters
Observer's name | 30 characters
Address | 90 characters, several lines possible

The observer information are recorded in the objects positions file itself.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Lists - Recording and editing of Central Meridian transit timings

You can use either the new WinJUPOS format (file extension .cmt) or the old format of PC-JUPOS (*.zmp) or PC-SAPOS (*.szm). The latter does not support the attributes ID, Description, and Channel.

Read-only records have a cream background, records with a white background can be edited.

Object

Record (no.)

Running number of the object position, starting with 1. It represents the record's physical position in the file, and may change after re-ordering or a deletion.

Code

Jupiter / Saturn

Region

Jupiter / Saturn

Date

Date of transit, in UT.

UT

Time of transit, in UT.

±

Uncertainty of the transit time, in minutes.

Long. L

Planetographic longitude of the Central Meridian in System at Date, UT. It will be automatically computed.

Sy.

Rotational system. Several longitude systems only exist for Venus (2), Jupiter and Saturn (3). Otherwise, the number is 1.

Instr.

Enter type and aperture of the observation instrument:

  1. "R" for refractor, or "S" for reflector
  2. Aperture in millimetres (40 to 999 possible).

If type or aperture are unknown, leave the corresponding fields blank.

Magn.

Magnification of the observation instrument (40 to 999 possible). If unknown, leave this fied blank.

Orie.

Enter the image orientation the planet has had in the eyepiece during the transit:

"SR"

South up, normal image (rotation from right to left)

"NR"

North up, normal image (rotation from left to right)

"SV"

South up, laterally inverted image (rotation from left to right)

"NV"

North up, laterally inverted image (rotation from right to left)

"IR"

any other "irregular" orientation

If unknown, leave the field blank.

ID

Arbitrary text, can be used to identify certain records. It is available as filter Object ID in the Selection module. (English, 16 characters, ASCII)

Description

Arbitrary text. Can, for example, be used to write down comments about aspect or behaviour of the observed feature. (English, 32 characters, ASCII)

Channel

Four-digit code to describe the wavelength range, or colour channel used (English, 4 characters, ASCII):

colo

No filter applied

red

Observation in red channel

gree

Observation in green channel

blue

Observation in blue channel

Ephemerides

Opens the Ephemerides module at Date and UT.

Save

Writes the current record to the file. A test is done if if a similar record already exists. If so, you have the choice either to (irretrievably) overwrite the existing transit, or to add the new one.

Cancel

Rejects all changes and closes the window.

(c) Grischa Hahn, Michel Jacquesson , Hans-Jörg Mettig, 2008


Lists - Recording and editing of Measurements

You can use either the new WinJUPOS format (file extension .mea) or the old format of PC-JUPOS (*.mes) or PC-SAPOS (*.sme). The latter does not support the attributes ID and Description, Image info just partially.

Read-only records have a cream background, records with a white background can be edited.

Measurements fields

File name

Path and name of Measurements file.

Observer

Name of observer associated to the Measurements file.
Object

Record (no.)

Running number of the object position, starting with 1. It represents the record's physical position in the file, and may change after re-ordering or a deletion.

Code

Object code Jupiter / Saturn

Region (or R)
Region code Jupiter / Saturn

When you open the Edit window from the Measurements screen, Region is pre-filled with the proper value determined from Latit. B/B". Special objects like RS or WOS-BC will also be taken into account.

Date

Date of observation, in UT.

UT

Time of observation, in UT.

Long. L

Measured planetographic longitude of the object in rotational system Sy..

±

Uncertainty of Long. L, in degrees. If unknown, leave this field blank.

Sy.

Number of the rotational system. Several systems only exist for Venus (2), Jupiter and Saturn (3). Otherwise, the number is 1. When you open the Edit window from the Measurements screen, Sy. is pre-filled with the proper value determined from Latit. B/B".

Latit. B/B"

Measured planetocentric (B) or planetographic (B") latitude of the object. If unknown, leave this field blank.

±

Uncertainty of Latit. B/B", in degrees. If unknown, leave this field blank.

ID

Arbitrary text, can be used to identify certain records. It is available as filter Object ID in the Selection module. (English, 16 characters, ASCII)

Description

Arbitrary text. Can, for example, be used to write down comments about aspect or behaviour of the observed feature. (English, 32 characters, ASCII)

Image measurement

Image Info

Arbitrary text for adding more information about the image. (old PC-JUPOS/SAPOS format: 8 characters, ASCII but only if empty Measurer code and Channel; WinJUPOS format: 32 characters)

Measurer code

Unique three-digit code to identify the measurer of the image. (ASCII)

Channel

Four-digit code to describe the wavelength (range), or colour channel used (ASCII):

colo

Colour image

inte

Integrated light image, without filter

red

Monochromatic image in red light, or red channel of a colour image

gree

Monochromatic image in green light, or green channel of a colour image

blue

Monochromatic image in blue light, or blue channel of a colour image

3780

Narrow-band image at 3780 nm

889

Narrow-band image at 889 nm (Methane)

ired

Broad-band image in infrared light

uv

Broad-band image in ultraviolet light

phot

Measurement of a photograph

draw

Measurement of a drawing

mmea

Micrometer measurement

mest

Positional estimate with the aid of a micrometer

Ephemerides

Opens the Ephemerides module at Date and UT.

Save

Writes the current record to the file. A test is done if if a similar record already exists. If so, you have the choice either to (irretrievably) overwrite the existing measurement, or to add the new one.

Cancel

Rejects all changes and closes the window.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Lists - Modified rotational system

What is a modified rotational system?

Each object in a planet atmosphere shows a particular movement against a defined rotation system. In fact, it means that the longitude and latitude of an object are changing continuously. In first approach, in most cases, this particular movement can be described as a linear movement or with a drift rate. For example, an object drifts with -0.4058° per day in longitude against the rotation system 2.

To follow better visually and numerically an object with a strong drift rate, it is possible to display its longitude in a modified rotational system. The modified rotational system corresponds then more to the average linear drift of an object in longitude, so that this object appears almost stationary when it is displayed with a modified rotational system.

A modified rotational system can be defined as follows:

L' = Lx - ( Lx(T0) + Drift_Lx * (T - T0) )

where:

L' | - Longitude in modified rotation system
L | - observed longitude
x | - Rotation system x
L(T0) | - average Longitude at the time T0 (= reference date)
Drift_Lx | - average drift in longitude
T | - Time of observation
T0 | - Reference date

How can I determine the drift parameters of an object?

When you are in an object positions list, select the positions of one object in a determined time span and run the command Drift computation. Then copy the computed drift data in the Clipboard. With the command Paste drift data (as described below) you can use the data for your modified rotational system.

Reference system

Enter the reference system (rotation system) which determine the average Drift and the average longitude L(T0).

L(T0)

Average longitude in the Reference System at the Reference Date.

Drift

Average Drift in longitude in the Reference System.

Reference Date

= T0.

The button [image] opens a context menu with following commands:

Copy drift data

Makes a copy of the actual values of the modified rotational system in the Clipboard.

Paste drift data...

Opens the Clipboard . You can chose the drift data to be used for your modified rotational system.

Reset

Sets back L(T0) and Drift on "0". That is, the modified rotational system corresponds to the reference system.

(c) Grischa Hahn, Michel Jacquesson 2008


Lists - List of observers

The module Observers list scans all central meridian transits or measurements files of a directory and produces a list of observers information. This list can be sorted by different criterions and recorded as a text file.

(c) Grischa Hahn, Michel Jacquesson 2007


Image measurement - Introduction

With the module Image measurement you can measure positions of objects on the surface of celestial bodies.

All terrestrial images of celestial bodies are suitable but you have to know the record date and time in UT and the image orientation. Further information relates to the observer, the spectral range of the image and the Edge ratio of sensor elements (see Options) - if these are known.

Additionally you are able to measure Jupiter images taken by the New Horizons probe in 2007.

If you want to measure an image, you have to determine the position of the body by an outline frame and the positions of the objects by a cross-wire.

Object's positions will be displayed as planetographic or planetocentric (L1-3, B"/B) and as cartesian (x, y) co-ordinates.

You can activate the different pages in the measurement window by pressing the following key combinations:

[Ctrl]+[I] | Image definition (Image)
[Ctrl]+[A] | Adjustment of image (Adjust.)
[Ctrl]+[S] | Object positions (Pos.)
[Ctrl]+[M] | Miscellaneous (Misc.)
[Ctrl]+[O] | Options (Opt.)

(c) Grischa Hahn, 2010


Image measurement - Image definition

You can measure CCD images but also scanned photos, drawings or figures of a planet from the literature. Take care that images on photo-negatives or in books do not become twisted when making prints or scans! WinJUPOS is able to correct a stretching in width and height related to the original sensor image. Therefore please do not rotate the image before loading in WinJUPOS, if the Edge ratio of sensor elements are not 1:1.

Take care that:

  • The planet's outline must be distinct on that side which is not darkened by phase (you might only determine this by an appropriate choice of brightness, contrast and gamma coefficient of the image).
  • The orientation of the planet's disc is not prescribed but must be known.

If the exposure time of the image is coded in the file name according to the following conventions, this information will be automatically copied to the corresponding data fields when selecting the file:

Miyazaki-Convention

"MDDHHMM[T].<ext>"

M | {1..9, O, N, D} | month Januar .. December
DD | {0..9} | day
HH | {0..9} | hour (UT)
MM | {0..9} | minute (UT)
T | {0..9} | optional tenth of minute (UT) or
 | {C} | colour image
 | {R} | red channel
 | {G} | green channel
 | {B} | blue channel
 | {I} | infrared
 | {M} | methane

Only the year, observer and image info you have to input manually.

WinJUPOS-Conventions

"[Observer-]YYYY-MM-DD-HHMM[.][T][-Image info].<ext>"

"YYYY-MM-DD-HHMM[.][T]-Observer[-Image info].<ext>"

Observer | {Text without '-'} | optional
YYYY | {0..9} | year
MM | {0..9} | month
DD | {0..9} | day
HH | {0..9} | hour (UT)
MM.T | {0..9} | minute (UT). tenth of minute, optional
Image info | {Text without '-'} | optional

BAA-Convention

"YYYYMM[M]DD_HHMM[.][T]_Observer[_Image info].<ext>"

YYYY | {0..9} | year
MMM | {JAN, FEB, MAR, APR, MAY, JUN, JUL, AUG, SEP, OCT, NOC, DEC} | month
MM | {1..12} | month
DD | {0..9} | day
HH | {0..9} | hour (UT)
MM | {0..9} | minute (UT)
T | {0..9} | tenth of minute
Observer | {Text without '_'} |
Image info | {Text without '_'} | optional

PVOL-Convention

"PYYYY-MM-DD_HH-MM[-SS][_Filter][_Observer][_Info].<ext>"

P | {Character, not '_'} | Code for celestial body ('j' for Jupiter; 's' for Saturn; 'u' for Uranus)
YYYY | {0..9} | year
MM | {0..9} | month
DD | {0..9} | day
HH | {0..9} | hour (UT)
MM | {0..9} | minute (UT)
SS | {0..9} | second (UT), optional
Filter | {Text without '_'} | optional
Observer | {Text without '_'} | optional
Info | {Text without '_'} | optional

(Image info = Filter [+ '_' + Info])

The Geographic Latitude is negative southern of the equator. The Geographic Longitude is negative western of Greenwich.

Jupiter images of the New Horizons mission have to be identified by entering "New Horizons" or "NewHorizons" in field Observer. Ephemerides will automatically be computed for the spacecraft's position then.

A click with the right mouse button on the image to be measured will open a popup menu with useful commands for image control. These commands are also available on the left side of the window.

Settings

Reset

Resets all settings for Image measurement to default values.

Save/Load

Save resp. load the current settings of Image measurement. The name of uses settings file (*.ims) will be showed in the caption line of the Image measurement window.

Ephemerides

Opens the module Ephemerides with the corresponding time and the geographic co-ordinates of image measurement.

(c) Grischa Hahn, 2013


Image measurement - Adjustment of image

General procedure:

  1. Move and zoom the planetary image that all the planet is visible in the middle of the measurement window.
  2. Increase the brightness till the dark background becomes slightly brightened, and the true limb clearly visible, regardless how poor atmospheric features may be visible then. To achieve this, you could also try to alter contrast and gamma coefficient.
  3. Fit the outline frame as precisely as possible onto the true planet's limb. Note that the terminator often shades much more into the dark sky background than the phase-opposite limb. Hence, adjust the outline mainly onto the limb. Before opposition the phase is situated on the p. side of the planet, on its f. limb afterwards. Bear in mind that the precision of this positioning does decisively influence the quality of your measurements!
  4. Change the Gamma value - and possibly also Brightness and Contrast - that all objects on the planetary surface will be visible. If necessary switch LD compensation on and modify the LD value.

Image

You can move the image with the scroll controls but also by pressed and held middle mouse button (or also the mouse wheel). If you have activate Quick move (s. Options) the image will be moved with the mouse cursor, otherwise first when you have released the mouse button.

Channel

Choose the colour channel of the image to be showed. Alternative [F9] or [Strg]+[F9].

Zoom

[+]

increases image by factor 1.15

[Ctrl]+[+]

increases image by factor 1.33

[Shift]+[+]

increases image by factor 1.07

[-]

decreases image by factor 1.15

[Ctrl]+[-]

decreases image by factor 1.33

[Shift]+[-]

decreases image by factor 1.07

[Alt]+[0]

original size, zoom factor = 1.0

Rotation

[L]

rotates image to the left by 1°

[Ctrl]+[L]

rotates image to the left by 10°

[R]

rotates image to the right by 1°

[Ctrl]+[R]

rotates image to the right by 10°

[Ctrl]+[Backspace]

rotates image by 180°

[Ctrl]+[0]

Rotation = 0°

[Ctrl]+[H]

Rotates equator in horizontal position.

Gamma

[G]

increases gamma coefficient by factor 1.03

[Ctrl]+[G]

increases gamma coefficient by factor 1.22

[Shift]+[G]

decreases gamma coefficient by factor 1.03

[Ctrl+Alt]+[G]

decreases gamma coefficient by factor 1.22

Brightness

[B]

increases brightness by 1

[Ctrl]+[B]

increases brightness by 10

[Shift]+[B]

decreases brightness by 1

[Ctrl+Alt]+[B]

decreases brightness by 10

Contrast

[C]

increases contrast by factor 1.03

[Ctrl]+[C]

increases contrast by factor 1.22

[Shift]+[C]

decreases contrast by factor 1.03

[Ctrl+Alt]+[C]

decreases contrast by factor 1.22

LD compensation

Switches the compensation of limb darkening on or off. The compensation of limb darkening of a celestial body levels the photometric brightness of the image of the body. The limb darkening depends on the direction of illumination, the nature of the surface and the wavelength of the light. Following some specialities:

Sun

A compensation is possible but the best LD value is strongly depended on the used colour channel.

Mars

A compensation is possible but only for longer wavelength because only red light (and longer wavelength) shows the real surface of Mars. Shorter wavelengths show the atmosphere and the clouds, which are not correctable (as well as the polar caps).

Moon

A compensation is possible but with a very slow method [3]. Global brightness differences will be lost, extreme bright or dark areas will be cut (photometric). The result is photometric "flat" and has low contrast. Please correct the brightness level with LD value to a medium level. Brightness should be 0 and Contrast > 1.

The compensation of limb darkening is problematically or impossibly if you have used not linear brightness transformations in your image processing (not Moon).

LD value

A value of 1.0 for the Sun means the normal brightness profile for white light [2]. For all other bodies means 1.0 the reflection profile of an ideal diffuse body by LAMBERT [1]. Often you have to decrease this value to get optimal results. At Moon LD value corresponds with the global brightness level.

Examples for limb darkening compensation for Jupiter

No limb darkening compensation
         Correct limb darkening compensation with LD = 0.90 Limb darkening compensation with LD too high = 1.16

LD angle

During the limb darkening compensation a uniform correction of the brightness is made. The correction value is produced by a segment of the surface. The points of this segment - considered from the planet center - as "LD angle", are not far from the earth and the sun. If you decrease this angle, the limb and poles are excluded because they are not sufficient for the original model of diffuse reflexion. It concerns for instance the bright pole caps, clouds and processing artefacts on the limb.

Examples of the effect of different "LD angle" on limb darkening correction on Mars

Mars (without LD) with two different surface segments for the brightness correction. Red delimits a region with LD angle = 65°. This correponds to a circle of r = 0.91 planet radius. Green delimits a region with LD angle = 50°, this corresponds to a circle of r = 0.77 planet radius. [ r = sin (LD angle) ]
         Limb darkening compensation with LD angle = 65° (red region). As very bright clouds structures are displayed in the northern red region, the value of the brightness correction is considerably distorted. Limb darkening compensation with LD angle = 50° (green region). The green region is reduced because no clouds structures are displayed. The value of the brightness is now correct for the centre regions.

Other commands

Original size of image

Resets the zoom factor to 1.0 that is the image to its original size.

Original rotation of image

Resets the rotation angle to 0 and then the image to its original position

Reset

Resets all settings for Image at default values.

Outline frame

The outline frame is correctly flattened, phase-corrected and complemented by the planet's equator. Phase and equatorial inclination are calculated on the base of recording date and UT. The planetary north pole is marked by an "N", and the p. limb (planetary east) by a "P" on the outline frame. The general image orientation is shown in the upper right corner of the screen.

You may compensate a possible distortion of the image's height-width ratio by changing the Edge ratio of sensor elements (Options).

In order to fit the outline frame onto the planet's image, use the following keys:

[Arrow keys]

removes outline frame

[PageUp]

increases outline frame

[PageDown]

decreases outline frame

[N]

rotates outline frame clockwise by 1°

[P]

rotates outline frame anti-clockwise by 1°

Combining these keys with [Ctrl], the effect will be raised ten times, the combination with [Shift] decreases the effect with factor 1/10. Moreover available are:

[Backspace]

rotates outline frame by 180°

[Space]

switches outline frame visible/invisible

[Ctrl]+[Z]

Centres outline frame in measurement window

[Ctrl]+[Alt]+[L]

rotates all to the left by 90°

[Ctrl]+[Alt]+[R]

rotates all to the right by 90°

Colour value

Changes outline frame colour. Alternative [F10] or [Ctrl]+[F10].

Draw outline frame

Activates or deactivates the display of the outline frame.

Other commands

Automatic detection (only Jupiter)

WinJUPOS is able to estimate the outline frame's placement automatically [1]. You only have to the set the basic image orientation, explained in the upper right corner, via [Backspace] and Image orientation (Options) and the Edge ratio of sensor elements (enter "?" if unknown) (Options). Indeed position, size, and rotation of the outline frame are uninteresting, also the choice of brightness, contrast and gamma coefficient. After pressing [F11], and waiting a little while, the outline frame gets adjusted. Computation time depends on both the image properties and the speed of your PC. The automatic calculation of the outline frame is always related to the current view of the image!

The quality of automatic positioning resembles that of a manual adjustment but depends on various image factors. Too heavy image processing and high JPEG compression rates have negative influence, in the latter case especially for the red and blue RGB channels.

If you had set the Edge ratio of sensor elements as unknown ("?"), WinJUPOS attempts to estimate its real value. However, we recommend to avoid that option and to preselect a value that fits best (often 1:1). Then you will get more accurate results.

Check all automatic results by your very eyes and improve the outline frame's position manually if necessary!

In case the visible Jupiter outline does not correspond to the true limb, e.g. on methane-band images, the [F11] function will always fail.

Centres outline frame

Centres the outline frame in the measurements screen.

Rotate equator of outline frame horizontally

Rotates the outline frame so that the equator is set horizontally.

Rotate outline frame as if image was captured to Equatorial system

If you are sure that your image is set in equatorial system (the position in WinJUPOS has no importance), you can turn the outline frame to the correct position with that command. Be sure before with the backspace key that the north/south position is correct.

The images are set in that position when the camera is exactly oriented along the main axe of an equatorial telescope and when the image has not been rotated in WinJUPOS.

Another way to align the outline frame equatorially is to use the apparent motion of the celestial body in the field of view of a non-tracking telescope. The movement is parallel to the celestial equator.

Determine equatorial vector from video

For the determination of the equatorial vector a video of the celestial body which was taken without telescope tracking is suitable. The celestial body should cover as large a part of the field of view as possible.

The correct image of the celestial body is calculated from a video with telescope tracking. It is important that between the two videos the camera on the telescope is not rotated.

For a telescope on a paralactic mount the determined equatorial vector is valid as long as the camera is not rotated. For a telescope on an azimuthal mount the equatorial vector is valid as long as the following image field rotation remains below the detectability limit.

Define equatorial vector

As an alternative to video, a double-exposed image or two single images are also suitable. The first image shows the celestial body on one side of the image field, the second on the other side. If you have two single images, you can crossfade the second image with the button Image - Add Images (Ctrl+F7) to the first image.

After starting the Define equatorial vector command, you can click with the left mouse button on two corresponding points in the measurement screen. A red line is drawn between the two points. The starting point (marked with a small circle) defines the position of the object at time t, the end point defines the position of the same object at the later time t+i.

Delete equatorial vector

Deletes the equatorial vector which had been defined before.

Rotate outline frame to equatorial vector

Rotates the outline frame according to the equatorial vector and deletes the vector. If you are surveying images of the Earth's Moon, please make sure that the exact geografic latitude and longitude of the observation point is given.

Reset

Resets all settings of outline frame to default values.

Image and outline frame

Other commands

Centres outline frame (and image)

Puts the outline frame and the image to the centre of the screen.

Rotate equator of outline frame (and image) horizontally

Rotates the outline frame with the image to put the equator is horizontally.

(c) Grischa Hahn, Michel Jacquesson, 2020


Image measurement - Object positions

Mark the object in question by placing the cross-wires on it. Its planetographic and cartesian co-ordinates will be displayed in the upper part of the window. The origin of the cartesian x-y-co-ordinate system is identical with the centre of the full planet's ellipse, its unit being the equatorial radius. The positive x-axis points to p. direction and cuts the planet's equator on the limb. The positive y-axis points to planetary north and is identical to the projection of the planet's rotation axis as viewed from Earth.

Concerning Jupiter and Saturn, the average drifts of short lived objects in the corresponding latitude are also displayed. Compare also the drift profiles of Jupiter and Saturn.

Following keys are active when selecting the object:

[Arrow keys] | Removes cross-wires. The cross-wires speed will be increased ten times when you press [Ctrl]+[Arrow key].
[Ctrl]+[Alt]+[L] | Rotates all to the left by 90°.
[Ctrl]+[Alt]+[R] | Rotates all to the right by 90°.

Cross-wires

Type

Changes type of cross-wires.

Size (F6)

Changes size of "Small cross-wires". Alternative [F6] or [Shift]+[F6].

Changes cross-wires brightness. Alternative [F10] or [Ctrl]+[F10].

Draw cross-wires (Space)

Switches cross-wires visible/invisible. Alternative [Space].

Measurements file

Select

Selects the measuremts file to be used.

Edit (F4)

Opens the selected file and sets the cursor, if it is possible, directly to the first record at the time of the measured image.

Unassign

Unassigns the selected measurements file.

The name of the used file is displayed in bold under the button Measurements file.

Saves object position

Saves the object position at the current cross-wires position in the selected measurements file. Alternative [Enter].

Measured object positions

Display (Ctrl+Space)

Displays in the Time interval the already measured objects positions in the used measurement file. To display and delete the measured positions, you can use [Ctrl] + [Spacebar].

Measurements made on the displayed image (± 1 Minute) are labelled with a vertical and horizontal cross (+); measurements made at another time are labelled with a St Andrew's cross (x).

This function is very useful when the celestrial body has already been measured a short time before (for Jupiter, less than 2 hours) so that the objects which are visible on both images are not measured twice.

Object description

Displays the object description when you put the mouse cursor on a measured object.

In addition, when the object description is displayed, a right click opens a contextual menu which allows the edition or deletion of the corresponding record in the measurements file.

Size

Adjustment of the size of the cross used to label the precedent measurements.

Adjustment of the label colour of the precedent measurements. [F5] and [Ctrl] + [F5] can be used to adjust.

Time interval

You can define the time interval on each side of the image time with the cursor. Inside of this time interval, the already measured objects will be labelled.

(c) Grischa Hahn, Michel Jacquesson, 2009


Image measurement - Save object position

Measurements file

File name

Name of the Measurements file. You can choose the modern WinJUPOS Measurements (*.mea) or the older Measurements of PC-JUPOS (*.mes) resp. PC-SAPOS (*.sme). In the older data formats you can't use Object-Id, Object description, Image info.

If you want to measure Jupiter images of the New Horizons probe, you have to store them in proprietary WinJUPOS Measurement files (with extension .mea).

Observer

Name of observer saved to the Measurements file. In WinJUPOS measurement files (*.mea) this name will be saved in the file itself, in older PC-JUPOS resp. PC-SAPOS measurement files the name will be saved in the associated List of Observers (*.beo). Please do not mix up with the Observer name in Image definition. This name is only extracted from the filename of the image to be measured and will not be used furthermore.

Object

Code

Jupiter / Saturn

Region

Jupiter / Saturn

When opening the window, the region code has already a value which, like the rotation system, corresponds to the planetographic latitude. The Code takes into account of special objects.

Id

User defined text/code of the object. In the module Data Selection you can use it for searching to special objects. (english, ASCII)

Description

Information to look and behaviour of the object. (english, ASCII)

Image measurement

Image info

Information to observational conditions.

Measurer code

Three digits code for measurer name (ASCII).

Channel

Four digits code of used channel of observation (ASCII).

Save (Shift + Enter)

Saves the object position to the specified measurement file. It will be checked if there is a similar object at the same time in the file - and in this case you will asked if you want to overwrite the older measurement or simply add the new one to the file.

Ephemerides (F8)

Starts the Ephemeredes module to Date and UT.

Close (ESC)

Closes the window and saves all changes.

(c) Grischa Hahn, Michel Jacquesson, 2007


Image measurement - Object code Jupiter (JUPOS)

You have to classify the object according to the following schema:
1st character | W for a bright object
 | D for a dark object
 | R for a red object
 | G for a green object
 | B for a blue object
 | Y for a yellow object
 | C for a cyan object
 | M for a magenta object
2nd character | P if the preceding end
 | C centre
 | F following end of the object was observed
 | S south edge of object (only Measurements)
 | N north edge of object (only Measurements)
3rd character | (in case this information is available)
 | 1 if the object was easy
 | 2 if the object was moderate
 | 3 if the object was difficult to see
4th-9th character | Object code

Object code - bright objects

SPTR | Small bright spot surrounded by a dark halo.
SPOT | Bright spot being not too extended or oblong.
OVAL | Large oval-shaped area, brighter than its surroundings and well defined.
BAY | Large and usually half-oval-shaped cut-out on the edge of a belt.
NICK | Small semicircle-shaped cut-out on the edge of a belt, frequently brighter than the adjoining zone.
SECT | Brighter section of a belt or zone.
GAP | Fairly extended, weakened or absent part of a belt.
RIFT | Bright line crossing a broad belt, usually at an angle of 45°..60°.
AREA | Extended bright and irregularly bordered area.
STRK | Very oblong, streak-shaped, bright object.

Object code - dark objects

SDER | Small dark spot surrounded by a bright halo.
SPOT | Dark spot being not too extended or oblong.
BAR | Dark oblong object.
FEST | Dark filament or festoon that passes through a zone. One end of the filament or both ends of the festoon may emerge from dark belt condensations.
PROJ | Dark projection on the edge of a belt. There are different shapes from rounded humps to tapering objects.
SECT | Darker section of a belt or zone.
VEIL | Extended dark shading in a zone or in polar regions.
DIST | Dark integral- or bridge-like structure which as a rule appears during a SEB revival.
COL | Column-like dark object in a zone, perpendicular or slightly inclined to it.
STRK | Very oblong, streak-shaped dark object.

Use special codes for the following objects:

RS | Great Red Spot
RSH | SEB hollow north of the Great Red Spot
WOS-FA, WOS-BC, WOS-DE | Long-lived White Ovals FA, BC and DE. Use WOS-BC also for Oval BE from 1998 to 2000, and Oval BA thereafter.
STRD | Classic STrZ disturbance
STZB | Additional belt in the STZ
STRB | Additional belt in the STrZ
NTRB | Additional belt in the NTrZ
NTZB | Additional belt in the NTZ
ZONE | Bright zone, only to be used for latitude measurements in special cases. Please note down the name of the zone in the field "ID" (names convention see Region code). This object code is only available for Measurements.
BELT | Dark belt, only to be used for latitude measurements in special cases. Please note down the name of the belt in the field "ID" (names convention see Region code). This object code is only available for Measurements.
SHAD | Shadow of a Jovian satellite
MOON | Disc of a Jovian satellite
IMPACT | Dark structures immediately after the SL-9 impact

(c) Grischa Hahn, 2013


Image measurement - Object code Saturn (SAPOS)

You have to classify the object according to the following schema:

1st character | W for a bright object
 | D for a dark object
 | R for a red object
 | G for a green object
 | B for a blue object
 | Y for a yellow object
 | C for a cyan object
 | M for a magenta object
2nd character | P if the preceding end
 | C centre
 | F following end of the object was observed
 | S south edge of object (only Measurements)
 | N north edge of object (only Measurements)
3rd character | (in case this information is available)
 | 1 if the object was easy
 | 2 if the object was moderate
 | 3 if the object was difficult to see
4th-9th character | Object code

Object code - bright objects

SPTR | Small bright spot surrounded by a dark halo.
SPOT | Bright spot being not too extended or oblong.
OVAL | Large oval-shaped area, brighter than its surroundings and well defined.
BAY | Large and usually half-oval-shaped cut-out on the edge of a belt.
NICK | Small semicircle-shaped cut-out on the edge of a belt, frequently brighter than the adjoining zone.
SECT | Brighter section of a belt or zone.
GAP | Fairly extended, weakened or absent part of a belt.
RIFT | Bright line crossing a broad belt, usually at an angle of 45°..60°.
AREA | Extended bright and irregularly bordered area.
STRK | Very oblong, streak-shaped, bright object.

Object code - dark objects

SDER | Small dark spot surrounded by a bright halo.
SPOT | Dark spot being not too extended or oblong.
BAR | Dark oblong object.
FEST | Dark filament or festoon that passes through a zone. One end of the filament or both ends of the festoon may emerge from dark belt condensations.
PROJ | Dark projection on the edge of a belt. There are different shapes from rounded humps to tapering objects.
SECT | Darker section of a belt or zone.
VEIL | Extended dark shading in a zone or in polar regions.
COL | Column-like dark object in a zone, perpendicular or slightly inclined to it.
STRK | Very oblong, streak-shaped dark object.

Use special codes for the following objects:

SHAD | Shadow of a satellite
MOON | Disc of a satellite
ZONE | Bright zone, only to be used for latitude measurements in special cases. Please note down the name of the zone in the field "ID" (names convention see Region code). This object code is only available for Measurements.
BELT | Dark belt, only to be used for latitude measurements in special cases. Please note down the name of the belt in the field "ID" (names convention see Region code). This object code is only available for Measurements.

(c) Grischa Hahn, 2013


Image measurement - Region code Jupiter (JUPOS)

In order to classify the latitude of an object a two-figure code has to be employed. First comes a letter, second a numeral.

 | 1 | 2 | 3 | 4 | 5
A | SPR | SSSTZ | SSSTB |  |
B | SSTZ | SSTB *) | SSTBn |  |
C | STZ | STB | WOS-FA | WOS-BC | WOS-DE
D | STBn |  |  |  |
E | STrZ | SEB(S) | RS | RSH |
F | SEBs |  |  |  |
G | SEB(C) |  |  |  |
J | SEB(N) | EZ(S) |  |  |
K | EB | EZ(C) |  |  |
L | EZ(N) | NEB(S) |  |  |
M | NEB(C) |  |  |  |
N | NEB(N) | NTrZ |  |  |
P | NTBs |  |  |  |
R | NTB | NTZ |  |  |
S | NNTBs |  |  |  |
T | NNTB | NNTZ |  |  |
U | NNNTB | NNNTZ |  |  |
V | NNNNTB | NNNNTZ | NPR |  |

*) True SSTB

It means:

RS | Great Red Spot (GRS)
RSH | SEB hollow of the Great Red Spot
X(N), (C), (S) | north, central or south component of belt or zone X
Xn, s | north, south edge of belt X

In the following the currents and jetstreams in the Jovian atmosphere, their jovigraphic latitudes, typical drifts and attached JUPOS region codes are listed. Currents are terminated by a "C", jetstreams occur on belt edges. Currents marked by an asterisk were only observed by the New Horizons spacecrafts as yet.

Current/ jetstream | Jovigraphic latitude [°] | Code | Drift versus [°/30d] | System
SPC | -90..-54 | A |  | 2
* S6TBn | -66 | A | -141 | 2
* S5TBn | -61 | A | -57 | 2
* S4TBn | -53 | A | -75 | 2
S3TC | -52..-45 | A | -15..0.0 | 2
* S3TBn | -43 | A | -105 | 2
SSTC | -42..-38 | B | -33..-24 | 2
SSTBn | -37..-36 | B | -90..-78 | 2
STC | -36..-29 | C | -21..-9 | 2
* STBs | -32 | C | +27 | 2
STBn | -29..-27 | D | -150..-60 | 2
STrC | -26..-13 | E | -6..+6 | 2
SEBs | -20 | F | +60..+150 | 2
SIC | -16..-11 | G | -150..-30 | 2
SEC | -10..-5 | J | -111..+75 | 1
CEC | -5..+5 | K | +3..+30 | 1
NEC | +5...+10 | L | -6..+6 | 1
NIC | +10..+16 | M | -159..-60 | 2
* NEBn | +17 | N | +30 | 2
NTrC | +14..+23 | N | -15..-6 | 2
NTBs | +24 | P | -171..+60 | 1
* NTBn | +31..+32 | R | +60 | 2
NTC | +25..+34 | R | +12..+21 | 2
NNTBs | +35..+36 | S | -96..-45 | 2
* NNTBn | +39..+40 | T | +27 | 2
NNTC | +37..+42 | T | -3..+3 | 2
* N3TBs | +43 | U | -45 | 2
N3TC | +44..+47 | U | -21..-9 | 2
* N4TBs | +47 | V | -39 | 2
N4TC | +49..+55 | V | -3..+3 | 2
* N5TBs | +56 | V | -60 | 2
* N6TBs | +64 | V | -63 | 2
* N7TBs | +69 | V | -93 | 2
NPC | +58..+90 | V |  | 2

See also drift profile of Jupiter used in WinJUPOS.
(c) Grischa Hahn, 2009


Image measurement - Region code Saturn (SAPOS)

In order to classify the latitude of an object a two-figure code has to be employed. First comes a letter, second a numeral.

 | 1 | 2
A | SPR |
B | SSTZ | SSTB
C | STZ | STB
E | STrZ | SEB(S)
G | SEB(C) |
J | SEB(N) | EZ(S)
K | EB | EZ(C)
L | EZ(N) | NEB(S)
M | NEB(C) |
N | NEB(N) | NTrZ
R | NTB | NTZ
T | NNTB | NNTZ
V | NPR |

It means:

X(N), (C), (S) | north, central or south component of belt or zone X
Xn, s | north, south edge of belt X

Consequently, there is a relation between the used region codes and their positions in latitude.

Belt/Zone | planetograph. latitude [°] | Code | System
SPR | -90..-59 | A1 | 3
SSTZ | -59..-54 | B1 | 3
SSTB | -54..-46 | B2 | 3
STZ | -46..-36 | C1 | 3
STB | -36..-29 | C2 | 3
STrZ | -29..-28 | E1 | 3
SEB(S) | -28..-19 | E2 | 3
SEB(C) | -19..-18 | G1 | 3
SEB(N) | -18..-10 | J1 | 1
EZ(S) | -10..-4 | J2 | 1
EB | -4..+4 | K1 | 1
EZ(C) | -4..+4 | K2 | 1
EZ(N) | +4...+10 | L1 | 1
NEB(S) | +10..+18 | L2 | 1
NEB(Z) | +18..+19 | M1 | 3
NEB(N) | +19..+28 | N1 | 3
NTrZ | +28..+30 | N2 | 3
NTB | +30..+39 | R1 | 3
NTZ | +39..+45 | R2 | 3
NNTB | +45..+55 | T1 | 3
NNTZ | +55..+60 | T2 | 3
NPR | +60..+90 | V1 | 3

See also drift profile of Saturn used in WinJUPOS.
(c) Grischa Hahn, 2009


Image measurement - Options

Image orientation

Normal image for image orientations SR and NR, Mirror-inverted image for image orientations SV and NV.

Sensor matrix

Distance ratio (x/y) of sensor elements

The sensor elements of some CCD matrices (cameras) have different distances in height and width. An example: The distances of sensor elements of a CCD-camera are 10µm in width and 10.5µm in height. A square with an edge length of 1 meter will be projected onto the sensor matrix with 100 pixels in width and 95 pixels in height. The image of the square on a normal Monitor is pressed. To compensate this effect set a value of 0.95 (= distance in width / distance in height of sensor elements) for Distance ratio (x/y) of sensor elements.

Unknown

If you do not know this value, select "Unknown". A value of 1.0 is assumed. An optimum value will be computed when the Automatic fitting of outline frame runs (only Jupiter).

Defined

Input the known value in the mask below.

Global settings

Quick move (Global setting)

If you have a high speed computer with very much main-storage capacity (RAM) you can activate Quick move. This performs the image operations for the whole image and not only for the current view.

High image quality (Global setting)

If you have a high speed computer you can activate this option to calculate a zoomed or rotated image with better quality.

(c) Grischa Hahn, 2013


Image measurements - Miscellanous

You will find here a set of additional fonctions more or less useful for image measurement.

Distance

Measure distance

Click with the left mouse button on two points of the celestrial body. Then the distance in kilometer is displayed under the button. For the computing, a line in magenta joining the two points is projected on the surface of the celestrial body.

Map computation

This function lets you to compute a map from the displayed image without using the module "map computation" This may be useful to illustrate the evolution of particular objects or regions.

Template settings

Choose with the button [image] a configuration file for computing the map. In this file, the image settings will be ignored et replaced by those of the displayed image. If a path and a file name are entered, this map will be saved in this subdirectory or else in the subdirectory of the displayed image. All other settings are taken in account.

The used template settings are global and then independent of the image measurement settings.

With the button [image] you can display the settings of the map computing, edit them and save them again.

Compile map

Start the map computing. When it is finished, the map is displayed. Its name is made by ["Name of the measured image]_[Name of the settings file].[Type of the measured image]".

The map contains always the whole surface or the half of the celestrial body. If you want to get only parts, we recommand to use the "batch conversion" of "IrfanView" or others.

Create transmission package

Creates a ZIP archive with the loaded image and its map projection in FITS format as well as the corresponding measurement settings (*.ims) and map projection data (*.gts). In addition, the image and map parameters are stored in XML files.

Create settings files (*.ims) for an image stack

Transfers the current measurement settings to a set of images and creates associated setting files (*.ims). The images must have their mean time of capture encoded in the file name (see Image definition) or be available as JPEG files with GPS tags.

The position of the celestial body may shift on the images, but its size and orientation must be the same.

(c) Grischa Hahn, Michel Jacquesson, 2019


Image measurement - Literature

[1] Grischa Hahn: "Automatische Auswertung von Zeichnungen, photographischen und CCD-Aufnahmen des Planeten Jupiter", Diplomarbeit, Technische Universität Dresden, Fakultät Informatik, Lehrstuhl für Bildverarbeitung und Künstliche Intelligenz, 2000

(c) Grischa Hahn, 2013


Selection - Introduction

The module Selection creates a selection file with CM transits or measurements which are selected according to different criteria. These selection files can be used in the modules Drift charts, Average positions or Longitudinal shifts.

Files

Chose the CM transits or measurements files to be used for the selection. Corrections in longitude for each object position can be made, in order to eliminate systematic observer errors.

Objects

Chose the object filters for the recordings to be selected. Filter criteria are position, brightness, object code. You can also compute automatically the average position of P-F couples of one object and add this position to the selection file.

Other filters

Chose other filters for the selection. Filter criteria are colour channel and measurer code.

Modified rotational system

Define virtually a modified rotational system. The longitude interval in Filters is always related to this modified rotational system. If L(T0) and Drift are set to zero, the modified rotational system corresponds to the reference system.

Why a modified rotational system?

In your measurements file, for several months, you have followed a small dark spot (D SPOT) which shows a high drift against the system 2, about -2.2°/d. In the observation time span, it has moved from L2=278° to L2=13°. As in your measurements file you have a lot of other object D SPOT in the same longitude area, the selection of this small dark spot is completely impossible only from a longitude interval. You must work with a modified rotational system which shows the longitude L' of this small dark spot almost constant. In our example, we determine following parameters for the modified rotational system:

Reference system: 2
       L(T0): 110°
       Drift: -2.200°/d
 Reference date: 2006-02-15, 12h UT

The modified longitude (L') of the small dark spot is then between 22° and 27°. The defined longitude interval can be for example [20°...30°].

opens a submenu with commands to use the drift data. You can copy a modified rotational system as a drift recording in the clipboard or paste a drift recording from the clipboard.

Filters

Set the limits of the intervals of time, longitude and latitude. The options min and max in the date interval means that there is no top nor bottom limits. The latitude interval is related to the latitude system used in Ephemerides module.

To set From date and To date on the limits of a planetary apparition, that is on:

From date | = Beginning of the apparition
To date | = End of the apparition

you can use following special keys:

[Page Up] | one apparition later
[Ctrl]+[page Up] | ten apparitions later
[Page Down] | one apparition before
[Ctrl]+ [Page Down] | ten apparitions before

Other parameters

Sorting

You can determine eventually how the recordings must be sorted.

Phase correction

The longitudes can be corrected, related to the actual phase angle (Jupiter only).

Nil-error bars

If the object position has no indication of error, the nil-error bar has a standard value. The error value of an object position, as it introduces a weighting, has an influence on the error, average and drift computations. Error values are displayed in the graph.

Comments

You can add a personal text for the more particular description of the selection file. This text is displayed in the legend of drift chart.

Selection file

Enter the path and name of the selection file to be created.

Choice of the selection file

Display of the selection file (F4)

Run the selection (F12)

Runs the selection. After a successful computation, all the settings of the selection are saved in a documentation file (simple text format) related to the selection file. Under WinJUPOS, this file has the extension "wsd". It is placed in the same directory as the selection file with the same name. Under PC-JUPOS and PC-SAPOS, the extension is ""doc" and it is placed in the subdirectory "COMMENTS".

Settings

Reset

After a confirmation question, all settings are reinitialised.

Save/Load

Saves or loads the actual settings of the selection. The name of the used settings file (*.ses) is displayed in the header of the selection window.

(c) Grischa Hahn, Michel Jacquesson 2008


Selection - Data files

Chose the CM transits and measurements files to be used for the selection. In each file, you can enter longitude corrections.

CM transists files

Choice of the directory of the CM transits.

Measurements files

Choice of the directory of the measurements files.

All the files of these directories are displayed in a file list. Measurements are reddish and CM transits are greenish.

+

The file is used (mark) or not. To modify the status, double click with the mouse in the little square or strike the [Space bar], when the selection bar is on the file.

SR, SV, NR, NV, **

If a object position is selected, you can correct errors of the particular observer and also shift the longitude value. This shift happens almost exclusively in the CM transits because of the systematic error of each visual observer when he estimates the time of the CM transit. This error is related to the image orientation. You can determine this personal error in the module Longitudinal shifts.

Observer (F3)

For a rapid selection of a particular observer (=file name), you can write in the field Observer the first charachters of his name. The selection bar is updated automatically. When you have found the observer, you leave the field with [Enter] - the file list is activated again.

Context menu of the file list (right button of the mouse):

Open file

Opens the actual objects positions file.

File info (Ctrl-F1)

Displays the file-info of the actual objects positions file.

(De-) Activate file

(De-) Activates the actual objects positions file.

(De-) Activate all files (F10)

(De-) Activates all objects positions files.

(De-) Activate cell SR/SV/NR/NV

(De-) Activates all CM transits with the orientation SR in the corresponding file. If the cell is activated, you can enter a longitude shift value in degrees.

(De-) Activate cell *

(De-) Activates all CM transits with the orientation IR or all measures of the corresponding file. If the cell is activated, you can enter a longitude shift value in degrees.

(De-) Activate column SR/SV/NR/NV

(De-) Activates all CM transits with the orientation SR in all files.

(De-) Activate column *

(De-) Activates all CM transits with the orientation IR or all measurements in all files.

(De-) Activate all columns

(De-) Activates all.

Save longitudinal shifts (F2)

Saves all longitudinal shifts (different from 0.0°) in a longitudinal shifts file.

Load longitudinal shifts (F4)

You can load a longitudinal shifts file which has been computed for instance with the module Longitudinal shifts. This longitudinal shifts file contains the longitudinal shifts from all observers selected in the longitudinal shift computation.

Reset all longitudinal shifts

All longitudinal shifts are set back to 0.

Global longitudinal shift (additive)

Addition of a particular longitudinal drift to all present shift values.

Other funcions of certain keys in the file list:

[Insert] | File selected - The selection bar moves automatically to the file below
[Delete] | File deselected - The selection bar moves automatically to the file below
[Space bar] | File selected/deselected
[Ctrl]+[Enter] | The button OKis focussed

(c) Grischa Hahn, Michel jacquesson 2008


Selection - Objects to be selected

Objects

Enter the objects and regions to be selected, using the objects and region codes.

Object code

Jupiter / Saturn

Region code

Jupiter / Saturn

A particular case is the object WOS, which represents the three long living WOS in STB. Each line is linked with "and", "except" is not posible. A blank represents "all possibilities". Some examples (the underscore "_" means a blank):

__ ______ __   ... all objects in all regions
_C WOS___ __   | ... all middles of the three long living WOS in STB
DP RS____ __   | ... all p. ends of a dark GRS
DP ______ E3   | ... the same case
WC ______ N2   | ... all middles of bright objects in the NTrZ
DF SECT__ C_   | ... all f. ends of dark sections in STB and STZ

If you want to select all objects in all regions, you must leave blank the ten lines.

If you enter a character set in the fourth column, only the recordings corresponding to this object-ID will be selected (in WinJUPOS CM transits and measurements only).

Including MOON + SHAD

Satellites and their shadows are apart in the objects positions because they are no atmosphere details. They are used to test the ephemerides and the determination of systematic observer errors.

If this option is activated and if the MOON and SHAD are not excluded from the objects list, these data will be recorded in the selection file.

Computation of object positions

If the menu option Computation of object positions is activated, corresponding couples of P and F positions are searched after the "usual" selection. The program computes from these couples new C values and creates with them a new selection file.

The couples and triplets must correspond to the following criteria:

  1. same object and same region,
  2. same observer,
  3. observed during the same Jupiter rotation,
  4. same image orientation and no "IR"
  5. the longitude distance between P and F does not exceed the value of Maximum longitude distance of a P-F / N-S pair.

The new C-position is computed from the arithmetic middle of P and F. The triplet P-C-F is computed as following: C(new) = (P+2*C+F)/4.

With Computation of object positions, you determine if couples and/or triplets should be searched and if a C observation linked with couples should exist. Transfer C determines if the C observations should be recorded in the final selection file or not. If Weighting is activated, the new value of C in triplets is computed with a weighting, only if an error value "+/-" exists in the three original observations.

If the Computation of object positions is activated, the selection file is always sorted chronologically. The fields "+/-", "Magnification" and "Remarks" in the new created C-recordings are left blank. "Instrument" is fillrd with folIowing codes:

p_f_   | ... from a P-F couple
pcf_   | ... from a P-C-F triplet, no weighting
pcfw   | ... from a P-C-F- triplet with weighting

Attention:

  1. The Computation of object positions is valid only if Object is not restricted concerning the object positions to be selected, that is the second column of Object must be left blank.
  2. In the measurements, only one position P,(C),F in one Jupiter rotation should exist concerning the object. In case of several couples or triplets during the same observation night, the observation times must not overlap. Other situations could lead to uncontrolled results!

Reset

Sets back the settings to "All Objects". MOON and SHAD are exculded. The Computation of object positions is desactivated.

(c) Grischa Hahn, Michel Jacquesson 2019


Selection - Additional filters

Channels

If you want to select observations in a particular channel, enter the corresponding channel code(s). With the options "Only these channels" or "Exclude these channels", the channels list can be interpreted positively or negatively. If the list is empty, no observation is excluded.

Code

If you want to select observations which have been measured by a particular measurer, enter the observer code.

If the measurer code is empty, no observation is excluded.

If the observer code is filled with three underscores ("___"), only observations WITHOUT measurer code are selected.

(c) Grischa Hahn, Michel Jacquesson 2008


Selection - Sorting criteria

Select up to three sorting criteria. Criterion no. 1 has highest priority, and no. 3 the lowest. Numbers will be sorted ascending, and non-numeric words (character strings) alphabetically.

Sorting criterion: Latitude / Region

If you have picked the Latitude / Region criterion, and a record does not contain a latitude value (as true for all Central Meridian transits but also some Measurements), a representative jov. latitude will be derived from the specified Region.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Drift computation - Drift conversion

The module Drift Conversion lets you to convert longitudinal drifts of an object to and from sidereal rotation time and metric velocity. Other needed data are the object latitude and the used longitude system.

(c) Grischa Hahn, Michel Jacquesson 2007


Drift computation - Drift computation with marked records

The drift computation using a choice of selected data records lets you to compute the linear drift of a particular object in longitude and latitude. Of course, this computation has a meaning only if all selected data records are related to one object.

An average linear drift in longitude (L) and latitude (B/B") is expressed by the following formulas:

Lx = Lx(T0) + Drift_Lx * (T - T0)
B  = B (T0) + Drift_B  * (T - T0)
B" = B"(T0) + Drift_B" * (T - T0)

Lx is the average Longitude in Reference system x. B is the average planetocentric latitude, B" the average planetographic latitude. T is the observation time expressed either in usual date or in Julian date. T0 is the Reference Date.

Example:

For instance, you have select the following object positions:

  Record  Object     R   Date        UT          L2     B"
----------------------------------------------------------
       1  WC3WOS-BC  C4  1995-04-10  04:10.0   33,8  -35,8
       3  WC1WOS-BC  C4  1995-05-26  00:46.0   18,3  -33,8
       5  WC1WOS-BC  C4  1995-06-14  20:54.0   10,6  -32,7
       6  WC1WOS-BC  C4  1995-06-19  20:27.0    8,0  -33,4
       7  WC2WOS-BC  C4  1995-07-20  20:02.0  353,4  -29,3
       9  WC1WOS-BC  C4  1995-08-13  19:43.0  347,5  -35,2
      10  WC1WOS-BC  C4  1996-06-28  02:19.0  215,1  -33,6
----------------------------------------------------------

Then, if you call the module Drift computation in the contextual menu or with Selected records and if you set trend drift to -0.4°/d, you get the following results:

 L1   =    3,9°  +  7,2241°/d * (T - 1995 Aug 10,5)
 L2   =  346,4°  -  0,4059°/d * (T - 1995 Aug 10,5)
 L3   =  160,1°  -  0,1393°/d * (T - 1995 Aug 10,5)
      ±    0,6°  ±  0,0043°/d

 B"   =  -33,4°  +  0,0010°/d * (T - 1995 Aug 10,5)
      ±    0,9°  ±  0,0063°/d

 n(L) =  7       (1995 Apr 10,2 ... 1996 Jun 28,1)
 n(B")=  7

 VL1  =  -88,800 m/s
 VL2  =    4,990 m/s
 VL3  =    1,712 m/s
      ±    0,070 m/s

 VB"  =   -0,014 m/s
      ±    0,092 m/s

 tSid =  000 09:55:23,969  ±  000 00:00:00,177
        [ddd hh:mm:ss,sss]   [ddd hh:mm:ss,sss]

L1..L3 are the average longitudes of the object in the rotation systems 1..3. B" is the average planetographic latitude, n(L) and n(B") the number of used object positions in longitude and latitude, VL1..VL3 the metric velocities against the rotation systems 1..3 and tSid the absolute rotation time of the object.

Error values (±):

Err(Lx) = Mean error of absolute term Lx
Err(Drift_Lx) = Mean error of drift coefficient Drift_Lx

The mean error of a single measurement, or standard deviation s, is approximately:

s = Err(Lx) * SQRT(n)

Reference system

Chose the reference system (rotation system) used to enter the trend drift.

Trend drift

Unfortunately, the longitudes of an object go through the limit 0°/360° in the two directions. During the drift computation, In order to know if the longitude must be corrected of +360° or -360°, a approach value Trend drift of the object must be entered. If this value is incorrect, the computed drift is completely false. The indication of a such incorrect result is for instance the great value of the error. That is why, you must always check the result to see if they are plausible !

Reference date

The standard value of the reference date is the average time value of the selected data records. It is the date when the object is placed at the average Longitude Lx(T0)in the selected reference system X.

Julian Date

Alternative for Reference date.

Copy

You can copy the resulting drift data in the Clipboard. This drift data record can be used later for instance for the definition of a Modified rotational system or these data can be used to determine the parameters of an auxiliary line in the drift chart, which should display the average linear drift of the object.

WC WOS-BC C4 : L2 = 346,6° - 0,4058°/d * (T - 1995 Aug 10.5)
                    [1995 Apr 10.2 ... 1996 Jun 28.1]
               B" = -33,4° +  0,0010°/d * ( T - 1995 Aug 10.5 )
                    [1995 Apr 10.2 ... 1996 Jun 28.1]

Modified rotational system

Reset

The active Modified rotational system in the lists display of objects positions is reinitialised. All the displayed longitudes correspond to the standard rotation systems.

Apply

When you apply the computed drift, the longitudes of the object positions list are displayed in the following Modified rotational system (L'):

L' = L2 - (346,6° - 0,4058°/d * (T - 1995 Aug 10.5))

----------------------------------------------------------
  Record  Object     R   Date        UT          L'     B"
----------------------------------------------------------
       1  WC3WOS-BC  C4  1995-04-10  04:10.0  357,6  -35,8
       3  WC1WOS-BC  C4  1995-05-26  00:46.0    0,8  -33,8
       5  WC1WOS-BC  C4  1995-06-14  20:54.0    1,1  -32,7
       6  WC1WOS-BC  C4  1995-06-19  20:27.0    0,5  -33,4
       7  WC2WOS-BC  C4  1995-07-20  20:02.0  358,4  -29,3
       9  WC1WOS-BC  C4  1995-08-13  19:43.0    2,3  -35,2
      10  WC1WOS-BC  C4  1996-06-28  02:19.0  359,4  -33,6

----------------------------------------------------------

In the Modified rotational system the object is almost stationary.

(c) Grischa Hahn, Michel Jacquesson 2011


Positional averages - Introduction

The module Positional averages allows you to compute average positions from a set of positions of one object. The resulting Positional averages file can be used in the module Drift charts to be displayed.

Data files

Chose the selection files to be used to compute average positions. This action is valuable only when you chose positions of the same object, either only P- or F-ends either only the middle of an object.

Trend drift

Computation of average positions needs to enter the rotational system and an approximate drift value of the object. If the approximate drift value is too uncertain, a error message will be displayed.

opens a submenu with different commands to use the data files. Drift values can be copy to or paste from the Clipboard.

Filters

Enter the time limits. Min and max options means that there is no bottom and top time limits.

To set the apparitions limits in the From date and To date boxes (only Mars, Jupiter and Saturn), press the following keys:

From date | = begin of an apparition
To date | = end of an apparition

following special keys can also be used:

[PgUp] | following apparition
[Ctrl]+[PgUp] | ten apparitions later
[PgDn] | preceding apparition
[Ctrl]+ [PgDn] | ten apparitions earlier

Computation of Positional averages

Running means

Lag, Interval

The average positions are computed in fixed time spans. Lag defines the number of days between the successive middles of this time span. The size of a time Lag is 2 * Interval days.

The Interval must be therefore at least Lag / 2. If not, gaps would be created.

You can define overlapping time spans with intervals larger than Lag / 2.

Average of all records

One average position is computed with all object positions in the time span defined by From date...To date.

Apparition averages (only Mars, Jupiter, Saturn)

One average position is computed for each apparition (conjunction...conjunction) of the reference planet. The middle of the time span is therefore the date of the opposition.

Equidistancy

Equidistancy forces the time of an average position to the middle of the time span. All average positions have therefore the same lag.

If the equidistancy function is deactivated, the times of the average positions correspond to the average value of all times of the used object positions. In consequence, all computed average positions have irregular time positions.

Weighting

Computation of the average position taking account of error estimations in longitude and latitude.

If the weighting function is deactivated, all positional observations have an equal weight.

Create Single drift data file with the same file name

This option allows the creation of a single drift file. For each data point of the average position file, it contains the related drifts in longitude and latitude from the precedent and following average position. For some objects, these data show a relation between the latitude and the longitudinal drift (see longitudinal drift chart).

Comment

More precise descriptions of the average positions file can be entered in the comment field with a personal text. This text will be displayed on the drift chart.

Positional averages file

Enter the path and name of the Positional averages file to be created.

Choose Positional averages file

Show Positional averages file (F4)

Start computation of Positional averages (F12)

Runs the computation of the average positions. After a successful computation, all the parameters are recorded in a documentation file (simple text file) connected with the average positions file. Under WinJUPOS, the extension of that file is "wad". It is located in the same directory as the average positions file and has the same name. Under PC-JUPOS ans PC-SAPOS, the extension is "doc" and the documentation file is located in the subdirectory "COMMENTS".

Parameters

Reset

After a confirmation request, all parameters of the average positions computation are reinitialized.

Save/Load

Saves and loads the active parameters of the Positional averages computation. The used parameters file name (*.avs) is displayed in the header of the window.

(c) Grischa Hahn, Michel Jacquesson, 2008


Positional averages - Data files

Choice of the selection files used for the average positions computation.

Selection files

Choice of the selection files directory.

All the files of the directory are displayed in a files list.

+

The file is selected or not (mark). To change the status, double-click with the mouse in the small square or strike the [Spacebar] key when the line containing the file name is selected.

File (F3)

For a quick choice of a file, write the fist characters of its name. The selection bar comes automatically on the line containing the file name. If the desired file is found, leave the input field with [Enter], the files list with the selection bar is active again.

Context menu of the files list (right mouse button):

Open file

Opens the selected file.

File Info (Ctrl-F1)

Displays the file info of the selected object positions file.

(De-) Activate file

(De-)activates the selected object positions file.

(De-) Activate all files (F10)

(De-)activates all object positions files.

Other active keys of files list:

[Ins] | Selects file - the selection bar drops automatically to the following line
[Del] | Deselects file - the selection bar drops automatically to the following line
[Space] | Selects/Deselects file
[Ctrl]+[Enter] | OK button gets the input focus

(c) Grischa Hahn, Michel Jacquesson, 2008


Longitudinal shifts - Introduction

The module Longitudinal shifts computes systematic errors of observers of Central Meridian Transits in different image orientations (Hahn, Grischa: "Systematische Fehler bei der Schätzung von Zentralmeridianpassagen auf Jupiter", Mitteilungen für Planetenbeobachter, ISSN 0175-6729, 15, 1-12 (1991)).

It needs a great number of positional observations of one object (for instance of the GRS on Jupiter) and also observations of different observers which add up in the time. The resulting files of longitudinal shifts can then be used in the module Selection to correct the longitude values.

Files

Chose the selection files used to compute the longitudinal shifts. These files must contain the positions of only one object. Of course, either only P or F ends or only the centre (C) of an object.

Trend Drift

To compute longitudinal shifts, you must enter a system (Reference System) and a estimation of the Drift of the object in this system. If the trend Drift is too uncertain, an error message is displayed.

opens a submenu with commands to run the drift data. You can paste drift values from the clipboard.

Filters

Enter the time limits to be used. The options min and max in the time interval mean that there is no top and bottom limits.

To set From Date and To Date to the limits of an planet apparition ( Mars, Jupiter, Saturn only), that is:

From Date | = Beginning of the apparition
To Date | = End of the apparition

use following special keys:

[Page Up] | One apparition later
[Ctrl]+[Page Up] | Ten apparitions later
[Page Down] | one apparition before
[Ctrl]+ [Page Down] | ten apparitions before

Standard class

A class of observations is made by an observer and one particular image orientation by the central meridian transit or all his processed measurements.

The standard class should be a very confident class with many observations which are regularly placed in time. Measurements are the best example because they suffer no systematic errors while it is the case with the CMT.

All measurements

Includes all measurements as a standard class.

Observer Code

Abbreviation of the data file of central meridian transits or measurements, limited to 16 characters.

Image Orientation

In the case of central meridian transits, a distinction must be made between SR, SV, NR, NV und IR (see Recording and Editing of Central meridian Transits). If the image orientation is unknown, IR will be recorded.

There is no image orientation in the measurements. All measurements are included as a single class.

Longitudinal shifts computation

Interval

Interval is half the length of the time intervals measured in days. Its double value should correspond to the greatest possible time range the object's longitude can be regarded as practically constant. On the other hand, it must not be too small: Throughout a Jupiter apparition many intervals should contain multiple observations to enable the computation of means. Note the following relation:

Lag/2 <= Interval <= 40 d.

If Interval becomes greater than Lag/2, running means will be computed.

Lag

Lag is the temporal distance of the interval centres, measured in days. The lower Lag with constant Interval, the more accurate the computation will be. Note the following relation:

4 d <= Lag <= 40 d.

Sampling distance

Sampling distance influences the accuracy of numerical computation. It must lie between 0.01° and 0.5°. A recommendable value is 0.1°. Smaller values will produce more precise results, but cause longer computation times. A smaller Sampling distance of 0.01° or so could be necessary, if many classes are to be processed with the Cumulative method.

Maximum shift

Maximum shift delimits the longitude range in which the systematic errors will be searched only. It must be greater than the greatest possible error value, otherwise the computation will produce nonsensical results. Actually a higher Max. error is "more sure" but increases computation time. Max. error must lie between 1° and 15°. 10° seem to be recommendable in most cases.

Weighting

Weighting defines whether computation will be performed with consideration of the longitudinal errors estimated or measured by the observers (Weighting = yes), or not (i.e. all observations will be considered as equally precise).

Cumulative

Cumulative = no causes error computation of all classes relative to the Standard class only. On the contrary, the Cumulative option effects computations on the base of all classes that were analyzed before (in the first step, relative to the Standard class only). Presuming a good temporal distribution of the observations, the Cumulative variant should deliver more trustworthy results.

3 phases

If this option is switched to "yes", after the normal computation two further analyses will take place with shifts of the intervals' centres by -2/3 and 2/3 of Lag. The finally given results are means of these three computations. Thereby you will also get more reliable results. Taking the third part of Lag will produce a similar but not the identical effect.

All measurements as one class

Includes all measurements as a single class.

Longitudinal shifts file

Chose the path and directory of the longitudinal shifts file to be created.

Choice of the longitudinal shifts file

Display of the longitudinal shifts file (F4)

Start of the longitudinal shifts computation (F12)

Runs the longitudinal shifts computation. In case of success, the results of the computation are displayed.

Settings

Reset

After a confirmation request, reinitializes all settings of the longitudinal shifts computation.

Save/Load

Saves or loads the active settings of the longitudinal shifts computation. The name of the used settings files (*.ecs) is displayed in the header of the longitudinal shifts computation window.

(c) Grischa Hahn, Michel Jacquesson 2020


Longitudinal shifts - Data files

Choice of the selection files used for the Longitudinal shifts computation.

Selection files

Choice of the selection files directory.

All the files of the directory are displayed in a files list.

+

The file is selected or not (mark). To change the status, double-click with the mouse in the small square or strike the [Spacebar] key when the line containing the file name is selected.

File (F3)

For a quick choice of a file, write the fist characters of its name. The selection bar comes automatically on the line containing the file name. If the desired file is found, leave the input field with [Enter], the files list with the selection bar is active again.

Context menu of the files list (right mouse button):

Open file

Opens the selected file.

File Info (Ctrl-F1)

Displays the file info of the selected object positions file.

(De-) Activate file

(De-)activates the selected object positions file.

(De-) Activate all files (F10)

(De-)activates all object positions files.

Other active keys of files list:

[Ins] | Selects file - the selection bar drops automatically to the following line
[Del] | Deselects file - the selection bar drops automatically to the following line
[Space] | Selects/Deselects file
[Ctrl]+[Enter] | OK button gets the input focus

(c) Grischa Hahn, 2007


Drift charts - Introduction

With the module Drift Charts, you can produce a graphic display of the objects positions. In that purpose, with the module Selection you can use selection files (C.M. transits and measures positions) and also Average positions.

Data files

Chose the selection and average positions files used to create the drift chart. For each file, you can set information about the display mode and you can also make simple corrections in longitude and latitude.

Modified longitude system

You can specify a modified rotational system. The longitude interval with Filters is always related to this modified rotational system.

Why a modified rotational system?

In a drift chart, the definition of a modified rotational system displays the positions of an object as an almost linear drift. The object appears then almost stationary. This is very useful for instance to show short period oscillations.

opens a submenu with commands to run the drift data. You can copy the active modified rotational system as a drift data record in the clipboard or paste a drift data record from the clipboard. .

Filters

Set the limits of the time, longitude and latitude intervals. The options min and max in the date interval mean that the top and bottom limits of date are set automatically. The latitude interval is related to the latitude system used in Ephemerides module.

To set From date and To date on the limits of the apparition of a planet (Mars, Jupiter, Saturn only), that is to the beginning and end of an apparition, you can use following special keys:

[PageUp] | One apparition later
[Ctrl]+[PageUp] | ten apparitions later
[PageDown] | One apparition before
[Ctrl]+ [PageDown] | ten apparitions before

Drift chart file

If you want it, write a name for the image file representing the drift chart to be created. The output format is usually TrueColor - 24 bits.

Chose a drift charts file

Delete the name of a drift chart

Drift chart display (F4)

Page layout

Page background

Colour of the page background.

Scale size

Size of the scale lines outside of the chart, in pixels.

(Scale) colour

Colour of the scale lines.

Caption

Write with [image] the text of the caption and also the font, colour and size. The font is displayed at the top.

Legends, Modified rotational system, Filters, Scale captions

Chose with [image] the font, colour and size of the captions at the top. "Scale captions" are always displayed. "Legends", "Modified rotational system", "Filters" are placed under "Caption". The "Legends" includes the used files with their symbols and the auxiliary lines.

X/Y-AxisTitles

Chose with [image] the font, colour and size of the X/Y axis titles. The X axis title is placed under the graph and the Y axis title on he left of the graph.

Data points labels

Chose with [image] the font, colour and size of the data points labels. When you activate this option, a data point will be labelled only if in Files the fields “Label T”, “Label L”, “Label B” are turned to “yes”.

Copyright

Chose with [image] the text of your Copyright information and also the font, colour and size. The Copyright information will be inserted at the bottom right of the chart.

Charts layout

Charts Background

Colour of the drift chart background.

Width, Height

Width and height of the particular drift chart in pixels. In addition, if these options are selected, captions, scales are displayed, so that the real width and height of the created image are larger.

Type

Chose the type of the drift chart to be created. In the pre-selected option, the X axis is the horizontal axis, the Y axis is the vertical axis of the diagram.

Time in JD

Activate this option if you want to display the date in JD and not in usual format.

Invert X/Y axis
Inverts the direction of an axis.

Auxiliary lines

Determine your personal auxiliary lines in your drift chart. The data for these auxiliary lines can be inserted from Drift Computation using the Clipboard

Grid Lines

Grid lines in X/Y

Display of the grid lines in the drift chart.

Increments

Longitude

Distance between the grid lines in longitude degrees.

Latitude

Distance between the grid lines in latitude degrees.

Time

Distance between the grid lines in days, months or year.

Colour

Colour of the grid lines.

Create the drift chart (F12)

The computed drift chart is displayed in a separate window. In this window, the mouse lets you to know the object coordinates.

With the button [image] you can get an alternate display of large cross wires. The reference data for Drift chart data are recorded in a file "[Drift chart file name]_[Extension].GTS" in the same directory, so that you display also the object coordinates independently of the module Drift charts.

The other elements let you to change rapidly the modified rotational system. You can change the increments for the drift value and L(0) with dDrift and dL(0) and decide if the chart must be fixed in the middle during the changes of the drift. In that purpose, activate the button [image].

With the buttons [image] you run a new computation of the drift chart. Drift and L(0) are then increased or decreased with the value of the increments.

Graphical determination of drift data

To determine the drift of an object please click with the left mouse button start and end point of a drift line. Then a window opens with all relevant data and options:

Settings

Reset

After a confirmation, all settings are reinitialised.

Save/Load

Saves and loads the current settings of the drift chart. The name of the settings file (*.grs) is then displayed in the header of the drift chart.

(c) Grischa Hahn, Michel Jacquesson 2011


Drift charts - Data files

Chose the selection and average positions files to be used for the drift chart. For each file, you can specify the display mode of the objects positions and make simple corrections of position in longitude and latitude.

Selections Files

Chose the directory of the selections files.

Average Positions Files

Chose the directory of the average positions files.

All files found in these directories are gathered in a file list. The background of the selection files is reddish, the background of the average positions files is bluish..

+

Displaying status of data files. To change the status, double click with the mouse in the little square or press the [Space bar], when the selection bar is on the file.

File

Name of the file.

Index (Drawing index)

During the creation of the drift chart, the selection files are processed beginning with the larger index to the smaller. It can then happen that data points with smaller indexes hide data points with larger indexes (the smaller the index number, the nearer of the foreground of the drift chart).

Marker

Symbol for a data point of the file.

Col. (Colour)

Colour of the data point symbol.

Size

Size of the data point symbol in pixels.

Error

Display of an error bar in longitude and latitude, only when longitude or latitude errors are mentioned in the data record.

Poly (Polygon)

The data points should be linked by lines.

Colour

Colour of the lines.

Label T (Time label)

Activates the data points labels for the observation time.

Label L (Longitude label)

Activates the data points labels for the object longitude.

Label B (Latitude label)

Activates the data points labels for the object latitude.

Offs. L (Offset in longitude)

Offset value in degrees of longitude for all data points of the file.

Offs. B (Offset in latitude)

Offset value in degrees of latitude for all data points of the file.

File (F3)

For a rapid selection of a file, you can enter the first characters of the file name in the field File. The selection bar of the files list is updated automatically. If you have found the desired file, press [Enter] - The data list is active again.

Contextual menu of the file list (right button of the mouse):

Open file

Opens the active object positions file.

File info (Ctrl-F1)

Displays the File-info of the active object positions file.

(De-) Activate file

(De-) Activates the active object positions file.

(De-) Activate all files (F10)

(De-) Activates all object positions files.

Reset drawing index

The display indexes are computed again according to the index order in the list and the activation of individual files.

Reset all markers

Sets back all markers to "Point".

Reset all marker colours

Sets back all Marker colours to "black" .

Reset all marker sizes

Sets back all marker sizes to "2".

(De-) Activate all nil-error bars

(De-) Activate a ll polylines

Reset all polyline colours

Sets all polygon lines colours to "grey".

(De-) Activate a ll time labels

(De-) Activate a ll longitude labels

(De-) Activate a ll l atitude labels

(De-) Activate a ll longitude offsets

Sets back all longitude offsets to "0".

(De-) Activate a ll latitude offsets

Sets back all latitude offsets to "0".

Other key combinations of the file list:

[Insert] | File on - The space bar moves automatically to the next bottom file
[Delete] | File off - The space bar moves automatically to the next bottom file
[Space bar] | File on/off
[Ctrl]+[Enter] | Button OK selected

(c) Grischa Hahn, Michel Jacquesson 2011


Drift charts - Auxiliary lines

You can insert longitude and latitude auxiliary lines in your drift charts. These lines are drawn with a certain time interval and correspond graphically to an average drift of an object in longitude and latitude. In that purpose, you can add the necessary data from Drift computation using Clipboard.

+

Displaying status of auxiliary lines. To change the status, double click with the mouse in the little square or press the [Space bar], when the selection bar is on the file.

Colour

Colour of the auxiliary lines.

Style (Line style)

The line styles are available only for the line thickness "1", thicker lines are generally drawn continuous.

Thickness

Thickness of the auxiliary lines in pixels.

L(0)

Longitude value of the auxiliary line in the longitude system System at the time Reference Date.

Drift (L)

Drift of the auxiliary line.

System

Reference system.

B(0)/B"(0)

Latitude value of the auxiliary lines in latitude with the longitude system System at the time Reference Date.

Drift (B/B")

Drift of the auxiliary line.

Reference Date

From Date

Start time of the auxiliary line.

To Date

End date of the auxiliary line.

Contextual menu of the auxiliary lines (right button of the mouse):

Add Auxiliary line for longitude

Add Auxiliary line for latitude

Delete

(De-) Activate

(De-) Activate all

Copy drift data

Makes a copy of the (drift) value of the selected auxiliary line in the clipboard.

Paste drift data

Calls the clipboard. Then you can chose drift data for your auxiliary line.

Reset

Sets back L/B (0) and Drift (L/B) to "0". That is, the auxiliary line is exactly at 0° in longitude of the reference system or at 0° in latitude.

Reset all colours

Sets back all auxiliary colours to "black".

Reset all line styles

Sets back all auxiliary lines styles to "continuous".

Reset all thicknesses

Sets back all auxiliary lines thicknesses to "1" (pixel).

Reset all L(0)

Sets back all L(0) to "0".

Reset all longitudinal drifts

Sets back all longitude drifts to "0".

Reset all longitudinal systems

Reset all B(0)

Sets back all B(0) to "0".

Reset all latitudinal drifts

Sets back all latitude drifts to "0".

Reset all "Reference date"

Sets back all "Reference date" to "2000-01-01".

Reset all "From date"

Sets back all "From date" to "1583-01-01".

Reset all "To date"

Sets all "To date" to "2100-01-01".

Other key combinations of the auxiliary lines list:

[Insert] | Activates Auxiliary line - selection bar moves down automatically to the next Auxiliary line.
[Delete] | Deactivates Auxiliary line - selection bar moves down automatically to the next Auxiliary line.
[Space bar] | Auxiliary line on/off
[Ctrl]+[Enter] | OK-Field selected

(c) Grischa Hahn, Michel Jacquesson 2007


Map computation - Introduction

The module Map computation allows you to compute projection maps of the visible surface of a planet from a series of images. Prerequisite is that each image, its time of exposure, size and special orientation were previously defined by a separate settings file (.IMS) of the Image measurement module. Precise adjustment of the outline frame of the measurement screen to the planet's true limb is essential for producing a consistent map.

Image measurements to use

If you click with the right mouse button into a list of Image measurements, or click on button Edit, a context menu with following commands appears:

Open

Opens the associated Image measurement.

Add

Appends one or more Image measurements at the end of the list.

Remove

Removes the highlighted Image measurement from the list. The settings file will not be deleted.

(De-) Activate

Activates or deactivates the highlighted Image measurement. Inactive entries will not be used for map computation.

Refresh (all)

If you have changed any setting within the Image measurement module, and saved it to the .IMS file, it will not automatically be loaded into the Map computation. You have to click on Refresh (all) in order to apply such changes.

Remove all

Removes all Image measurements from the list. The settings files will not be deleted.

(De-) Activate all (alternatively, double-click on column header "+")

Activates or deactivates all listed Image measurements.

Sort all by date (alternatively, double-click on column header "Image measurement")

Sorts all Image measurements by exposure date and UT.

Sort all by C.M. (alternatively, double-click on column header "C.M.")

Sorts all Image measurements by Central Meridian longitudes in the map's rotational System.

Set optimum longitude ranges

First, all Image measurements are sorted by Central Meridian longitudes in the map's rotational System. Second, From L and To L will be set to the middle of the CM's of both adjacent images.

Ephemerides (F8)

Opens the Ephemerides module at date and time of image exposure.

To set a certain column in all lines to the same value, please double-click on the respective column header.

Parameters of an Image measurement

+

Activation status of the Image measurement: checked = active, not checked = inactive.

Image measurement

Name of the settings file (.IMS) of the Image measurement.

Channel

Colour channel to be used.

B

Brightness.

C

Contrast.

G

Gamma.

LD comp. (Limb darkening compensation)

Switches the compensation of limb darkening on, or off. This compensation balances the photometric brightness of an planetary image across its whole disc. The degree of limb darkening depends on the direction of illumination by the Sun, the nature of the planet's surface, and the wavelength of light. Some peculiarities:

Sun

Compensation is possible but the best "LD val." (see below) is strongly dependent on the colour channel.

Mars

Compensation is only possible for red and even longer wavelengths because they represent Mars' surface. Shorter wavelengths show the atmosphere and clouds which cannot be usefully corrected. Moreover, the polar caps refuse any useful correction in all spectral ranges.

Moon

Compensation is possible by a very slow method [3]. Global brightness differences will get lost, extremely bright or dark areas are diminished. The result looks rather "flat" with low contrast. First you should adjust "LD val." to a medium grey level, and try to increase the contrast.

Compensation of limb darkening becomes problematic or even impossible if not-linear or local brightness transformations had been applied in the course of image processing (except for the Moon).

LD val. (Limb darkening value)

A value of 1.0 for the Sun means the brightness profile for white light [2]. For all other bodies, 1.0 represents the reflection profile of an ideal, diffuse body according to LAMBERT [1]. Often you have to decrease this value to get optimal results. In the case of the Moon, "LD val." influences the global brightness level.

From L

Minimum longitude of map segment in the range [0°..360°], Moon [-180°..+180°], counted in reference system Sy.

To L

Maximum longitude of map segment in the range [0°..360°], Moon [-180°..+180°], counted in reference system Sy.

C.M.

Central Meridian in system Sy.

Sy.

Basic rotational system of the map. You can change it in the Layout region.

From B/B"

Minimum latitude of map segment in the range [-90°..+90°].

To B/B"

Maximum latitude of map segment in the range [-90°..+90°].

General map settigs

Map file

Image file name of the map to be computed (optional). The output is always TrueColor 24 bits.

Select map file

Delete name of map file

Show map (F4)

Projection type

Type of map to be computed:

Lambert cylindrical equal-area projection: Equatorial cylindrical projection, using parallel projection

Equirectangular projection: Equatorial cylindrical projection with equidistant scaling in latitude and longitude

Polar projection: Polar parallel projection

Stereographic polar projection: Polar projection with equidistant scaling in latitude

Latitude scale

Determines how the term "latitude" is defined:

Planetocentric (B): Angle between the connection line planet's centre - surface point, and the equatorial plane.

Planetographic (B"): Angle between the perpendicular to the tangent at the surface point, and the equatorial plane (used for ellipsoids with strong flattening, especially Jupiter and Saturn).

Map orientation

Which pole has to be on top of a cylindrical projection, or which pole has to be displayed in a polar projection.

Layout

Page layout

Map width

Width of map measured in pixels. Right of it the optimal width (and corresponding height in parenthesis) with avoids losing image information.

Sets the optimal width.

Longitude of left margin ... in System

Planetocentric longitude of the left margin of the map, followed by the basic rotational system Sy. (only for Venus, Jupiter and Saturn as different systems exist). Since definitions of rotation systems might differ owing to historical reasons, the following maps are examples computed with north at top, and longitude of left margin = 180°:

Sun, Venus, Uranus, Pluto:

Mercury, Mars, Jupiter, Saturn, Neptune:

Earth's Moon:

Drift correction (only Jupiter and Saturn)

Automatic brightness and colour correction of image segments

If this option is checked, WinJUPOS balances the brightness of every colour channel on each individual image automatically. This happens before manual corrections of Brightness, Contrast and Gamma are applied. This results not only in a balance of brightness but also of colour.

Brightness levelling specially for "Longitudinal drift determination from image pairs" (slow)
From time to time, the usual correction of limb darkening compensation [1] is not sufficient to display a regular brightness and color aspect, without edge effect. However, this correction is very important for the Longitudinal drift determination from image pairs. So, with this option, you have another process [3] which keeps local differences of brightness but levels out strongly the global chart.

Compile map

It may take some time until computation is finished. The map will be displayed in a separate window. Moving the mouse cursor over the map, Date, UT, observer and current coordinates are visible in the status bar. If you press [image] large cross-wires are used instead of the mouse cursor.

Relevant data associated to the map are stored to a .GTS file located in the same directory as the Map file. So all this auxiliary information is also available in module Tools - Image viewer.

Settings

Reset

Resets all settings of Map computation to default values.

Save/Load

Saves, or loads Map computation settings. The name of the settings file (*.mcs) will be shown in the title bar of the Map computation window.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2018


Map computation - Page layout

Page background

Colour of background outside the proper projection area, used for scales and captions.

Scales, Size, Colour

Defines whether scale ticks have to be drawn, their lenght (in pixels), and colour. Scale and grid concide in terms of position and distance of ticks. Unchecking Scales is useful of you want to produce a texture map used by the Ephemerides module.

Scale captions

Include degree labels, information about rotational system, type of latitude and projection. Specify the font and its size with [image].

Caption

With [image] you can define a map headline, its font, colour and size.

Legend

With [image] you can define a map legend, its font, colour and size. The legend includes dates, UT's and observers of used Image measurements, the colour channel, and limitations in longitude and latitude.

Map background

Colour of the map background. This is the area inside the projection but outside image information.

Grid, Increments, Colour

Does a grid have to be drawn; what is the spacing of grid lines in longitude and latitude; and what is their colour?

Copyright

With [image] you can define a copyright notice, its font, colour and size. It will be displayed at the lower right corner of the projection area. The background colour of the notice is identical to that of the map background.

(c) Grischa Hahn, Michel Jacquesson , Hans-Jörg Mettig, 2008


Kartenberechnung - Seitenlayout

Map computation - Drift correction

Drift correction (only Jupiter and Saturn)

For example, if you compute a planisphere of Jupiter from a sequence of observations over ten hours, a problem of overlap will appear at the limit between the first and last image in the equatorial zone (system 1). It is not amazing because the equatorial structures shift of about 3° against system 2. The option Drift correction adjusts each image with the help of a mean drift profile on the mean time, so that overlap problems are generally corrected. This is useful for the Longitudinal drift determination from image pairs to reach more precise and clearer results.

However, this option should not be used for maps made with images separated by more than a jovian rotation (10 hrs for Jupiter). The mean drift profile adjusts also the GRS and the WOS-BC with the SEBs jet stream for GRS and STBs jet stream for WOS-BC. This could lead to an interactive deformation of the two objects which have completely different movements.

Original map

Map with drift correction

Longitude shifting (only Jupiter)
Sample longitude shifting file (text file):

! Longitude shift (drift) data for "weather forecast" maps (Jupiter)
! ------------------------------------------------------------------
!
! Comments are marked with "!" at the beginning of a line.
!
! A subsequent line overrides the definition of a previous line for the same
! latitude sector.
!
!      B" : jovigraphic latitude
!      L  : jovigraphic longitude
!     SiO : single object = [WOS-FA, WOS-BC, WOS-DE, RS]
! L drift : average drift in longitude in deg/month in latitude interval
!  System : system of longitude/drift
!
!
!  B" min   B" max         L min        L max           L drift       System
!   [Deg]    [Deg]         [Deg]         [Deg]   [DegPer30Days]      [1|2|3]
!                    [SiO+/-Deg]   [SiO+/-Deg]

! --------------------------------------------------------------------------
    +34.0    +25.0           0.0         360.0               21            2
    +22.0    +14.5           0.0         360.0                8            2
    +11.5    -06.0           0.0         360.0               13            1
    -06.0    -26.0           0.0         360.0               10            2
    -27.0    -37.0           0.0         360.0              -16            2
    -06.0    -29.0       RS-15.0       RS+80.0                0            2
    -27.0    -37.0   WOS-BC-10.0   WOS-BC+20.0              -11            2
    -37.0    -45.0           0.0         360.0              -28            2
! --------------------------------------------------------------------------

Map with longitude shiftings for simulation of the atmosphere 30 days later.

The same with drift correction.

(c) Grischa Hahn, 2016


Map computation - Supplementary notes

[1] Brightness profile of ideal diffuse reflecting bodies according to LAMBERT

S0 - Surface vector/normal (3D) of a surface point, normalized

I0 - Illumination vector (3D) of the surface point, normalized

h - Normal brightness of the surface point

hS - Observed brightness of the surface point

[2] Brightness profile of Sun in white light

r - Observed Cartesian distance (2D) of a surface point from the centre of Sun, Sun's radius as unit

h - Normal brightness of the surface point

hS - Observed brightness of the surface point

[3] Common brightness correction

  1. Compute an unsharp image (UI) from the original image (OI) with filter box size ~ 0.2*r where r is the radius of the celestial body in pixels

  2. Compute the brightness-corrected image (CI) with: CI(x,y) = OI(x,y) + (hMax(UI) - UI(x,y)) where hMax(UI) is the maximum brightness of UI

(c) Grischa Hahn, Michel Jacquesson , Hans-Jörg Mettig, 2008


Longitude drifts determination from image pairs

With the module Longitude drifts determination, you can compute automatically mean objects drifts along a whole given latitude using two images measurements and/or maps. The algorithm is based on a series of parameters which determine precise conditions for the utput material and which must be taken in account for the interpretation of the results.

You need two images measurements or maps with different times. Following conditions must be filled:

  • all objects structures along a latitude drift with almost the same speed
  • all objects sructures along a latitude have been subject of little changes between the times of the two images measurements/maps
  • the images have similar photometric values and can be compared.

In fact, the time span of the two images measurements/maps must be no longer than a few days. The maps should be made from a sequence of pictures.

Computing method

As an example, here are two maps of Jupiter made from pictures taken by the New Horizons spacecraft of January 2007 [1].

Blue - 8./9. January 2007
Red - 20./21. January 2007

fig. 1

Intensity values over the whole longitudes from 0° to 360° in system 2 at a latitude of ß" = -40.5°. The 7 main white ovals in SSTB can be easily seen. As the time span is about 13 days and the mean drift at this latitude is about -1°/day, the two intensity curves show a shift of about 13°.

The algorithm searches for the longitude shift which gives the optimal overlay of the two curves.

fig. 2

Mean negative intensity difference for each reference point (G) of the two intensity curves with a shifted longitude from -180° bis +180°. G reaches its maximum when the two intensity curves have an optimum overlay. This is the case here with a longitude shift of -13.2°. Using the time span of the two maps, a mean drift of -1.02°/day for all objects can be computed.

The pale blue area indicates the region with a arithmetic mean ± 1.0 s (s = Standard deviation). The maximum peak at -13.2° oversteps the mean value with 6.4 s.

Results

If you compute drifts for all the latitudes and if you choose a time span neither too big nor not too small, you can get for example the following wind profiles of the visible atmosphere. Concerning Jupiter, the optimal time span is about 20 hours (2 rotations). On one hand, it must not be too small because the computed drifts would be too unprecise, on the other hand, it must not be too big because in that case, the small details of the surface would have considerably changed and the algorithm could not find any coincidence.

fig. 3

See also the drift profiles of Jupiter and Saturn used in WinJUPOS.

Improvements

The best description of general longitude drifts/winds speeds in an atmosphere is provided by few visible, short lived details of the atmosphere. Long lived vortexes or well visible disturbances are little influenced by surrounding winds. These must be thence excluded from the computing like in the following example. In that purpose, they are marked in magenta.

fig. 4a

fig. 4b

Errors analysis

The computed longitude drift velocities contain always errors which come from following causes:

Images

  • rotation error of the outline frame
  • position error of the outline frame
  • Size error of the outline frame
  • Time data errors

Maps

  • Time data errors of the images included in the map
  • Differences of brightness of the images included in the map

The perfect case is a map made with a set of images (for Jupiter a time span of 1 hour = rotation of 36°). Rotation errors of the outline frame are easily visible and can be removed.

atmosphere unhomogeneity

The wind strengh are different around the whole planet at a given latitude. To get the maximum and minimum values of the wind speeds, you can use the option "Min/Max values" .

fig. 5

The module Longitude drift determination

First map/Image measurement / Second map/image measurement

Choice of a map/image measurement

Remove the file name

Display/open a map/image measurement

Drift data file (optional)

Display the file documentation

Choice of the driftdata file

Remove the driftdata file

Display the driftdata file

Further settings

Longitudes

Increment in longitude

Enter the shift increment of the intensity curves. Small values give more precise drift determinations but they require obviously a longer computing time.

From/To longitude

Only the image informations inside of this longitude span are used.

Compute drift data in running longitudinal intervals

If you activate this option, the longitude span is divided in several intervals and the drifts are computed for each of these intervals. This option needs much more computing time than the simple drift computing.

Interval

Determines the interval size. The correct values should not be smaller than " "Minimum overlapping interval"/2.

Increment for longitudinal intervals

determines the distance of the interval centres.

Output type for drift values

Min/Max values

Gives the computed minimum and maximum drift for each interval of a given latitude (see fig. 5).

Separate values

You can chosse an output format:

  • Longitudinal drift in current reference system
  • Longitudinal in default reference system
  • Metric velocity in default reference system

Image measurements

First/second image: maximum longitude difference to C.M.

Longitude difference to be used for an image measurement. In addition to the limit "From/To longitude".

Reference system

Refernce system to be used for an image measurement. If you use two image measurements, the two C.M. should not be too different.

Latitudes

From/To latitudes

Only the drift values inside of the latitude differences are computed.

Planetocentric / Planetographic

Type of the latitude inputs in "From/To Latitude"

Increment in latitude

Reference points span in which the drift values are computed, inside of the latitude span "From/To latitude". Small increments improve the definition of the drift values in latitude, but they need more computing time.

Use intensity averages over latitude interval

If this option is desactivated, the intensity values are used over the the latitude circle b.

If this option is activated, an average intensity is used in a latitude zone b ± "Increment in latitude"/2. This is possible only for the map projection types cylindrical projection or simple cylindrical projection. This option can be used with noisy image informations but in that case, the "Increment in latitude" must not be too big because small drift variations could be lost. This option needs more computing time.

Limits/Options

Colour channel

The algorithm works only with monochrome pictures (brightness/intensity). With color images, you must choose which colour channel will be used.

Minimum contrast

You can determine under which level the intensity value will be rejected as "noise" (see fig. 1). If the difference between the brightest point and the darkest point of the latitude circle is smaller than this threshold, it is impossible to compute drift values.

Minimum significance

For example, if you give a value of 3.0, only the peaks over 3.0 s (s = standard deviation) will be taken in account. The "Minimum significance" is useful to limit the noise.

Minimum overlapping interval

You must determine here how the two intensity curves should overlap so that a drift can be computed. The valid longitude intervals of an intensity curve can be limited by following conditions:

  • Longitude domain
  • Longitude interval
  • with image measurements, the maximum longitude difference to C.M.
  • With maps, the square unit
  • automatic object occultation or manual zone occultation.

The vaild longitude domains are not necessarily contiguous.

Ignore RS / WOS-BC (Jupiter only)

Hides automatically GRS and WOS-BC on the images.

Ignore magenta-coloured areas

This is the general method to exclude areas from the drift computing. You must mark in magenta (red=255, green=0, blue=255) these areas with an image processing software. You must pay attention that the edges of the magenta areas should be distinct and not softened (see fig. 4).

It is useful to hide large objects which would cause an important disturbance in the average drift curve over large areas of latitude because they have their own different drifts. This is the case for example on Jupiter with GRS, the long lived WOS and disturbances (DIST) at the south edge of SEB. The satellites and their shadows must also be hided.

Be careful:

Images containing magenta areas should not be recorded in a reduced format (JPEG), but for example in PNG format.

If you save the processed images with a different name, do not forget to change the name of the related GTS file. Example:

old: Jupiterkarte.bmp / Jupiterkarte_bmp.GTS

new: Jupiterkarte_maskiert.bmp / Jupiterkarte_maskiert_bmp.GTS

Start drift determination (F12)

Starts the drift determination. Be aware that according to the chosen parameters the computing time can be from several hours to several days.

Temporary interruption and resuming of the computing

With [image] you can interrupt temporarily the computing, with [image] you can resume it. It can be useful, when you run at the same time another computing which needs much computing power, to free temporarily your computer for this other task.

Cancel (ESC)

When you stop a computing, the the results you have got are saved if you have created a drif data flle.

Settings

Reset

After asking a confirmation, put all settings back.

Save/Load

Saves or loads the current settings for a longitudinal drift determination. The name of the used settings file (*.des) is then displayed in the header of the longitudinal drift determination window.

Sources

  1. Jupiter images of the Long Range Reconnaissance Imager (LORRI) of the New Horizons spacecraft: http://pluto.jhuapl.edu/soc/index.php, NASA/Johns Hopkins University Applied Physics Laboratory/Southwest Research Institute
(c) Grischa Hahn, Michel Jacquesson,, 2013


Drift profile Saturn

Average drifts [°/d] of short lived structures in system 2 against the planetocentric latitude.

Sources:

A. D. Del Genio, R. K. Achterberg, K. H. Baines, F. M. Flasar, P.L. Read, A. Sánchez-Lavega, A. P. Showman, "Saturn Atmospheric Structure and Dynamics". Chapter 7 in Saturn after Cassini-Huygens. M. Dougherty, L. Esposito and T. Krimigis (edt.), Springer-Verlag (in press)

A. Sánchez-Lavega, J.F. Rojas, P.V. Sada. "Saturn's zonal winds at cloud level", Icarus, 147, 405-420 (2000).

A. Sánchez-Lavega, S. Pérez-Hoyos, J. F. Rojas, R. Hueso, and R. G. French. "A strong decrease in Saturn's equatorial jet at cloud level", Nature, 423, 623-625 (2003).

A. Sánchez-Lavega, R. Hueso, S. Pérez-Hoyos, J. F. Rojas, "A strong vortex in Saturn's South Pole", Icarus, 184, 524-531 (2006)

A. Sánchez-Lavega, R. Hueso and S. Pérez-Hoyos. "The three-dimensional structure of Saturn's equatorial jet at cloud level". Icarus, 187, 510-519 (2007).

E. García-Melendo, A. Sánchez-Lavega, J. F. Rojas, S. Pérez-Hoyos, R. Hueso. "Vertical shears in Saturn's eastward jets at cloud level", Icarus (in press, 2009).

(c) Grischa Hahn, Michel Jacquesson, Marc Delcroix, 2009


Drift profile Jupiter

Average drifts [°/d] of short lived structures (10h) in system 2 against jovigraphic latitude. This drift profile has been determined from images of the Hubble Space Telescope in September 2012.

Sources:

The Jovian Transit of Venus - A 'Truth Test' for Atmospheric Characterization of Earth-Size Planets in Habitable Zones HST Proposal 13067
Glenn Schneider, University of Arizona

 http://archive.stsci.edu/proposal_search.php?mission=hst&id=13067

Instrument: WFC3
Filter/Grating: F763M
Aperture: UVIS2-2K2C-SUB
Config: WFC3/UVIS
(c) Grischa Hahn, Michel Jacquesson, 2013


Computation of drift averages

The module Computation of longitudinal drift averages allows the computation of average values of a free quantity of drift data files produced by the module Longitudinal drift determination from image pairs. The only condition is that all used longitudinal drifts must be of the same type.

Source files
Open
Opens the selected drift data file

Add
Adds one or several drift data files

Remove
Removes the selected drift data file

Remove all
Removes all drift data files

Set optimum drift correction (dD)

Determines an optimum drift correction value dD for the selected drift data file. This value minimizes the errors related to the used standard drift profile (Jupiter / Saturn).

Set all drift corrections (dD)

Optimum drift correction values for all drift data files.

Reset all drift corrections (dD)
Sets all drift correction values dD to zero.

Drift type of drift corrections (dD)
You can choose here the drift unit for the correction value dD (degree/day, degree/month and meter/second). The drift correction value determines a simple linear shift of the drift value before computing the particular average value. This is often necessary because on amateur images, the recording time and the position of the outline frame in Image measurement can be false. These errors are difficult to eliminate and determine a systematic decrease or increase of the drift value.

Latitude interval
The average longitudinal drift data are computed in fixed spans of 0.1° in latitude in an interval of ± latitude interval. The average latitude is computed as well. According to the dispaching, similar records can be produced. The output will give allways only one record.

Output file

Choice of the path and name of the file containing the average drift data

opens/displays the average drift data file

Run average computation (F12)

Runs the average drift computation.

Parameters

Reset

After a confirmation question, resets all parameters.

Save/Load

Saves or loads the selected parameters for the average drifts computation. The name of the used parametrs file (*.das) is displayed in the window header.

(c) Grischa Hahn, Michel Jacquesson 2011


Longitudinal drift charts - Introduction

With the module Longitudinal drift charts, you can produce a graphic display of longitudinal drifts in correlation to latidude or longitude. You can use Single drift data, Longitudinal drift data from the module Longitude drifts determination from image pairs or Longitudinal drift averages from the module Computation of drift averages .

Data files
Chose the drift data files used to create the longitudinal drift chart. For each file, you can choose the display mode and you can also make a simple correction in drift.

Type
Determination of the chart type. According to the chart type, only particular drift data files can be used. Illegal files have a gray background in the Data files file.

Filters
From/To latitude
Latitudinal limitation of the chart.

Latitude scale
Type of latitude scale.

From/To drift
Drift limitation of the chart in units of the selected drift type.

Colour channel
The computing of longitudinal drift values in the module Longitude drifts determination from image pairs is always made with a particular color channel. This color information is recorded in the longitudinal drift file. For example, the red filter allows only the display of red channel longitudinal drifts. All other longitudinal drift files have a grey background in the files list.

From/To longitude (only if "Drift vs. longitude intervals" is selected)
The limits of the longitude domain for the graph are determined by the selected longitude reference system.

Only longitude intervals in reference system (only if "Drift vs. longitude intervals" is selected)
The computing of longitudinal drift values in the module Longitude drifts determination from image pairs is available only for a determined longitude reference system. This longitudinal reference system is recorded in the longitudinal drif file. The filter "Only longitude intervals in the reference system" allows to determine wich reference system is used and in consequence wich drift data files will be displayed. The files concerning other reference systems have a grey background.

File of longitudinal drift chart
Chose path and name of the longitudinal drift chart file.
Delete name of longitudinal drift chart file.
Displays the longitudinal drift chart file.

Page layout
Background
Colour of then page background.

Scale size, Colour
Size of the scale lines outside of the chart, in pixels.

Caption
Write with [image] the text of the caption and also choose the font, colour and size. The caption is displayed at the top.

Legend, Filters, Scale captions
Choose with [image] the font, colour and size of the captions at the top. "Scale captions" are always displayed. "Legends" and "Filters" are placed under "Caption". The "Legends" includes the used files with their symbols.

X/Y axis title
Choose with [image] the font, colour and size of the X/Y axis titles. The X axis title is placed under the graph and the Y axis title on the left of the graph.

Data point labels
Choose with [image] the font, colour and size of the data points labels. When you activate this option, a data point will be labelled only if in Data files the fields “D La.”, “Label L”, “Label B” or "Obj. La." are turned to “yes”.

Copyright
Choose with [image] the text of your Copyright information and also the font, colour and size. The Copyright information will be inserted at the bottom right of the chart.

Diagram layout
Type
Choose the type of the longitudinal drift chart to be created. In the pre-selected option, the X axis is the horizontal axis, the Y axis is the vertical axis of the diagram.

Width/Height
Width and height of the particular longitudinal drift chart in pixels. In addition, if these options are selected, captions, scales are displayed, so that the real width and height of the created image are larger.
Invert X/Y axis
Inverts the direction of an axis.

Background
Colour of the drift chart background.

Grid lines
X/Y grid
Display of the grid lines in the longitudinal drift chart.
Increments
Latitude, Drift, Longitude
Distance between the grid lines in latitude, drift or longitude.

Colour
Colour of the grid lines.

Drift values
Drift type
Type of the displayed drift values.

In reference system
Reference system of displayed drift values.

Compute longitudinal drift chart (F12)
Starts the computation of the longitudinal drift chart.
Settings
Reset
After a confirmation, all settings are reinitialized.
Save/Load
Saves and loads the current settings of the longitudinal drift chart. The name of the settings file (*.dgs) is then displayed in the header of the longitudinal drift chart.

(c) Grischa Hahn, 2011


Longitudinal drift charts - Files

Longitudinal drift charts - Data files

Choose the drift data files to be used for the longitudinal drift chart. For each file, you can specify the display mode and make simple corrections of the longitudinal dirft.

+
Displaying status of data files. To change the status, double click with the mouse in the little square or press the [Space bar], when the selection bar is on the file.

File
Name of the file.

Index (Drawing index)
During the creation of the longitudinal drift chart, the drift data files are processed from the larger index to the smaller. It can then happen that data points with smaller indexes hide data points with larger indexes (the smaller the index number, the nearer of the foreground of the longitudinal drift chart).

Marker
Symbol for a data point of the file.

Diagram type "Drift vs. latitude"
Size
Size of the data point symbol in pixels.

Col.
Colour of the data point symbol.

Error
Display of an error bar in longitudinal drift, only when this errors are mentioned in the data record.

Min co. (only files of longitudinal drifts with Min/Max values)
Colour of the symbol for the minimum longitudinal drift value.

Max co. (only files of longitudinal drifts with Min/Max values)
Colour of the symbol for the maximum longitudinal drift value.

Diagram type "Drift vs. longitude intervals"
Poly (Polygon)
The data points should be linked by lines.
Style
Line style of the polygon.

Tickn.
Thickness of the polygon lines in pixels.

D La.
Activates the data points labels for the longitudinal drift.

Label L (only if drift chart type "Drift vs. longitude intervals" is selected and Longitudinal drift data files with Single values or Single drift data files)
Activates the data points labels for the average longitude of the corresponding longitudinal interval or the longitude of a sigle object.

Label B
Activates the data points labels for the corresponding latitude of the longitude drift or the latitude of a single object.

Obj. La. (only Single drift data files)
Activates the data points labels for the object code of a single object.

dD [°/d, °/m, m/s]
The value of correction value determines a simple linear shift of the longitudinal drift values of a file. This is often necessary because in amateur images the image time and the position of the outline frame in the image measurements can be false. This error is difficult to eliminate and determine a systematic decreasing or increasing of the computed drift values.

Context menu of liles list (right mouse button) or button Edit:

Open file

File info (Ctrl-F1)

Add (Ins)

Remove (Del)

(De-) Activate file

Set optimum drift correction (dD)

Determines an optimum drift correction value dD for the selected drift data file. This value minimizes the errors related to the used standard drift profile (Jupiter / Saturn).

Remove all

(De-) Activate all files (F10)

Sort list by file name

Reset drawing index

The display indexes are computed again according to the index order in the list and the activation of individual files.

Reset all markers

Reset all marker sizes

Reset all marker colours

(De-) Activate all nil-error bars

Reset all min-marker colours

Reset all max-marker colours

(De-) Activate all polylines

Reset all polyline styles

Reset all polyline thickness

(De-) Activate all drift labels

(De-) Activate all longitude labels

(De-) Activate all latitude labels

(De-) Activate all object name labels

Reset all drift corrections

(c) Grischa Hahn, 2011


Administration - Data test

The module Data test lets you verify the data integrity of object positions stored in PC-JUPOS/PC-SAPOS or WinJUPOS format.

You may cancel the process at any time.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - Data repair

The module Data repair corrects object positions if unambiguously possible. This might become necessary as older versions of WinJUPOS up to 7.0.26, PC-JUPOS up to 6.23, and some data imports produced data inconsistencies.

Central Meridian transits:

  • rounds the UT to the nearest tenth of a minute (only old format)
  • re-calculates the Julian Date from Date and UT (only old format)
  • re-calculaties Central Meridians and phase angle
  • corrects the rotational System on the basis of the specified Region

Measurements:

  • rounds the UT to the nearest tenth of a minute (only old format)
  • re-calculates the Julian Date from Date and UT (only old format) as a small offset, namely the running measurement number per image * 1/1000 minute, was applied in PC-JUPOS
  • re-calculates Longitudes - where the longitude of the current rotational System is the reference value and remains unchanged
  • re-calculates the phase angle
  • corrects the rotational System on the basis of the specified Region

Measurements / Selections:

  • eventual new allocation of the reference informations on an image measurement

If a "Longitudes diverge mutually..." error occurs, longitudes in individual rotational systems do not match each other (Measurements) or conflict with the Julian date (Central Meridian transits), and will not be corrected.

If Date/UT or Julian date are invalid, any repair is impossible.

You may cancel the repair process at any time.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2009


Administration - Data conversion

The module Data conversion converts object positions files from the old PC-JUPOS/PC-SAPOS to the new WinJUPOS format, and vice versa.

Options:

Include Data test

Before conversion starts, a full Data test is executed for all records.

Include Data repair

Object positions are additionally repaired if necessary (see module Data repair).

You may cancel the conversion process at any time.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - Data comparision

The module Data comparison compares object positions files, and logs found differences. You are able to compare individual files, even with different names, or groups of files with identical names (without suffix). Also possible is a comparison of old (PC-JUPOS/SAPOS) and new (WinJUPOS) file formats.

Options:

Disregard record order and search through File 2 (low speed)

If the record order of both files to be compared is different, you can try to activate this option. However it is only possible to verify that records of File 1 also exist in File 2. Detecting internal differences between records is impossible.

Do not log differences possibly caused by a Data repair run

Ignores minor differences in Julian Date, Longitude, Phase, and Rotational system possibly caused by a Data repair or Data conversion (Include Data repair) executed for one of the files.

List columns to be compared

Defines the columns to be taken into consideration when comparing.

You may cancel the comparision process at any time.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - File sorting

The module File sorting enables you to sort one or more object positions files by different sort orders. Numbers will be sorted ascending, and non-numeric words (character strings) alphabetically.

If you select "Customized sorting", criterion no. 1 has highest priority, and no. 3 the lowest.

If you have picked the Latitude / Region criterion, and a record does not contain a latitude value (as true for all Central Meridian transits but also some Measurements), a representative jov. latitude will be derived from the specified Region.

You may cancel the sorting process at any time.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - Sorting criteria for object positions files

Select up to three sorting criteria. Criterion no. 1 has highest priority, and no. 3 the lowest. Numbers will be sorted ascending, and non-numeric words (character strings) alphabetically.

Option:

Sorting criterion: Latitude / Region

If you have picked the Latitude / Region criterion, and a record does not contain a latitude value (as true for all Central Meridian transits but also some Measurements), a representative jov. latitude will be derived from the specified Region.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - File export

The module File export stores WinJUPOS object positions to external files with standard formats.

Fixed length text (*.txt) for printing

Plain text suitable for printing, table header included.

Fixed length text (*.txt)

Plain text suitable for data exchange.

Comma separated text (*.csv)

Recommended for import to external spreadsheet or database applications. Decimal and column separators are as defined by your operation system settings. If the destination application uses other delimiters, you have to modify them!

dBASE III (*.dbf)

Rather aged database format of the DOS period but still readable by many applications. For compatibility reasons, the file name is restricted to the "8.3" DOS scheme.

List columns

Choose all list columns to be exported. You can activate a preset Short format or Long format.

Destination directory

Select the destination directory of the export.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - Rename file

You should never rename object positions files outside WinJUPOS because associations to related content (e.g., observer's data and Image measurement), will get lost then.

When renaming an object positions file in WinJUPOS, the following operations will be executed additionally:

Central Meridian transits and Measurements in PC-JUPOS/-SAPOS format (*.ZMP; *.SZM)

  • the file name is truncated to 8 characters, and illegal characters are replaced by an underscore ("_")
  • the associated List of Observers (*.BEO) is updated and sorted.

Measurements in WinJUPOS format (*.MEA; *.WSE)

  • the associated .IMR file which contains information on Image measurements is renamed

Selections and Positional averages in PC-JUPOS/-SAPOS format (*.SEL; *.MIT and *.SSE; *.SMI)

  • the file name is truncated to 8 characters, and illegal characters are replaced by an underscore ("_")
  • the associated log file (COMMENTS\*.DOC) is renamed

Selections and Positional averages in WinJUPOS format (*.MEA; *.PAV)

  • the associated log file (*.WSD; *.WAD) is renamed

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - Update List of Observers (PC-JUPOS/SAPOS)

The module Update List of Observers refreshes a PC-JUPOS/SAPOS List of Observers (LIST_MES.BEO, LIST_ZMP.BEO) with contents of object positions files located in the same directory as the .BEO file.

Option:

Attach information from other List of Observers

If you select a second List here, possible differences between both Lists will be automatically detected, and you can copy changes from the second to the first one. This makes sence if the second List contains more up-to-date information about observers' names and adresses. Only after that external update is finished, the standard process of reading object position files in the same directory will be executed.

Finally, the (first) List of Observers will be sorted alphabetically.

You are able to cancel the process at any time.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Administration - Macro execution

The module Macro execution lets the automatic running of a great number of operations on the selected data: Selections, Positional averages, Longitudinal shifts, Drift charts, Map computation, Longitude drifts determinations from image pairs , De-rotation of images , De-rotation of R/G/B frames or De-rotation of video streams .

Edit macro

A macro file (*.wjm) contents a list of settings files to be run.

Output files overwrite

If this option is activated, eventually already existing output files will be overwritten without confirmation question.

Drift charts settings can contain parameters to edit them or create groups of drift charts.

Date

Particular time span
From/To Date overwrite the corresponding time limits of the settings file.

Latitude

Particular latitude span
From/To Latitude overwrite the corresponding latitude limits of the settings file.
With latitude steps
In the determined latitude span a group of drift charts is created, defined by Latitude Interval and Increment. Example:
From Latitude: -45.0°; To Latitude: -35.0°; Latitude Interval: 5°; Increment: 2° creates the following groups of drift charts:
-45°..-40°, -43°..-38°, -41°..-36°

Drift

With drift steps
If this option is activated, a group of drift charts is created which differ only in the used drift (of the modified rotational system). If latitude spans are defined, the difference of drift is made in each latitude span!

Drift charts files

Name convention
WinJUPOS
WinJUPOS Standard format:
"WSpot 2005-11-01 2006-09-01 +45,0 +40,0 -1,3000 2"
"[Name of the settings file] [From Date] [To Date] [From Latitude] [To Latitude] [Drift] [Longitude system]"
The unit corresponds to the unit defined in WinJUPOS in Preferences.
PC-JUPOS/SAPOS
Name conventions of the macros in PC-JUPOS/SAPOS, but the sign # is replaced by a correct sign +:
"*VV*BB*DDD_S"
* replaces - or +
VV is the value of From Latitude rounded off to the nearest degree, BB is To Latitude, DDD describes the Drift (without comma) rounded off to the integer 0.1°/day.
Name from the settings file
The defined file name in the drift charts settings is used. This option is available only if a single drift chart should be created, that is in macros without latitude and drift steps.

(c) Grischa Hahn, Michel Jacquesson, 2012


Administration - Synchronise settings files

Using Synchronise settings files, you can update a set of settings files on the base of a template file which contains all relevant changes. Supported is the synchronisation of Selection, Positional averages, Longitudinal shifts and Drifts chart settings.

When is it useful? An example.

You have created many settings files for the Jupiter apparition 2006. Now, you want to analyse apparition 2007 and wonder if you have to create completely new settings or modify those of 2006 manually. You do not need to do either!

  1. Create a template settings file with From Date and To Date properly chosen for apparition 2007
  2. Load this template with [image] .
  3. Copy your settings files of 2006 to another directory, preferably named "2007" or similar.
  4. Load all these copies with Add. (If you are in the File-open dialogue, pressing Ctrl+A selects all files in the current directory!)
  5. Activate only the option From Date/To date, Reference Date under Parameters to be synchronised.
  6. Run Synchronise settings files.

Now the 2007 values From date, To date und Reference date have been applied to your copied settings. (Optionally, you may let WinJUPOS carry out further work for you at Administration - Macro...)

Parameters to be synchronised

Migrate data file settings

Active data types

Transfers activation status of supported file types.
(Selection: CM transits and Measurements; Drifts charts: Selections and Positional averages)

Directories related to data types

Transfers directories associated to file types.

Activation flag of data files

Transfers activation status of individual data files.

Parameters of data files

Transfers parameters associated to data files.

Distinguish PC-JUPOS/SAPOS from WinJUPOS data files (recommended)

If this option is activated, old and new data files are distinguished, even if their have the same name.

If this option is deactivated, ancient and new data files are used in the same way, also when they have the same name. The file TEST.ZMP (PC-JUPOS) and its attributes are then transferred in a file TEST.CMT (WinJUPOS). Only files and their attributes which are present in the new target directory are finally taken in account!

From longitude/To longitude

Transfers From longitude and To longitude.

From date/To date, Reference date

Transfers From date, To date, and Reference date.

Phase corrections (Selections only)

Transfers all attributes related to phase correction.

Nil-error bars (Selections only)

Transfers all attributes related to nil-error bars in longitude and latitude.

Size of drift chart (Drift charts only)

Transfers pixel size of the diagram area.

Basic layout of drift chart (Drifts charts only)

Transfers essential layout attributes like fonts, colours, and scale sizes.

(c) Grischa Hahn, Michel Jacquesson, Hans-Jörg Mettig, 2008


Ephemerides - Introduction

Planetary Ephemerides calculates physical ephemerides of the Sun, the planets (its moons) and the Earth Moon. Necessary are the data of observational place at Earth (Geographic Longitude and Latitude) as well as the observational time (Universal Time).

In the Graphics window you can see the current aspect of the planet (and its moons). In the case of Jupiter, Saturn and Uranus it shows eclipses, occultation's, transits and shadow-transits of the brightest moons as well as mutual phenomena. Encounters of planets, eclipses of Moon and Sun as well as transits of Mercury and Venus before the Sun are showed.

You can calculate ephemerides between 1583 Jan 1, 0h 0min UT and 2099 Dec 31, 23h 59.9min UT. The date is generally related to the Gregorian Calendar, which was initiated on 1582 Oct 15, but not in all countries. Fore instance the change in Great Britain took place 1752 [4].

New Horizons ephemerides, currently implemented for 2007 January 01 to May 01, have been adopted from [7].

The Geographic Latitude is negative southern of the equator. The Geographic Longitude is negative western of Greenwich.

Following keys are available:

[Ctrl]+[-] | decreases observational time by 10 minutes
[Alt]+[-] | decreases observational time by 1 minute
[Alt]+[+] | increases observational time by 1 minute
[Ctrl]+[+] | increases observational time by 10 minutes
[Ctrl]+[E] | opens the Ephemeris window
[Ctrl]+[M] | opens the Moon coordinates window
[Ctrl]+[G] | opens the Graphics window
[Ctrl]+[O] | opens the Options window

With the keys [image] you can increase or decrease the observational time. Real time sets the current (system) UT of your computer.

With the keys [image] you can control animation of observational time. Quick run works with 10 minutes steps, slowly run with 1 minute steps. ESC stops the animation. Real time sets the current (system) UT of your computer.

Most texts are self-explanatory. The position angle of Jupiter's and Saturn's rotation axis is given with respect to both the equatorial and the horizontal system of Earth and counted eastwards (in direction of f. limb) from the corresponding north point. The equatorial diameter of Jupiter's and Saturn's disk relates to the illuminated part, in all other cases to the full disk. "Declin. of Earth" is the declination of Earth as viewed from the planet, the value B" immediately behind it shows the planetographic latitude of the centre of Planet as viewed from Earth. The physical ephemerides of the Moon are generally tropocentric.

Central Meridians of Mars, Jupiter and Saturn are listed for each full hour of the same night in the screen's left part, but only if the planet is visible.

Rotational systems

There are some historical differences in defining direction of longitude scales:

Sun

L(WinJUPOS) = L(NASA) = 360° - L(BDL) = L(AHNERT)

Venus

System II of Venus has a retrograde rotation of -85.7142857°/d and refers to the upper atmosphere visible in UV light [6]. System I, on the other hand, is bound to the solid surface of Venus. Zero meridians of both Systems coincide at J2000.

L(WinJUPOS) = L(NASA) = 360° - L(BDL)

Jupiter

Note that Central Meridians calculated by WinJUPOS and PC-JUPOS always refer to the illuminated disk (i.e., they are phase-corrected), not the full planet's ellipse as done by most other ephemerides. The difference between both types of Central Meridians can reach 0.6° maximum. This divergence affects Central Meridian values only, and has no impact on longitudes measured on images.

System III

PC-JUPOS <= 6.24 | 870.536°/d | [2]
PC-JUPOS >= 6.30
WinJUPOS <= 10.1.15
870.5366420°/d
[3]
WinJUPOS >= 10.2.0 | 870.536°/d | [8]

Saturn

The rotation systems of Saturn are defined as follows:

System I | 844.300°/d | IAU
System II | 812.000°/d | ALPO
System III | 810.7939024°/d | IAU

Uranus, Neptune

L(WinJUPOS) = L(NASA) = 360° - L(BDL)

Latitude systems

Planetocentric: | Sun, Mercury, Venus, Moon, Mars
Planetographic: | Jupiter, Saturn, Uranus, Neptune

Central Meridian (C.M.) List

Central Meridians of Sun, Mars, Jupiter and Saturn are listed for each full hour of the same night, but only if the planet is above and the Sun below the horizon. The current observational time preceding hours are marked with "-", following hours with "+".

Central Meridian Transits (C.M.T.)

If you wish to know the exact time a certain meridian becomes central, click on "System 1..3" for the system in question and enter the meridian's longitude. The two times afterwards displayed precede and follow the current observational time. You may accept them in the main window.

Copy UT and C.M. to clipboard

If you click with the right mouse button in the edit box for Date or UT it appears a context menu with the command for copying the current Time of ephemerides and the corresponding Central Meridians to the clipboard. The text line in the clipboard (for Jupiter) looks like:

2003-10-17 (yyyy-mm-dd), 09:20.5 UT CM I 129,3° CM II 339,0° CM III 229,9°

(c) Grischa Hahn, 2015


Ephemerides - Moon coordinates

The Moon coordinates window shows the geocentric positions of the brightest moons and their shadows. The Cartesian coordinates x, y and z are measured in a rectangular coordinate system whose origin is identical with the centre of the full planet's ellipse as viewed from Earth, its unit being the planet's equatorial diameter. The positive x-axis points to p. direction (planetary east) and cuts the equator of the planet on limb. The positive y-axis points to planetary north and is identical with the projection of the rotation axis as viewed from Earth. Y- and rotation axis intersect at angle "Decl. of Earth". Finally, the negative z-axis is directed to the observer, but only information whether the moons are situated "in front of" (z<0) or "behind" the planet (z>0) is given.

Small arrows indicate the direction where a certain moon or shadow can be found with respect to the chosen image orientation. If a moon or shadow is in front of (or on) the planet's disc, its zeno-/saturnigraphic coordinates are also listed:

dL | longitude of C.M. minus longitude of object (dL is before the Central meridian Transit (CMT) negative, otherwise positive)
B" | planetographic latitude

Search for personal error of an observer in the CMT estimation with help of the observation of satellite or satellite shadow CMT

Central Meridian Transits (CMT) observed visually are distorted because of the darkening of the planet terminator. Before the opposition, the estimated CM by the observer is slightly shifted towards the f-edge compared to the the CM of the geometrically illuminated part of the planet (computed for Jupiter and Saturn), otherwise towards the p-edge. The value of the shift in planetographic longitude degrees is about 12% of the phase angle [4] for Jupiter. The time of an observed CMT must therefore be corrected of:

dL = - b.F. - (0.12 * Phase angle)

with "dL" as defined above and "b.F." the systematic personal error of the observer. So that:

b.F. = - dL - (0.12 * Phase angle).

This relation allows the determination of the personal error using the CMT of satellites or satellites shadows and the estimation and the correction of the CMT of other objects like for instance the GRS:

Lxcorr = Lx + b.F. + (0.12 * Phase angle)

"Lx" is there the CM in longitude system x at the time of a CMT of an object related to the geometrically illuminated part of the planet disk.

"Lxcorr" is the corrected and "true" Longitude of the object.

An example of computation:

On january 9th, the author observed following CMT:

Shadow III  03h 19.0min UT +/- 2.0min  dL = -2.6° +/- 1.0°
GRS         04h 15.0min UT +/- 1.5min  L2 = 81.1° +/- 0.9°

Phase angle = + 4.9°

Then:

b.F. (Hahn) = - dL - (0.12 * Phase angle) = + 2.0° +/- 1.0°

L2corr = L2 + b.F. + (0.12 * Phase angle) = 83.7° +/- 1.9°

Measured CCD images gave in this moment the GRS at = 84.0° +/- 0.8°. As there is also a phase effect in CCD measurements (but only about 6% of the phase angle), the corrected longitude from the CCD observations is:

LxCCDcorr = LxCCD + (0.06 * Phase angle)

L2CCDcorr = 84.3° +/- 0.8°

Of course, a mean confident determination of the personal error needs numerous observations of satellite and shadow CMT.

(c) Grischa Hahn, Michel Jacquesson 2007


Ephemerides - Graphics

In the Graphics window you can see the current aspect of the planet (and its moons). The display is adjusted to the rotational axis of the planet.

If the option "C.M. + equator" is switched on, a line marks the direction to the equatorial celestial pole. Also the Central Meridian (at Jupiter and Saturn phase corrected) as well as the planet's equator will be showed. Spacecraft ephemerides like those for New Horizons always use and show Central Meridians of the full planet's ellipse.

All shadow representations show umbrae (black) and penumbrae (dark-grey). The outer penumbra boundary is located on the connection line between centre of Sun and limb of the shadow-casting object. The times of begin and end of eclipses in the common tables of ephemerides corresponds to these outer penumbra boundary.

If you press the middle mouse button (or press the mouse wheel) over the planetary display and hold it, you can move the planet with the mouse. Pressing and holding the right button increases (move up) or decreases (move down) the planet.

If the option "Texturing" is switched on, you can apply image information at the planets body. All you need is a planetary map and its correct parameters (s. Options). Planet's maps of Mercury, Venus, Mars and the Earth moon you can download from the Internet (s. Literature). The surfaces of the gas-planets and the Sun are, compared to the other, not constant and only valid to one time. You can create this maps yourself with the modules Image measurement and Map computation in WinJUPOS.

The option "Shading" causes a (visual) limb darkening of the texture.

The option "Equatorial" causes the rotation of the image to the equatorial system.

The following keys are available:

[Ctrl]+[PgUp] | largest possible display
[PgUp] | increases the display
[Home] | normal size
[PgDn] | decreases the display
[Ctrl]+[PgDn] | smallest possible display
[Alt]+[0] | centres the planet
[Alt]+[1..5] | centres moon
 | 1..2 (Mars)
 | 1..4 (Jupiter)
 | 1..5 (Saturn)
 | 1..5 (Uranus)
[Alt]+[Arrow keys] | moves the display by 0.2 planet's radii
[Ctrl]+[Arrow keys] | moves the display by 1 planet's radius

Prints graphics in current aspect.

Saves graphics as image sequence file (GIF).

Saves current graphics as image file.

(c) Grischa Hahn, Michel Jacquesson, 2008


Ephemerides - Options

Surface Texturing

For surface texturing you need a planet's map with one of the following projection types:

Lambert cylindrical equal-area projection:

The meaning feature of this projection is that the latitude scale is not linear. Polar regions will be displayed distorted. Lambert cylindrical equal-area projections are common used for planets, which equatorial inclination varies only a little bit about 0° (Jupiter).

Cylindrical projection of the planet Jupiter. South is at top. The Longitude of the left side of the map is 180° in System 2.

Equirectangular projection:

The Equirectangular projection is linear and uniform longitude and latitude scales. You have only to differ between planetographic (B") (PC-JUPOS) and planetocentric (B) latitude values (PlanetaryDataSystem - Map Server).

The planetocentric latitude (B) describes the minimum angle between the lines planet's middle point - surface point and planet's middle point - equator.

The planetographic latitude (B") describes the minimum angle between the perpendicular to the tangent at the surface point and the line planet's middle point - equator (sensible only for bodies with high flattening - Jupiter, Saturn a.s.o.).

Equirectangular projection map of the planet Mars. North is at top. Longitude of left margin of the map is 0°. The latitude values are planetocentric.

(c) Grischa Hahn, 2018


Ephemerides - Literature

Planetary maps

Planetary Data System (PDS): http://pds.jpl.nasa.gov

PDS-Map Server: http://pdsmaps.wr.usgs.gov/maps.html

Björn Jónsson: http://www.mmedia.is/~bjj/index.html

James Hastings: http://planetpixelemporium.com/planets.html

Steve Albers: http://laps.fsl.noaa.gov/albers/sos/sos.html

Planetary moons maps

NASA: http://maps.jpl.nasa.gov

Björn Jónsson: http://www.mmedia.is/~bjj/planetary_maps.html

Steve Albers: http://laps.fsl.noaa.gov/albers/sos/sos.html

Rings of Saturn

Björn Jónsson: http://www.mmedia.is/~bjj/data/s_rings/index.html

Planetary Ephemerides

VSOP87

[1] Montenbruck, Oliver: Grundlagen der Ephemeridenrechnung, SuW-Taschenbuch Nr. 10, Verlag Sterne und Weltraum, München, 1984, S. 108-113

[2] Seidelmann, P. K.: Explanatory Supplement to The Astronomical Almanac, University Science Book, Mill Valley (California), 1992

[3] P. K. Seidelmann (Chair), B. A. Archinal (Vice-Chair), M. F. A'Hearn, D. P. Cruikshank, J. L. Hilton, H. U. Keller, J. Oberst, J. L. Simon, P. Stooke, D. J. Tholen, and P. C. Thomas, Report Of The IAU/IAG Working Group On Cartographic Coordinates And Rotational Elements: 2003, Celestial Mechanics and Dynamical Astronomy, 2005, 91, pp. 203-215, http://astrogeology.usgs.gov/Projects/WGCCRE/

[4] Meeus, Jean: Astronomische Algorithmen, Johann Ambrosius Barth, Leipzig, Berlin, Heidelberg 1994

[5] Hahn, Grischa: Systematische Fehler bei der Schätzung von Zentralmeridianpassagen auf Jupiter, Mitteilungen für Planetenbeobachter (MfP) 15, 1 (1991), S. 1-12

[6] Crussaire, Daniel: Éphémérides de la couche nuageuse de Vénus, http://www2.saf-lastronomie.com/grpmars.htm

[7] Mark Showalter: Jupiter Ephemeris Generator 1.2 for New Horizons, Updated Trajectory version 4 (31 October 2006), http://pds-rings.seti.org/tools/ephem2_jupnh.html

[8] B. A. Archinal, M. F. A’Hearn, E. Bowell, A. Conrad, G. J. Consolmagno, R. Courtin, T. Fukushima, D. Hestroffer, J. L. Hilton, G. A. Krasinsky, G. Neumann, J. Oberst, P. K. Seidelmann, P. Stooke, D. J. Tholen,P. C. Thomas, I. P. Williams. , Report of the IAU Working Group on Cartographic Coordinates and Rotational Elements: 2009, Celestial Mechanics and Dynamical Astronomy, 2011, Volume 109, Issue 2, pp 101-135, http://astropedia.astrogeology.usgs.gov/download/Docs/WGCCRE/WGCCRE2009reprint.pdf

Moons of Mars

ftp://ftp.imcce.fr/pub/ephem/satel/martian/ 2007-05-14

Lainey, V., Dehant, V. and Paetzold, M. "First numerical ephemerides of the Martian moons", Astron. Astrophys., vol 465 pp.1075-1084 (2007).

© V. Lainey, IMCCE - Observatoire de Paris, 77 avenue Denfert-Rochereau, F-75014 Paris, France

Moons of Jupiter

ftp://ftp.imcce.fr/pub/ephem/satel/galilean/L1/L1.1/ 2007-05-07

Théorie synthétique ajustée entre 1891 et 2003 des satellites Galiléens (Version 1.1) V.Lainey, IMCCE - 77, Avenue Denfert-Rochereau 75014 Paris (France)

Lainey, V., Duriez, L. and Vienne, A. "Synthetic representation of the Galilean satellites' orbital motions from L1 ephemerides", Astron. Astrophys., vol 456 pp.783-788 (2007).

Lainey, V., Arlot, J.E. and Vienne, A. "New accurate ephemerides for the Galilean satellites of Jupiter. II. Fitting the observations", Astron. Astrophys., vol 427 pp.371-376 (2004).

Lainey, V., Duriez, L. and Vienne, A. "New accurate ephemerides for the Galilean satellites of Jupiter. I. Numerical integration of elaborated equations of motion", Astron. Astrophys., vol 420 pp.1171-1183 (2004).

Moons of Saturn

ftp://ftp.imcce.fr/pub/ephem/satel/tass17/ 1996-11-14

TASS1.7 by Alain Vienne and Luc Duriez (1995, A&A 297, 588-605) and 'Theory of motion and ephemerides of Hyperion' (5 Nov 1996)

© BUREAU DES LONGITUDES and UNIVERSITE DES SCIENCES ET TECHNOLOGIES DE LILLE, Alain Vienne (VIENNE@GAT.UNIV-LILLE1.FR ) and Luc Duriez (DURIEZ@GAT.UNIV-LILLE1.FR), UNIVERSITE DES SCIENCES ET TECHNOLOGIES DE LILLE, Laboratoire d'Astronomie, 1 Impasse de l'Observatoire, F-59000 LILLE, FRANCE

Moons of Uranus

ftp://ftp.imcce.fr/pub/ephem/satel/gust86/ 1996-02-03

GUST86 - An analytical ephemeris of the Uranian satellites, LASKAR J., JACOBSON, R., <Astron. Astrophys. 188, 212-224 (1987)>

URANIAN satellites theory Laskar and Jacobson (1987), URANUS position (VSOP85, Bretagnon 1985), several routines from G. Francou, (c) Astronomie et Systèmes Dynamiques, Bureau des Longitudes, (1988, 1995), Jacques Laskar (laskar@bdl.fr), Astronomie et Systèmes Dynamiques, Bureau des Longitudes, 3 rue Mazarine, F-75006 Paris, France

Moons of Neptune

Seidelmann, P. K.: Explanatory Supplement to The Astronomical Almanac, University Science Book, Mill Valley (California), 1992

(c) Grischa Hahn, 2020


Planning of observations - Introduction

The module Planning of Observations lets you to compute the time of CM transit of a chosen object with a certain drift in longitude in a certain place of the Earth.

(c) Grischa Hahn, Michel Jacquesson 2008


Monochrome image computation

De-rotation of images

With the module De-rotation of images you can stack several records of a celestial body, as much as possible with small time spans. The planet rotation is then corrected. In consequence, the noise is reduced and the details are enhanced.

You can find more explanations in the help page of De-Rotation of R/G/B images.

Possible uses:

You are observing a planet for instance in methan band during 15 minutes. Unfortunately, the video recording contains periods with clouds. But you can use several images of small sequences. With the De-rotation of images, you can stack these separate images.

You want to make color images with a monochromatic camera. With the standard process, you must make video sequences with red, green and blue filters in a small time span. With Jupiter, if you want for instance make video sequences of more than 2 minutes for each color channel, you can proceed as following :

Cut a video sequence of 18 minutes in parts of each 2 minutes:

RGBRGBRGB

Each time you compute 3 images from each color channel which will be merged in the De-rotation of images. Then you can merge the three resulting images R, G, B in the module De-rotation of R/G/B frames to obtain a colour image.

Tip:

It is better to choose a 48 bits format for the final image, PNG or TIFF. Then, you can use the wavelet function of Registax to sharpen the image. The image should be saved with 8 or 24 bits only after this enhancement.

Pay attention to put a correct LD value for each separate image. If the values are too high (it can be tested in the module Image Measurement), the result is a very ugly limb effect in the final image:

Optimize Image measurements

Optimizes the Image measurements for the best possible coverage. However, the quality of this automatic optimization depends heavily on the richness of detail and the absence of noise in the images.

 In the context menu of a selected Image measurement, you can specify whether it is to be used as a reference for optimization. Select the best quality image with a well-defined Image measurement.

The type of optimization can be selected using the button [image] . For an optimum result, you should optimize as few parameters as possible.
(c) Grischa Hahn, Michel Jacquesson, 2018


Image computation

De-rotation of R/G/B frames

With the module De-rotation of R/G/B frames you can compute a colour image from two or three monochromatic images which are taken in a little time span. You must pay attention to the time of the images to get the best fitting of the surface configurations. If you dispose of only red an blue channel images, you can get the green channel by interpolation of the first two (R(G)B-image instead of RGB-image).

Another possibility is to produce a luminescence channel to compute a LRGB/LR(G)B-image. This technique combines a monochromatic, filter free, high resolution image in integer light (that is gathering the whole spectral domain) with colour information from filtered images which may have a lower resolution. The luminescence image defines the light information, that is the surface configurations, although in grey scales. The colour images give only the colour information, their light information are ignored.

From two to four settings files are necessary for the image computation with WinJUPOS. In that purpose, you must first process your monochromatic images in the module Image measurement and save the settings.

Image measurements to be used

Incorporate your red, green, blue and luminescence channels of the resulting image in Image measurement . If you leave the green channel (situated in the middle) free, it will be computed from a linear interpolation from the red and blue channels. A LRGB image will be computed only if you incorporate a luminescence channel.

Gamma

The gamma value influences the brightness of the colour channel. However, you must the pay attention to the colour shifts if you give different gamma values.

LD value

Pay attention to put a correct LD value for each separate image. If the values are too high (it can be tested in the module Image Measurement), the result is a very ugly limb effect in the final image:

dX / dY

If it is not possible to adjust the outline frames in the Image measurements exactly, you can specify an additional displacement of the outline frame in pixels here. X stands for a horizontal shift of the channel image to the right, Y for a vertical shift to the top.

Weighting

If you have specified a luminescence channel, you can specify the intensity of its use between 0..1 here.

Optimize Image measurements (R/G/B)

Optimizes - except for R(G)B images - the Image measurements of the R/G/B color channels for the best possible coverage. However, the quality of this automatic optimization depends heavily on the richness of detail and the absence of noise in the images.

The type of optimization can be selected using the button [image] . For an optimum result, you should optimize as few parameters as possible.

Image to be computed

Destin. directory

Destination directory of the final image. The source directory of the red image is proposed.

Choice of the destination directory

File name

Automatically produced file name of the resulting image. The "image" average time is included in this name.

Open the image measurement of the computed image

When you have computed an image, you can immediately open the measurement window. But the settings for the image measurements are not yet saved in a settings file. You must do it yourself eventually.

Display of the computed image (F4)

When you have computed an image, you can display it.

Observer

Observer name, which is used immediately to build the first part of the file name.

Image Info

Other information about the computed image, which are used immediately to build the last part of the file name. It is useful to record here information like "RGB", "R(G)B", "LRGB" or "LR(G)B".

Image Type

File type of the resulting file, which is used immediately to build the file name extension.

Quadratic Image Size

As a rule, the resulting image is quadratic. Its size can be defined here. On the preview on the right, you can see the size of the computed celestial body in the resulting image. The image definition is automatically computed in order to keep all image information.

Image Orientation

Define which pole should be on top. The equator is always horizontal in the resulting image.

Preview

The preview shows the size of the celestial body on the resulting image and the position of the equator and the central meridians of the particular channels.

Settings

Reset

After a security request, reinitialises all settings of the image computation.

Save/Load

Saves or loads the active settings for the image computation. The name of the settings file (*.ics) is displayed in the header of the image computation window.

(c) Grischa Hahn, Michel jacquesson 2020


Correction of planetary rotation

De-rotation of video streams (Mars, Jupiter, Saturn, Uranus, Neptune)

Computing of planetary images from thousands of frames from video recordings is very common. But the rapid rotation of Jupiter limits the duration of the recording at about 2 minutes. With a longer time, the details of the surface or the outline of the planet are blurred:

Jupiter, 2011-10-22, 10 minutes video from 21:33 - 21:43 UT, Red channel, Torsten Edelmann, Germany, Aperture 230mm, Registax 5.0

Alignment to cloud structures in the middle of planetary surface | Alignment to shadow of Io | Alignment "Centre of gravity"

The module De-rotation of video streams corrects the frames of a video recording so that all frames are related to an exact mean time. Then, longer recordings can be processed (till about 15 minutes). With the same image frequency, much more frames can be used or you can increase the exposure time with less noise on the frames. The two ways can be used to process hires planet images.

2 minutes video from 21:33 - 21:35 UT Registax 5.0 | 2 minutes video from 21:33 - 21:35 UT Correction of rotation with WinJUPOS Output "Stacked image" Wavelet sharpening with Registax 5.0 | 10 minutes video from 21:33 - 21:43 UT Correction of rotation with WinJUPOS Output "Stacked image" Wavelet sharpening with Registax 5.0 (Moon Io and shadow are not corrected)

The enhancement of the 2 minutes recordings with the rotation correction against the standard processing comes from the use of bilinear interpolation in the computing of the corrected image and also in the stacking.

The rotation correction requests the following procedure:
  1. Capture 10 minutes video -> Jupiter10min.avi.
  2. Compute normal image from a part of this video (maximum 2 minutes) -> Jupiter2min.png.
  3. Measure outline frame of this image with WinJUPOS-Image measurement and save settings file -> Jupiter2min.ims.
  4. Start module De-rotation of video streams.
  5. Original video = Jupiter10min.avi
  6. Set start time of video
  7. Image measurement of preliminary image from the original video = Jupiter2min.ims
  8. Start De-rotation of video stream
  9. Corrected video: compute normal image from the corrected video (Jupiter10min-DeRot.avi) with Registax -> Jupiter10min.png.
  10. Stacked image: you can use the wavelet sharpening function of Registax -> Jupiter10min.png.

Original video
Enter here the video to be corrected. Following videos are accepred:
  • AVI either grayscaled or RGB / 8 bit. Some compressed formats - linked with installed codecs - can be read, but compressed formats are not useful because important image informations are lost.
  • Lumenera SER files mono or Bayer-RGB/CYM / 8..16 bit.
Important:

WinJUPOS uses the first frame of the original video as reference image. In it is computed the mean background brightness and the threshold value for the separation of the sky background from the planet. Make sure that this image is valid.

Start time (UT)
Enter here the start time of the video in UT. In case of AVI data, the end time in UT will becomputed automatically.

End time (UT)
Enter here the end time in UT.

Image calibration (optional)

Image measurement of a preliminary image from the original video
The input of the measurement of a preliminary image is necessary for an exact rotation correction. Informations about size, inclination, image orientation (normal / mirror view), ratio of the camera pixels and the parameters of the LD compensation are used.

Pay attention to put a correct LD value for each separate image. If the values are too high (it can be tested in the module Image Measurement), the result is a very ugly limb effect in the final image/video:

If the option Compensation of field rotation in altitude over azimut mounts is activated, the input of the observation place and recording time must be made carefully.

Compensation of field rotation in altitude over azimut mounts
According to the position of the planet in the sky and the recording duration, the field rotation causes a trouble in case of azimutal telescope:

Without correction | With correction

Accurate single frame calibration
Determines the position of the celestial body for each video frame separately, independently of brightness variations, planetary moons and image captions.

Output
The choice of the output type depends essentially on the used recording conditions. For small and medium telescopes (until ~250 mm of aperture), the computing of a stacked image is most valuable. For bigger telescopes, a corrected video should be computed in order to be able to use the geometrical correction function of Registax 6. This gives better results because the atmospheric movements can be partially corrected:

Jupiter, 2011-10-14, 22:13, Red channel, Jean-Luc Dauvergne, France, Aperture 1000mm

Output "Stacked image" Wavelet sharpening with Registax 6.0 | Output "Corrected video" processed with Registax 6.0 and geometry correction
Corrected video

The output corrected video contains only the corrected frames from the rotation.

Original format | Output format
SER / AVI monochrome | SER monochrome
SER / AVI Bayer-RGB or RGB | SER RGB (version 3) otherwise:
AVI RGB < 2GB | AVI RGB
AVI RGB > 2GB | SER monochrome (R/G/B)
SER Bayer-RGB | SER monochrome (R/G/B)

See also: Program / Preferences / Options - Write RGB SER videos (SER version 3)

Stacked image

In a stacked image the rotation is corrected in all frames and all corrected images are stacked. The stacking is made without geometrical correction which is possible for example in Registax 6.

Reference time (UT)

The reference time is automatically computed and set to the mean of start and end times.

Processor utilization
For the computing, all available processors/processor cores of the system are used (Processor utilisation = 100%). If you need computing capacity for other works, you can deplete the capacity and increase it again.
(c) Grischa Hahn, Michel Jacquesson, 2018


De-rotation of video streams - Image calibration

Rough video images contain a lot of errors from the system: the noise from the CCD-camera, bright or dark pixels on the image, difference of sensibility of the pixels and impurities on the CCD sensor or in the route of the light in the recording system. These errors can be cancelled by a dark field and flat field image.

If the option Compensation of field rotation in altitude over azimut mounts is activated, this calibration must be done before or during the derotation because the images of the corrected video - containing the field rotation - do not correspond to the calibrated images.

Original image (rough image)

I

Dark frame

D

Flatfield

F'

Calibrated image
I'

Darkframe (D)
A darkframe is a frame made with the open camera, with the same exposure time and temperature as the rough image, best just before or after the original frame. It is used to cancel the noise produced by the dark electric currents. The dark frame is substracted from the rough frame (dark currents or dark frame correction). The pixels react strongly and in a different way to the temperature conditions, that is for a particular CCD temperature, each pixel produces a different current as dark. For a particular pixel, the dark current swings around a constant value, so that a correction is possible. Pixels with particular highdark current are called hot pixels.

In order to minimize the influence of the temperature noise of the sensor, it is recommended to make not only a single dark frame but a series of such images to produce a median dark frame called the master dark frame.

Flatfield (F)
In order to level the brightness differences which come from impurities on the CCD chip, disparities of sensitivity of the pixels or from the used optics (vignettage, reflections), a flatfield is recorded where the instrument is turned toward a uniform lighted surface. The rough frame (from which the dark frame has alreadybeen substracted) is then divided by the flatfield (flatfield correction) and multiplied by the mean value of the flatfield. For example, if a pixel is covered by 50% by dust, the measured intensity is reduced by the recorded object and also by the flatfield. The division by the small brightness value in the flatfield gives the true value, as there were no dust.
For the recording of a flatfield, a uniform lightened surface is required. The produced flatfield can be used for all images where the focussing of the telescope is unchanged, no new dust must come in the light route or a present dust must not change its place. A new position of the camera causes a displacement of the dusts on the image, then the flatfield cannot be used no longer. Then, the images cannot be corrected. A stable position of the camera is then necessary.

There are two ways of producing a flat field. First, at dawn or twilight, turn the telescope toward a uniform lighted part of the sky. If it is impossible, an artificial uniform light can be used, but this way is often difficult to do and the natural light of the sky is the easiest solution. For instance, a frosted grass in front of the telescope could be used to make a flat field, because the incident light is softened and scattered to produce a minimum of brightness differences.

Making a flatfield, the exposure time should be chosen so that the pixels contain about 2/3 of their capacity. Be aware that this flat field frame, like the other images, must be corrected by the substraction of a (master) dark frame before it can be used itself for a correction. For a most precise scientific use, the production of a master flat field is recommended because the ratio signal/noise is higher. This master is also made from several flat fields ( after the substraction of the (master) dark frame) producing a median value.

Flatfield offset (FO)
It is special dark frame for an uncorrected flat field.

Computation of different calibrated images:

D | I ' = (I - D)
F, FO | mF = average value for all image pixels in (F - FO) I ' = I / (F - FO) * mF
D, F, FO | mF = average value for all image pixels in (F - FO) I ' = (I - D) / (F - FO) * mF
D, F ' | F ' is a dark field corrected with a flat field mF ' = average value for all image pixels in F ' I ' = (I - D) / F ' * mF '

Sources:

Wikipedia
http://www.pixelmask.de
(c) Grischa Hahn, Michel Jacquesson, 2012


Monochrome Bildberechnung - Übersicht

Computation of polarization

With the module Computation of polarization you can compute the grade of polarization and the polarization angle of the light reflected or emitted by a celestial body. The process needs following requirements:

 You have to mount a polarization filter before your camera. The axis of the polarization filter has to be known.
How to determine the axis of a polarization filter?
You need strict polarized light. This is light which swings only in one plane.

A simple method to generate such light is known from the telescopic Sun observation (Herschel prism). Unpolarized light will be polarized after reflection on a glass plane under a reflection angle of ~60°.

After reflection the light swings only in a plane perpendicular to the plane defined by incident and reflected ray. If you rotate the polarization filter P in the position in with the darkest light, the axis of the filter is perpendicular to the swinging plane of the reflected light. Now you can mark the axis on the filter rings and mount the filter in the right position before the camera.

How to take images?
Variant 1:
The axis of the polarization filter lies parallel to the vertical direction of the image matrix. Camera and polarization filter are fixed connected.

Six or more images of the celestial body should be taken. Rotate camera and polarization filter between the shots so that you get an angle interval of about 180°. E.g. rotation angels of 0°, 30°, 60°, 90°, 120° and 150°:

Gray: Image matrix with vertical and horizontal direction; Black ring: Polarization filter with polarization axis

The angle Delta - described in Variant 2 below - is here generally 0°.

Variant 2:
The camera is fixed connected to the telescope, only the polarization filter can be rotated by the angle Delta (Δ) (+/-90°). A Delta angle of 0° means that the polarization axis is parallel to the vertical direction of the image matrix.

Gray: Image matrix with vertical and horizontal direction; Orange ring: Polarization filter - can be rotated by +/90° (Delta)

Six or more images of the celestial body should be taken. Rotate the polarization filter between the shots so that you get an angle interval of about 180°. E.g. shots with Delta = -90°, -60°, -30°, 0°, +30°, +60°. You have to record the Delta angle to every shot.

The method is based on monochromatic intensity values. For better image quality it is recommended to capture only monochromatic images. You can use colour filters to limit the light spectrum.

Editing the shots
You can stack or de-rotate the frames of your video as usual. Only sharpening is problematic. All common sharpening algorithms are unfortunately not suitable, since they change the brightness non-linearly.

Therefore, a two-step process is useful:

Image series a)
Sharpen your images as usual (e.g. with wavelets) and save the results as 8-bit JPEGs. Important is a well defined rim of the celestial body.

Image series b)
Do NOT sharpen your images and save the results as 16-bit TIFF/PNG or FITS. Important is that the celestial body has the same position and size on the image like the corresponding images in series a).

Measure the images of series a) with the module Image mesurements and save the measurement settings in a *.ims file. Make sure that the diameter of the outline frame does not change within the image series.

Afterwards, exchange in all image measurements of the image series a) the sharp 8-bit images against the blurred 16-bit images of the image series b) and save the image measurements settings under a new name.

A little mathematics
For each surface point on the celestial body, the corresponding image points in the images are determined and a function of the brightness (I) is determined as a function of the angle Kappa (Θ). Kappa is in this case the angle between the polarization axis of the filter and the north-facing rotational axis of the celestial body in the range of -90°..+90°:

For all brightness values (I) the unknown parameters (A, B, Φ) of the function
I = A * cos² (Θ - Φ) + B

are determined.

The angle Phi (Φ) is the polarization angle of the light related to the rotational axis of the celestial body (normal image orientation).

The grade of polarization (P) will be determined with the formula [1]:

P = A / (A + 2*B)

Computation of polarization
The user interface is similar to De-rotation of images or De-rotation of R/G/B frames.
  • First add all Image measurements (*.ims) to the image list.
  • Set all related Delta angels
  • Choose the destination directory, define Observer and Image info.
  • Start computation of polarization with F12.
Maximum polarization value

The standard value is 100%. If the output image is too dark and the maximum polarization is e.g. 10%, you can set Maximum polarization value to 10%. In this case image points with 10% polarization will be maximum bright (white).

Results of computations
You get three results:

[File name]_Polarization.[EXT]
 [File name]_PolarizationStdDev.[EXT]
[File name]_PolarizationAngle.[EXT]

If you press the button [image] after the computation, the corresponding Image measurement windows for the result images are opened. The numerical values for the polarization (P), the standard deviation of the polarization (σ) and the polarization angle (Φ) of each image point are displayed in the tab "Pos." under P, σP and Phi, respectively.

Below an example by Phil Miles from 2016-12-05 18:58.5 UT:

 Polarization P displayed as brightness (Gamma = 4.05)

Standard deviation of polarization displayed as brightness (Gamma = 4.05)

Polarization angle Φ displayed as colour

[1] Andrew Fearnside, Philip Masding, Chris Hooker, Polarimetry of moonlight: A new method for determining the refractive index of the lunar regolith, Icarus, Volume 268, April 2016, Pages 156-171, ISSN 0019-1035

(c) Grischa Hahn, 2017