PIPP マニュアル

惑星イメージング前処理


前書き

PIPPは、惑星の画像をRegistaxなどの画像スタッキングソフトウェアでスタックする前に前処理するために設計されたWindowsアプリケーションです。 PIPPの主な目的は、各画像フレームをトリミングし、最高品質のフレームのみを選択して、スタッキングソフトウェアのメモリと処理要件を削減することです。 たとえば、これにより、7200フレームのAVI（60 fpsで2分のAVI）から最高の1500フレームをトリミングして、Registaxでスタックできるようになります。 私のPCでは、Registaxはそれほど多くのフレームを持つAVIファイルを処理しませんが、1500の前処理されたビットマップファイルを簡単に処理できるため、これは非常に便利です。

PIPPはもともと、各惑星イメージングセッションで生成されると思われる多数の大きなAVIファイルの自分自身の処理を高速化するために作成されました。 PIPPが実際に処理ワークフローを実際にスピードアップするようになりました。PIPPを他の人が利用できるようにして、彼らが役立つかどうかを確認し、天文学コミュニティに少しだけ還元することにしました。


PIPPの機能

● サポートされているビデオファイル、SERビデオファイル、またはTIFF / BMP / FITS / JPEG / RAWカメライメージファイルから一連のイメージをロードします。

● ダーク、フラット、ダークフラットのキャリブレーションフレームでフレームをキャリブレーションします。

● カラーカメラから生フレームをデバイヤしてカラーフレームを作成します。

● 各フレームに完全に画像上にある惑星が含まれていることを確認し、含まれていないフレームを破棄します。

● 露出オーバーのフレームを確認して破棄します。

● 惑星をフレームの中心に置きます。

● 中心にある惑星をオフセットします。

● 中心にある惑星の周りの各フレームを切り抜きます。

● 各フレームに固定ゲインを適用します。

● 各フレームに固定ガンマ補正を適用します。

● 各フレームに中央値ノイズフィルターを適用します。

● 各フレームのストレッチヒストグラム（カラーイメージのR、G、Bチャネルを均等化）。

● 各フレームの品質を推定し、処理されたフレームを品質順に並べ替えます。

● ユーザーが指定した最高​​品質のフレームの数のみを保持します。

● カラーフレームをR、G、Bフレームに分割します。

● 処理されたフレームを一連のTIFF / BMP / FITS画像ファイルとして、単一のAVI / SERビデオファイルとして保存し、スタッキングまたはアーカイブの準備ができているか、アニメーションGIFとしてオンラインで共有できます。

PIPPダウンロード

現在サポートされているプラットフォーム。

Windows XP Service Pack 3以降のすべてのバージョンのWindows。

● PIPP（64ビット）Windowsインストーラー（v2.5.9）：ダウンロード

● PIPP（32ビット）Windows / Wineインストーラー（v2.5.9）：ダウンロード

*** SER形式でデータをキャプチャする場合は、他のアプリケーション SERプレーヤーを確認してください。***

FFmpeg

v2.2.0以降、PIPPはLGPLv2.1でライセンスされた優れたFFmpegのDLLを使用します。 FFmpegソースはここからダウンロードできます。 このコードを個別にインストールする必要はなく、必要なすべてのコンポーネントはPIPPのインストーラーに含まれていることに注意してください。


PIPPの構成

PIPPは一連のタブ付きページで構成されるシンプルなアプリケーションであり、最初に開いたPIPPが最初のタブである[ソースファイル]タブで起動します。

PIPPの推奨される使用方法は、左から右に1つずつタブを操作することです。 各タブには、処理のさまざまな側面に関するコントロールとオプションがあり、最後の[処理を実行]タブは処理が実際に行われる場所です。 各タブ付きページのコントロールについては、このページの上部にリンクされているマニュアルページで説明しています。 タブ付きページの外側にあるすべてのコントロールについて、以下で説明します。

テストオプションボタン

このボタンは、最初のフレームが処理された後に終了し、出力フレームを画像プレビューウィンドウに表示する、非常に迅速なテスト実行を開始します。 このテストオプション処理の実行により、現在選択されているオプションをすばやくテストできます。

画像プレビューウィンドウ

上記のように、出力フレームが生成された場合、テストオプション処理の実行が完了すると、画像プレビューウィンドウが開きます。 これは、完全なモノクロフレームを表示する画像プレビューウィンドウです。

これはフルカラーのフレームを示す画像プレビュー画像です

画像プレビューウィンドウには、画像に表示される最大ピクセル値も表示されます。カラーフレームには、赤、緑、青に個別の値が指定されています。

画像プレビューウィンドウは画像を適切なサイズに自動ズームし、ユーザーはズームコントロールを使用して手動でズームを調整できます。 画像ペインの任意の場所をダブルクリックすると、いつでも元のズームレベルに戻すことができます。

ファイルメニュー

● ファイル->ソースファイルの追加

このメニュー項目は、[ソースファイル (Source Files) ]タブの[ソースファイルの追加 （Add Source Files）]ボタンを押すのと同じです。

● ファイル->すべてのファイルを削除

このメニュー項目は、[ソースファイル]タブの[すべてのファイルを削除 （Remove All Files）]ボタンを押すのと同じです。

● ファイル->終了（Quit）

このメニュー項目はPIPPを終了します。

オプションメニュー

● オプション->オプションのリセット（Reset Options）

このメニュー項目は、すべてのオプションをデフォルト値にリセットします。

● オプション->リセットオプションを元に戻す（Undo Reset Options）

このメニュー項目は、すべてのオプションを、最後に[オプション]> [オプションのリセット（Reset options）]メニュー項目が使用される前の値に戻します。

● オプション->保存オプション（Save Options）

このメニュー項目は、現在選択されているオプションを、後でロードできるPIPPオプションファイル（.pof）に保存します。

● オプション->オプションの読み込み（Load Options）

このメニュー項目は、以前に保存されたPIPPオプションファイル（.pof）からオプションの完全なセットをロードします。

● オプション->最後のセッションからオプションをロード（Load Options From Last Session）

このメニュー項目は、すべてのオプションを、PIPPが最後に閉じられたときの値に戻します。

● オプション->拒否されたフレームを保存（Save Rejected Frame）

このメニュー項目は、拒否されたフレームの保存を切り替えます。 通常、オブジェクトの検出に失敗したために拒否されたフレームは単純に破棄されますが、このオプションを有効にすると、後で検査するために独自のフォルダーに保存されます。

● オプション->オブジェクト検索デバッグ（Object Find Debug）

このメニュー項目は、オブジェクト検索デバッグモードを切り替えます。 有効にすると、PIPPは検出されたオブジェクトの周りに長方形を描画し、オブジェクト検出が期待どおりに機能しない状況をデバッグできるようにします。 このオプションが必要になることはほとんどありませんが、PIPPが検出したものについてある程度の実行可能性を提供します。

ソースファイル

画像ファイル

Image Files

画像ファイル一覧 Image Files List

この領域は、処理の開始時にPIPPが処理する画像ファイルのリストです。 ファイルは、Windowsエクスプローラウィンドウからドラッグアンドドロップすることでリストに追加できます。 リスト内のファイルをクリックして選択し、Deleteキーを押すと、リストからファイルを削除できます。 [ソースファイルの追加]、[選択したファイルの削除]、および[すべてのファイルの削除]ボタンを使用して、ソースファイルリストにファイルを追加/ソースファイルから削除することもできます。 上矢印ボタンと下矢印ボタンを使用して、リスト内で上または下に移動するファイルを選択し、適切な上/下ボタンを押すことにより、ソースファイルリストを並べ替えることができます。

リスト内のファイルを右クリックすると、表示されるファイルの詳細からファイルを削除できるサブメニューが表示されます。

複数のソースファイル　Multiple Source Files

このコントロールは、複数のソースファイルの処理方法を選択します。 ソースファイルリストにファイルが1つしかない場合、このコントロールは効果がありません。

バッチモード　Batch Mode

ソースファイルリストの各ファイルは、選択したオプションを使用して個別に処理されます。 これは、同じオプションを使用してファイルを1つずつ処理するのと同じです。

結合モード　Join Mode

すべての入力ファイルが連結され、1つのファイルであるかのように処理されます。 これは、複数の短いキャプチャが連続して行われ、1つのキャプチャであるかのように処理する必要がある場合に役立ちます。

オプションを最適化　Optimise Options For

このコントロールはオプションであり、実際に使用する必要はありませんが、PIPPにイメージングの実行時間を通知するために使用できます。 このコントロールを使用してイメージングのタイプを指定すると、PIPPの他のタブのオプションのデフォルト値がそのタイプのイメージングに合うように自動的に変更されます。さらに、そのタイプのイメージングに適さないオプションは無効になるため、 選択されました。 一般に、正しいオプションを選択するための手順が簡略化されるため、ここで行われるイメージングのタイプを選択することには価値があります。 このコントロールを使用して変更されたオプションの色は、選択されたオプションの色と一致するように変更されます。

惑星　Planetary

●各フレームには、最小サイズが25ピクセルの完全なオブジェクトが含まれていることが確認され、含まれていないオブジェクトは拒否されます。

●惑星は各フレームの中心にあります。

●フレームは448 x 448ピクセルにトリミングされます

ISS

●各フレームは、最小サイズが10ピクセルの完全な惑星が含まれていることを確認し、そうでないものは拒否します。

●オブジェクトは各フレームの中央に配置されます。

●フレームは300 x 300ピクセルにトリミングされます。

●出力フレームは、個別のTIFF画像ファイルとして保存されます。

●保存されたTIFFファイルはそれぞれ、元のフレーム番号として名前が付けられるため、どのファイルがグループ化されているかがわかります。

太陽/月のクローズアップ　Solar/Lunar Close-up

●オブジェクト検出関連のすべてのオプションが無効になります。

ソーラー/ルナフルディスク　Solar/Lunar Full Disc

●各フレームは、最小サイズが50ピクセルの完全なオブジェクトが含まれていることを確認し、含まれていないオブジェクトは拒否します。

●惑星は各フレームの中心にあります。

●フレームは1200 x 1200ピクセルにトリミングされます。

●雲の影響を受けるフレームを簡単に削除できるように、フレームは合計ピクセル値の順に並べ替えられます。

●出力フレームは、個別のTIFF画像ファイルとして保存されます。

惑星アニメーション　Planetary Animation

●各フレームには、最小サイズが25ピクセルの完全なオブジェクトが含まれていることが確認され、含まれていないオブジェクトは拒否されます。

●オブジェクト検出の最小ピクセル値は20に設定されています。

●惑星は各フレームの中心にあります。

●ヒストグラムストレッチは95％で有効になり、R、G、Bの個別のストレッチは無効になり、画像の色が保持されます。

●アニメーションオプションは、順方向再生の最後に最終フレームを20回繰り返すように変更されました。

●アニメーションオプションは、シーケンス全体を5回繰り返すように変更されています。

●出力AVIコーデック「FMP4（MPEG-4 Lossy Compression）」が選択されています。

●出力AVIフレームレートは10フレーム/秒に設定されています。

ダークファイル

Dark Files

ダークファイル一覧　Dark Files List

この領域は、暗いファイルのみを含む画像ファイルのリストです。 これらのファイルはオプションですが、存在する場合、これらのファイル内のすべてのフレームがスタックされ、マスターダークフレームが生成されます。 このマスターダークフレームは、処理されるすべての画像フレームから差し引かれます。

ファイルは、Windowsエクスプローラウィンドウからドラッグアンドドロップすることでリストに追加できます。 リスト内のファイルをクリックして選択し、Deleteキーを押すと、リストからファイルを削除できます。 [ダークファイルの追加]、[選択したファイルの削除]、および[すべてのダークファイルの削除]ボタンを使用して、ダークファイルリストにファイルを追加/削除することもできます。

リスト内のファイルを右クリックすると、表示されるファイルの詳細からファイルを削除できるサブメニューが表示されます。

ダークフレームオプション　Dark Frame Options

ダークフレームの減算の有効　Enable Dark Frame Subtraction

このコントロールは、ダークフレームの減算を有効または無効にします。 このコントロールは、ダークファイルリストからすべてのファイルを削除せずに、ダークフレームの減算を簡単に無効にできるようにするために提供されています。

マスターダークフレームを保存　Save Master Dark Frame

このコントロールを有効にすると、画像の処理時に生成されるマスターダークフレームが、PIPPが生成するログファイルと共にTIFF形式で保存されます。

ホットピクセルオプション　Hot Pixel Options

ホットピクセル置換の有効　Enable Hot Pixel Replacement

ダークフレームの減算は、明らかなダークピクセルを発生させることにより、ホットフレームが画像フレームの明るい領域から減算される問題を引き起こす可能性があります。 ホットピクセル置換は、画像フレームピクセルからダークフレームピクセルを減算するのではなく、隣接するピクセルから画像フレーム内のホットピクセルの値を推定することにより、この問題を回避します。 これにより、画像の明るい領域に暗いピクセルが現れる問題が解消されます。

ホットピクセルしきい値％　Hot Pixel Threshold %

このコントロールは、マスターダークフレームピクセルがホットピクセルとして扱われるために、それ以上である必要がある最大ピクセル値のパーセンテージを指定します。 この値の設定が低すぎると、多くのピクセルがホットピクセルとして処理され、画像処理が遅くなり、結果のフレームに望ましくないアーティファクトが生じます。

データはベイヤーパターンのモノクロ　Data Is Monochrome With Bayer Pattern

ホットピクセルの値を推定するとき、アルゴリズムは、画像がベイヤーパターンの生のカラー画像であるかどうかを知る必要があり、これはこのコントロールで指定されます。 この場合、異なるピクセルを使用してホットピクセルの値を推定し、同じ色のピクセルのみがホットピクセル推定計算に使用されるようにします。

フラットファイル

Flat Files

フラットファイル一覧　Flat Files List

この領域は、フラットフレームファイルのみを含む画像ファイルのリストです。 これらのファイルはオプションですが、存在する場合、これらのファイル内のすべてのフレームがスタックされ、マスターフラットフレームが生成されます。 処理されるすべての画像フレームは、このマスターフラットフレームで分割され、フラットフレーム補正です。 フラットフレーム補正は、ケラレやダストバニー、ピクセル間の感度のばらつきなど、光路の歪みによって引き起こされる画像のアーティファクトを除去するために使用されます。

フラットフレームオプション　Flat Frame Options

フラットフレーム補正を有効にする　Enable Flat Frame Correction

このコントロールは、フラットフレーム補正を有効または無効にします。 このコントロールは、フラットファイルリストからすべてのファイルを削除せずにフラットフレーム修正を簡単に無効にできるようにするために提供されています。

マスターフラットフレームを保存　Save Master Flat Frame

このコントロールを有効にすると、画像の処理時に生成されるマスターフラットフレームが、PIPPが生成するログファイルと共にTIFF形式で保存されます。

フラットダークファイル

Flat Dark Files

フラットダークファイル一覧　Flat Dark Files List

この領域は、フラットイメージファイルのダークファイルのみを含むイメージファイルのリストです。 これらのファイルはオプションですが、存在する場合、これらのファイルのすべてのフレームがスタックされ、マスターフラットダークフレームが生成されます。 このマスターフラットダークフレームは、マスターフラットフレームが生成されるときに、すべてのフラットフレームから減算されます。

ファイルは、Windowsエクスプローラウィンドウからドラッグアンドドロップすることでリストに追加できます。 リスト内のファイルをクリックして選択し、Deleteキーを押すと、リストからファイルを削除できます。 [フラットダークファイルの追加]、[選択したファイルの削除]、および[すべてのフラットダークファイルの削除]ボタンを使用して、フラットダークファイルリストにファイルを追加/削除することもできます。

リスト内のファイルを右クリックすると、表示されるファイルの詳細からファイルを削除できるサブメニューが表示されます。

フラットダークフレームオプション　Flat Dark Frame Options

フラットダークフレーム減算の有効　Enable Flat Dark Frame Subtraction

このコントロールは、フラットフレームからのフラットダークフレームの減算を有効または無効にします。 このコントロールは、フラットダークファイルリストからすべてのファイルを削除せずにフラットダークフレームの減算を簡単に無効にできるようにするために提供されています。

マスターフラットダークフレームを保存　Save Master Flat Dark Frame

このコントロールを有効にすると、画像の処理時に生成されるマスターフラットダークフレームが、PIPPが生成するログファイルと共にTIFF形式で保存されます。

入力オプション

Input Options

Raw画像ファイルオプション　Raw Image File Options

この制御グループは、入力ステージでの生のカメラ画像の処理方法を制御します。 PIPPはコード形式DCRAWを使用してrawファイルをデコードするため、ほとんどのカメラのrawファイルがサポートされます。

Raw画像ホットピクセルフィルターの有効　Enable Raw Image Hot Pixel Filter

このコントロールは、RAW画像ファイルのホットピクセルフィルターを有効にします。 このフィルターは、ホットピクセルを検出し、同じ色の隣接するピクセルから計算された値に置き換えます。

Debayer Rawイメージファイル　Debayer Raw Image Files

このコントロールにより、ベイヤーパターンのあるモノクロ画像からカラー画像へのディベイヤー操作が可能になります。このオプションはデフォルトで有効になっていますが、未処理のモノクロデータが必要な場合は無効にすることができます。これにより、処理チェーンのさらに下のツールでディベイヤリング操作を実行できます。または、データのディベイヤされていないバージョンはカラーバージョンよりもはるかに小さいため、アーカイブ目的で使用できます。

Debayerアルゴリズム　Debayer Algorithm

このコントロールは、DCRAWでサポートされているファイルからraw画像ファイルをデベイアするために使用するアルゴリズムを選択します。個人的には、デフォルト以外のアルゴリズムが非常に遅いことを除いて、これらのアルゴリズムが与える結果に違いはありません。

出力色空間　Output Colour Space

このオプションは、カメラセンサーが認識するRGB値から、ディスプレイに表示または印刷されたときに人間の目が見ているものをより代表する標準の色空間に変換します。この操作、または類似の色空間への操作は、生のカメラデータを一般的な画像形式に変換するすべてのソフトウェアによって実行されます。ただし、アストロイメージングの目的では、カメラセンサーの色空間のデータを操作し、スタッキング後の処理で正しく表示されるように変更することをお勧めします。もう1つの考慮事項は、カラースペースを変更すると処理が遅くなり、処理時間が長くなることです。

ハイライトの回復　Highlight Recovery

通常の地上写真では、一部のピクセルが最大値で露出オーバーになることは珍しくありません。これが修正されない場合、これらの露出過度の領域は不自然なピンクまたは紫の色相になります。この制御により、いくつかのアルゴリズムの1つを使用してこの問題を修正し、より自然なイメージを生成できます。ただし、天体写真では、通常、ピクセルが露出過度にならないように注意が払われているため、このオプションは必要ありません。

AVIファイルのオプション　AVI File Options

このコントロールグループは、特定のコーデックを含むAVIファイルが入力ステージでどのように処理されるかを制御します。

Y800コーデックフレームを厳密にデコード　Decode Y800 Codec Frames Strictly

このコントロールは、Y800コーデックを使用するAVIファイルのImaging Source互換Y800デコードではなく、厳密なY800コーデックデコードを有効にします。 一般に、この厳密な動作は望ましくありません。誤って選択された場合、16〜235の範囲外のピクセル値がクリップされます。

日付/時刻の抽出　Date/Time Extraction

このコントロールグループにより、PIPPはファイルのファイル名からビデオストリームの日付と時刻を抽出できます。 この日時情報とフレーム/秒の値により、PIPPは各フレームのタイムスタンプを計算できます。 この機能により、PIPPでフレームタイムスタンプ付きのSERファイルまたはWinJUPOSフレンドリーなファイル名を持つファイルを生成できます。

入力ファイル名がタイムスタンプを含むSERファイルである場合（SERファイルではタイムスタンプはオプションです）、PIPPはタイムスタンプから必要なすべての日時情報を取得するため、このコントロールグループは必要ありません。

ファイル名からファイルの開始日時を抽出する　Extract File Start Date/Time From Filename

このコントロールにより、ファイル名から日付と時刻を抽出できます。

現地時間から世界時への変換　Convert From Local Time To Universal Time

このコントロールは、ファイル名の時間が世界時ではなく現地時間であることをPIPPに通知します。 このオプションはオフにする必要があります。変換が必要ないため、ファイル名に世界時の値が含まれています。

入力ファイル名の日付/時刻形式　Input Filename Date/Time Format

このオプションは、PIPPが日付/時刻の詳細を抽出できるように、入力ファイル名の日付/時刻の形式を指定します。 いくつかの固定日付/時刻マスクが利用可能で、他の日付/時刻形式と一致するように設定できる3つのカスタム設定があります。

形式の文字は次のとおりです。

Y -年の文字（2または4が必要）

M -月の文字（2つ必要）

D -日の文字（2つ必要）

h -時間文字（2つ必要）

m -分の文字（2つ必要）

s -2番目の文字（ 't'が使用されない限り2が必要）

t -分の文字の一部（ 's'が使用されない限り1が必要）

？-任意の1文字に一致（オプション）

n -任意の1桁の文字に一致します（オプション）

N -1桁以上の数字に一致します（オプション）

他の文字は完全一致が必要です。

1秒あたりの入力フレーム数（タイムスタンプのないSERファイルの場合）　Input Frames Per Second (For SER Files Without Timestamps)

このコントロールは、タイムスタンプを含まないSERファイルに使用する1秒あたりのフレーム数を指定します。

SERファイルオプション　SER File Options

この制御グループは、入力ステージでのSERファイルの処理方法を制御します。

ピクセル深度　Pixel Depth

このオプションにより、SERファイルヘッダーのピクセル深度値を上書きできます。 SERファイルヘッダーのピクセル深度値が正しくないことが判明しない限り、このオプションはお勧めできません。

入力フレーム範囲　Input Frame Range

このコントロールにより、必要な開始フレームと終了フレームを指定するか、ビデオの中心から使用するフレーム数を指定することで、処理される入力フレームを制限できます。 これにより、入力ビデオを小さなビデオに分割したり、ビデオの中心から短いスライスを抽出したりできます。これは、WinJUPOSと組み合わせて使用してビデオを逆回転させる場合に役立ちます。

入力フレームのドロップ　Input Frame Dropping

このコントロールは、1つのフレームが処理された後にいくつかのフレームをスキップすることにより、処理されるフレームの数を減らします。 この機能は主に、通常、各フレームが何度も繰り返されるビデオカメラを統合してAVIファイルを処理するためのものです。

このコントロールが0に設定されている場合、入力フレームはドロップされません。

入力フレームカラー/モノクロ　Input Frame Colour/Monochrome

デフォルトでは、PIPPは最初のフレームを分析して、入力フレームがカラーかモノクロかを自動検出します。 PIPPが何らかの理由でこれを誤って検出した場合、このコントロールを使用して自動検出アルゴリズムをオーバーライドできます。

ベイヤー処理が必要なカラーカメラの生画像は、モノクロフレームと見なされます。 モノクロフレームはカラーフレームとして処理できますが、これにより、出力フレームが必要なサイズの3倍になります。

色Debayer　Colour Debayer

Debayerモノクロフレーム　Debayer Monochrome Frames

このコントロールは、このタブに独自のディベイヤコントロールを持たないファイルタイプのカラーカメラからの未加工キャプチャのディベイヤを有効にします。 このコントロールによってディベイヤリングが有効になっている場合、ディベイヤリングの詳細は、「カラーディバイヤーオプション」グループのコントロールによって制御されます。 モノクロカメラからのキャプチャ、またはすでにカラーになっているカラーカメラからのキャプチャでは、ディベイヤーは必要ありません。

センタリング/クロッピング時にバイエルパターンを保護（ディベイヤしない）　Protect Bayer Pattern When Centring/Cropping (Do Not Debayer)

このコントロールは、カラーカメラからの未加工のキャプチャを処理するがディベイヤしない場合に使用されます。 これにより、画像のベイヤーパターンがセンタリングおよびクロッピング操作中に保持されます。

カラーデベイヤーオプション　Colour Debayer Options

このコントロールグループは、有効になっている場合のディベイヤー操作の詳細を制御します。

Debayerアルゴリズム　Debayer Algorithm

このコントロールは、使用されるディベイヤーアルゴリズムを選択します。

●双線形―これは使用する推奨アルゴリズムであり、高速で高品質の結果を生成します。

●Smooth Hue―この代替アルゴリズムはかなり低速です。

デバイヤーパターン　Debayer Pattern

カラーフレームを生成するためにカラーカメラから生のモノフレームをディベイヤするために使用するパターンを選択します。

処理オプション

Processing Options

入力ゲインとガンマ補正　Input Gain And Gamma Correction

入力ゲイン　Input Gain

この固定ゲインは、処理前にすべてのフレームに適用されます。 値が1.0の場合、ゲインは適用されません。

ガンマ補正値　Gamma Correct Value

この固定ガンマ補正は、処理前にすべてのフレームに適用されます。 値1.0は、ガンマ補正が適用されないことを意味します。

ノイズフィルター　Noise Filter

この制御により、フレームごとにノイズフィルターの中央値が有効になります。 フィルターは、モノクロフレームと未加工のカラーフレーム（ベイヤーパターンを含むモノクロフレーム）で機能します。

中央値ノイズフィルターを有効にする　Enable Median Noise Filter

ノイズフィルターを有効にします。

モノクロ変換　Monochrome Conversion

このコントロールを使用すると、カラーフレームをモノクロフレームに変換できます。 これは、ターゲットに実際の色情報がなく、カラーフレームがモノクロフレームの3倍になる月または太陽のイメージングにカラーカメラが使用される場合に役立ちます。

カラーをモノクロに変換　Convert Colour To Monochrome

カラーからモノクロへの変換を有効にします。

ヒストグラム均等化　Histogram Equalisation

このコントロールグループは、0から指定された最大ピクセル値までのデータ範囲を使用するように、各フレームのヒストグラムのストレッチを制御します。 カラー画像の場合、赤、緑、青のチャネルは個別に引き伸ばされ、すべて同じデータ範囲を使用します。 これにより、スタックされた画像を処理するときの色補正が容易になります。

ヒストグラムのブラックポイントをXX％に設定　Set Histogram Black Point to XX%

このコントロールにより、ヒストグラムの白色点を最大ピクセル値の指定したパーセンテージに拡大できます。

ヒストグラムの黒点を0％に設定　Set Histogram Black Point to 0%

このコントロールを使用すると、ヒストグラムの黒点を0に引き伸ばすことができます。これは、高いゲイン値またはガンマ値で、または明るい背景が暗くなる明るい（おそらく日光）背景でキャプチャされたフレームに役立ちます。

ヒストグラムストレッチR、G、Bチャネルを個別に有効にする　Enable Histogram Stretch R, G and B Channels Individually

カラー画像の場合、このコントロールを使用すると、赤、緑、青のチャネルを個別にストレッチして、すべて同じデータ範囲を使用することができます。 これにより、最終的な画像の色補正が容易になります。 このオプションが有効になっていない場合、元のカラーバランスが保持されます。 このオプションは、モノ画像には影響しません。

％ヒストグラムストレッチ　% Histogram Stretch

各フレームのヒストグラムを最大のxx％までストレッチします。 これにより、すべてのフレームのピクセル値の範囲が同じになります。 カラー画像の場合、赤、緑、青のチャンネルが引き伸ばされます

オプションで個別に使用して、すべてが同じデータ範囲を使用するようにします。これにより、スタック後の色補正が容易になります。

露出オーバーの検出　Overexposed Detection

このコントロールグループは、露出オーバーのフレームの拒否を制御します。 これは、薄い雲が変化するために、キャプチャされるオブジェクトの明るさが変化する場合に役立ちます。 これにより、露出オーバーのフレームを自動的にスタックから除外できます。

露出オーバーのピクセルがあるフレームを拒否する　Reject Frames With Overexposed Pixels

このコントロールをチェックして、露出オーバーのフレーム拒否機能を有効にする必要があります。

拒否前の最大値ピクセル数　Number Of Maximum Value Pixels Before Rejection

これは、フレームが露出オーバーと見なされる前に最大値（255）でなければならないフレーム内のピクセル数を指定します。

フリップして回転　Flip And Rotate

このコントロールグループを使用すると、すべてのフレームを反転または回転できます。

左右反転　Flip Horizontally

水平軸に沿ってフレームを反転できるようにします。

垂直に反転　Flip Vertically

垂直軸に沿ってフレームを反転できるようにします。

回転　Rotation

フレームを90度の倍数だけ回転します。

オブジェクト検出　Object Detection

このコントロールグループは、フレーム内の完全なオブジェクトの検出に関連するオプションを制御します。

オブジェクト検出を有効にする（オブジェクトのないフレームを拒否する）　Enable Object Detection (Reject Frames Without Object)

このコントロールにより、オブジェクトが各画像に存在し、完全にフレーム内にあることを確認できます。 このチェックに失敗したフレームは破棄されます。 このコントロールグループ内の他のコントロールをアクティブにするには、このコントロールを有効にする必要があります。

各フレームの中央にオブジェクト　Centre Object In Each Frame

このオプションにより、オブジェクトのセンタリング機能が有効になり、スタッキングソフトウェアの作業が容易になります。

自動最小ピクセル値　Auto Minimum Pixel Value

この制御により、オブジェクト検出の最小ピクセル値の自動計算が可能になります。 この自動計算を有効にすることをお勧めしますが、自動値が正しい結果を生成していないことが判明した場合は、ここで無効にすることができます。

自動が選択されていない場合の最小ピクセル値　Minimum Pixel Value When Auto Is Not Selected

このコントロールは、最小ピクセル値の自動計算が自動最小ピクセル値コントロールによって無効にされている場合に、オブジェクト検出に使用される最小ピクセル値を指定します。

最小オブジェクトサイズ（ピクセル）　Minimum Object Size (pixels)

オブジェクトが検出される前のピクセル単位の最小サイズ。

オブジェクトにハードエッジがあります　Object Has Hard Edge

オブジェクトが検出されると、オブジェクトのソフトエッジを可能にするために、フレーム内に完全にあるかどうかを判断するときに、PIPPは通常、サイズをわずかに大きくします。 これは、惑星などのソフトエッジを持つオブジェクトに非常に役立ちますが、ISS、月、太陽などのオブジェクトにはソフトエッジがなく、オブジェクトサイズが大きくなると、適切なフレームが破棄される可能性があります。 このオプションを選択すると、オブジェクトはハードエッジであると見なされ、オブジェクトが完全にフレーム上にあるかどうかを判断するときにそのサイズは増加しません。

トリミング　Cropping

このコントロールグループは、フレームのトリミングを制御します。 オブジェクトが各フレームの中央に配置されている場合、オブジェクトの周りでトリミングが行われます。 中央に配置されているオブジェクトがない場合、トリミングは各フレームの中央で行われます。

トリミングを有効にする　Enable Cropping

このコントロールは、トリミングを有効にするために使用されます。

クロップ幅（X）　Crop Width (X)

このコントロールは、最後にトリミングされたフレームの幅を指定します。

作物の高さ（Y）　Crop Height (Y)

このコントロールは、最後にトリミングされたフレームの高さを指定します。

Xオフセット　X Offset

このコントロールは、X軸のトリミング領域のオフセットを指定します。 負の値を指定するとトリミング領域が左に移動し、正の値を指定するとトリミング領域が右に移動します。

Yオフセット　Y Offset

このコントロールは、Y軸のトリミング領域のオフセットを指定します。 負の値はトリミング領域を下に移動し、正の値はトリミング領域を上に移動します。

品質オプション

Quality Options

品質見積もり　Quality Estimation

品質推定機能により、PIPPは低品質のフレームを拒否し、フレームを品質順に並べ替えることもできます。

品質推定を有効にする　Enable Quality Estimation

これは、品質推定を有効にするためのマスターコントロールです。 このコントロールは、このページの他のコントロールをアクティブにする前に有効にする必要があります。

品質順でフレームを並べ替え　Reorder Frames In Quality Order

このコントロールにより、フレームを品質順に並べ替えることができます。

品質制限　Quality Limiting

このコントロールグループは、すべてのフレームを保持するか、指定した数の最高品質のフレームのみを保持するかを制御します。

最高品質のフレームのみを保持　Only Keep The Best Quality Frames

このコントロールを有効にすると、指定した数の最高品質のフレームのみが保持されます。 保持するフレーム数は、下の「保持する最高品質のフレーム数」コントロールで指定します。

保持する最高品質のフレームの数　Number Of Best Quality Frames To Keep

このコントロールは、「最高品質のフレームのみを保持」コントロールが有効になっている場合に保持する最高品質のフレームの数を指定します。

品質アルゴリズムの選択　Quality Algorithm Selection

PIPPには、4つの異なる品質アルゴリズムがあります。デフォルトのアルゴリズム、Ninoxのオリジナルのアルゴリズム、ピークヒストグラムベースのアルゴリズム、および総ピクセル値アルゴリズムです。 このコントロールグループは、品質推定に使用する品質アルゴリズムを選択します。

デフォルトのPIPP品質アルゴリズム　Default PIPP Quality Algorithm

これは、段階的なコントラストの変化よりもシャープなコントラストの変化により大きな重みを与えるように設計された、Ninoxの元の品質アルゴリズムの修正バージョンです。 一般に、これはPIPPで使用可能な3つのアルゴリズムの中で最高品質のアルゴリズムであることがわかっており、ほとんどの場合に推奨される選択です。

オリジナルのNinox品質アルゴリズム　Original Ninox Quality Algorithm

これは、Ninoxから採用された元の品質アルゴリズムです。 この元のアルゴリズムは、キャプチャされたビデオの品質が非常に高い場合に、わずかに優れた結果を生成することがありますが、ほとんどの場合、デフォルトの品質アルゴリズムの方が適しています。

ピークヒストグラムベースの品質アルゴリズム　Peak Histogram Based Quality Algorithm

このアルゴリズムは、他の2つの品質アルゴリズムを処理するために、キャプチャされたビデオに実際の詳細が存在しない異常なケースを処理するために開発されました。 この状況は、ターゲットの惑星がフレーム内で非常に小さく、おそらく露出オーバーでさえある、キャプチャされたビデオで見られました。 上記の品質アルゴリズムは、このタイプのデータを適切に処理しないため、シャープなフレームではなく、オブジェクトがぼやけている、または伸びているフレームが優先されます。 このアルゴリズムは、この状況でフレームを選択するためのはるかに優れた機能を果たし、他のアルゴリズムで満足のいく結果が得られない場合は試す価値があります。

総ピクセル値品質アルゴリズム　Total Pixel Value Quality Algorithm

このアルゴリズムは、オブジェクト検出が有効な場合は画像内のオブジェクトのすべてのピクセル値を加算し、オブジェクト検出が有効でない場合は画像内のすべてのピクセル値を加算します。 このすべてのピクセル値の合計は、フレームの品質値として使用されます。 このアルゴリズムは、画像内のクラウドが総ピクセル値を低下させるフルディスクの太陽/月のイメージングを行うときに、クラウドの影響を受ける画像を検出するためのものです。

品質アルゴリズムオプション　Quality Algorithm Options

デフォルトおよび元の品質アルゴリズムの場合、品質推定は、一連のサブサンプリングされた画像のローカルコントラスト値の合計（隣接するピクセル間の差の平方和）の計算に基づいています。 より高い計算値は、より高品質の画像を示します。 使用されるサブサンプリングされた画像の数とサンプリングパラメーターは、「最大サブサンプル値」、「最小サブサンプル値」、および「サブサンプル増分値」コントロールを使用して制御されます。 これらの3つのパラメーターは、他の品質アルゴリズムが選択されている場合は効果がありません。

最大サブサンプル値　Maximum Subsample Value

品質推定の最大サブサンプル値。

最小サブサンプル値　Minimum Subsample Value

品質推定の最小サブサンプル値。

サブサンプルの増分値　Subsample Increment Value

品質推定のためのサブサンプル増分値。

品質の重み付け　Quality Weighting

これは、最終的なスタックで最高品質のフレームの重みを増やすことを目的とした実験的な関数です。 これは実際には非常に単純な手順であり、いくつかのスタックされた画像に改善をもたらすことができます。 この機能が行うことは、フレームの最高の25％を2回複製し、次の最高の25％を1回複製することです。

これは、1000フレームスタックが1750フレームスタックになることを意味します。 これにはノイズリダクションの利点はありませんが、最高品質のフレームは、最終的なスタックされたイメージにより大きな影響を与えます。

品質の重み付けを有効にする　Enable Quality Weighting

このコントロールは、品質の重み付け機能を有効にします。

アニメーションオプション

Animation Options

フォワードプレイ　Forward Play

すべてのフレームを順方向に再生する（無効にすることはできません）　Play All Frames In Forward Order (Cannot Be Disabled)

フレームは常に順方向に再生されるため、このコントロールを無効にすることはできません。

最終フレームを繰り返して一時停止を作成　Repeat Final Frame To Create Pause

このコントロールが有効になっている場合、最後のフレームは、以下の「最後のフレームの繰り返し数」コントロールで指定された回数だけ繰り返されます。

最後のフレームの繰り返し数　Number Of Last Frame Repeats

このコントロールは、名声の前方再生の最後に遅延を作成するために、最後のフレームを繰り返す回数を指定します。

逆再生　Reverse Play

順方向再生後にすべてのフレームを逆順で再生する　Play All Frames In Reverse Order After Forward Play

このコントロールは、順方向の再生が完了した後にすべてのフレームの逆方向の再生を可能にします。

最終フレームを繰り返して一時停止を作成　Repeat Final Frame To Create Pause

このコントロールは有効になっています。逆再生の最後のフレームは、以下の「最後のフレームの繰り返し数」コントロールで指定された回数だけ繰り返されます。

最後のフレームの繰り返し数　Number Of Last Frame Repeats

このコントロールは、名声の逆再生の最後に遅延を作成するために、最後のフレームを繰り返す回数を指定します。

完全なシーケンスの繰り返し　Complete Sequence Repeat

すべてのフレームを順番に繰り返す　Repeat All Frames In Sequence

このコントロールは、フォワードプレイおよびリバースプレイコントロールで有効にされた、フォワードプレイ、リバースプレイシーケンスの繰り返しを可能にします。 これにより、アニメーション全体が効果的に何度もループします。

完全なシーケンスの繰り返し数　Number Of Complete Sequence Repeats

これは、完全なシーケンスが繰り返される回数を制御します。

最終リピートで逆再生しないでください　Do Not Reverse Play In Final Repeat

このオプションは、最後の完全なシーケンスの繰り返し中にフレームの逆再生を無効にし、最初のフレームではなく最後のフレームでアニメーションを終了できるようにします。

選択された出力AVI設定　Selected Output AVI Settings

このコントロールは、参照用に出力AVI設定のステータスを表示するだけです。 これらの値は、必要な設定ではない場合、[出力オプション]タブで変更できます。

出力オプション

Output Options

出力ディレクトリ　Output Directory

デフォルトでは、PIPPは、最初に処理するソースファイルと同じディレクトリに出力ファイルを書き込むためのディレクトリを作成します。 ソースファイルがDVDまたはリムーバブルメディアにあり、書き込みが遅い場合は、出力ディレクトリに別の場所を選択できます。

デフォルトを使用します　Use Default

このボタンをクリックすると、ソースファイルディレクトリ内のデフォルトの自動生成出力ディレクトリが使用されます。

ディレクトリを選択　Select Directory

このボタンをクリックすると、出力ディレクトリを直接指定できるディレクトリ選択ウィンドウが開きます。

出力ファイル名の接頭辞　Output Filename Prefix

このコントロールにより、生成された出力ファイル名に追加されるプレフィックスを指定できます。

出力フォーマット　Output Format

このコントロールは、出力フレームが書き出されるフォーマットを許可します。

AVI ： AVIビデオファイルとして書き出された出力フレーム。

SER ： LuCamレコーダーのSER形式のビデオファイルとして書き出された出力フレーム。

BMP ： BMPビットマップイメージファイルのシーケンスとして書き出された出力フレーム。

TIF ： TIFF画像ファイルのシーケンスとして書き出された出力フレーム。

FITS ： FITS画像ファイルのシーケンスとして書き出された出力フレーム。

アニメーションGIF ： アニメーションGIFとして書き出されたフレームを出力します。

AVIファイルのオプション AVI File Options

このコントロールグループは、生成されたAVIファイルの詳細を制御します。

AVIコーデック AVI Codec

このコントロールは、AVIファイルの生成時に使用されるコーデックを選択します。

「DIB」は、惑星のイメージングによく使用される標準の非圧縮コーデックです。 利用可能なコーデックの中で最大サイズのファイルを生成しますが、他のほとんどのソフトウェアパッケージでサポートされているファイルです。

「ULRG」は、可逆圧縮を使用して 「DIB」コーデックよりも小さいファイルを生成するコーデックですが、データの品質は低下しません。 「ULRG」コーデックは、スタックされるファイルに適しています。

「FMP4」は、MPEG-4非可逆圧縮を使用して、はるかに小さいサイズのAVIファイルを生成するコーデックです。 圧縮は不可逆的であるため、このコーデックはスタックするAVIファイルには使用しないでください。ビデオ共有Webサイトにアップロードしたり、電子メールで共有したりできるファイルを生成するのに役立ちます。

品質　Quality

このコントロールは、「FMP4」コーデックの品質レベルを選択し、1〜10の値をとることができます。品質レベルが低いと、ファイルは小さくなりますが、ビデオの品質は明らかに低くなります。 品質レベルを高く設定しすぎると、ビデオの品質は向上しませんが、ファイルが必要以上に大きくなります。 試行錯誤は、適切な品質レベルを選択するための鍵であり、エンコードされるビデオに依存します。

古い形式のAVIファイルを生成　Generate Old Format AVI File

このオプションを使用すると、PIPPは古いフォーマットのAVIファイルを生成します。このファイルは、他の古いソフトウェアパッケージとの互換性は高いかもしれませんが、最大サイズの制限が2 GBであるという欠点があります。 PIPPが生成する標準のAVIファイルは、問題なく120GBのサイズに到達できます。

可能であれば、入力ビデオと同じFPS　Same FPS As Input Video If Possible

このコントロールを有効にすると、生成されたAVIファイルの1秒あたりのフレーム数の値は、入力AVIファイルの1秒あたりのフレーム数の値と同じになります。 入力AVIファイルがない場合は、「1秒あたりのフレーム数」コントロールの値が使用されます。

それ以外の場合に使用する1秒あたりのフレーム数　Frames Per Second To Use Otherwise

このコントロールは、「可能な場合は入力ビデオと同じFPS」コントロールが有効になっていないか、入力AVIファイルが指定されていない場合に、生成されたAVIファイルに使用される1秒あたりのフレーム数を指定します。

イメージフレームの再番号付け　Image Frame Renumbering

品質推定が無効で、出力フォーマットがBMP（またはTIFF）に設定されている場合、デフォルトでは、出力ファイルは0001.bmp、0002.bmp、0003.bmpなどのように順番に名前が付けられ、個々のファイル名は必ずしも 何らかの理由でフレームが拒否された場合は、元のフレーム番号。 画像フレームの再番号付けが無効になっている場合、出力ビットマップファイルの個々のファイル名は元のフレーム番号と完全に一致します。

イメージフレームの再番号付けを無効にする　Disable Image Frame Renumbering

このコントロールは、BMP / TIFFフレームの再番号付けを無効にするために使用され、品質推定が無効になっている場合にのみ有効です。

色（RGB）チャネル分割　Colour (RGB) Channel Splitting

出力ビデオまたは画像を赤、緑、青のチャネルに分割します。 フレームを単一のカラービデオファイルまたは単一のカラービットマップイメージのシーケンスとして書き出す代わりに、このオプションでは、出力を3つのモノラルチャネルに分割します（それぞれ赤、緑、青のチャネルに1つずつ）。 これは、いくつかの高度な画像技術が個々の赤、緑、青のチャネルで作業し、それらを処理ワークフローの後半でカラー画像に結合することを好むために提供されます。

RGBチャネル分割を有効にする　Enable RGB Channel Splitting

このコントロールは、RGBチャネル分割を有効にします。

出力フレームのドロップ　Output Frame Dropping

このコントロールは、各フレームが出力された後にドロップするフレームの数を指定します。 0に設定すると、すべてのフレームが出力されます。 1に設定すると、出力されるフレームごとに1フレームがドロップされ、合計フレームの半分のみが出力されます。 2に設定すると、出力されるフレームごとに2フレームがドロップされ、合計フレームの3分の1のみが出力されます。

このオプションの用途は非常に限られています。主な用途は、60 fpsのAVIファイルから1フレームおきに破棄して、プレゼンテーション用に30 fpsファイルとして書き出すことです。

WinJUPOS互換ファイル名　WinJUPOS Compatible Filenames

このコントロールは、WinJUPOSが理解できるタイムスタンプ付きの出力ファイル名を生成するため、「画像測定」段階で日時を手動で入力する必要はありません。 これが機能するには、入力ファイルがタイムスタンプを含むSERファイルであるか、タイムスタンプのないAVIファイルまたはSERファイルに対して「入力オプション->日付/時刻抽出」グループを使用する必要があります。

WinJUPOS互換ファイル名を有効にする　Enable WinJUPOS Compatible Filenames

このコントロールにより、WinJUPOS互換のファイル名を生成できます。

ファイル名に使用する時間　Time To Use For Filename

WinJUPOSフレンドリーなファイル名に使用する時間を指定します。 これは次のいずれかです。

（1）出力フレームの中点時間。

（2）最も早い出力フレームの時間。

（3）最初の出力フレームの時間。

処理を行う

Do Processing

コントロール　Control

このコントロールボックスには、処理を開始するボタンと、処理が開始されたら処理をキャンセルするボタンがあります。

処理を開始　Start Processing

このボタンをクリックすると、処理の実行が開始されます。

処理をキャンセル　Cancel Processing

処理実行がアクティブなときにこのボタンをクリックすると、処理実行がキャンセルされます。 このボタンをクリックすると、処理がすぐにキャンセルされ、出力ファイルが部分的に生成された状態になる可能性があります。

状態　Status

このステータス領域には、常にPIPPの処理コアの状態が表示されます。

処理　Processing

このステータス領域には、現在の処理実行の進行状況を示すいくつかの進行状況バーが含まれています。

出力　Output

この領域には、PIPPの処理コアからの出力メッセージが含まれます。 最も重要なこととして、この領域には、処理が完了すると実行される処理の概要が含まれます。 この要約をチェックして、処理中に問題が発生したかどうかを確認する必要があります。


SERプレーヤー

Windows（macOS、Linux）用 SERプレーヤー

SERプレーヤーはLuCamレコーダーSERファイルを再生するためのビデオプレーヤーです。 SERファイルは、惑星、月、太陽のキャプチャに使用されます。このプレーヤーでは、標準のビデオプレーヤーでAVIファイルを表示するのと同じ方法で、これらのキャプチャを表示できます。

SERプレーヤーは、Windows、OS X、Linuxで利用できるオープンソースアプリケーションです（下記のダウンロードリンク）。

処理

● Debayer RAWカラーフレームを使用してカラーフレームを作成します。

● フレームを反転してネガティブバージョンを生成します。

● ゲインとガンマの調整。

● カラーチャネルの配置。

● カラーフレームをモノクロフレームに変換します。

● 彩度調整。

● カラーバランス調整。

● フレーム領域のトリミング。

● フレームのサイズを小さくします。

サポートされる保存形式

● SER形式。

● 非圧縮AVI（DIBコーデック）。

● アニメーションGIF。

● 個別の画像（JPEG、BMP、PNG、TIFF）。

技術的な詳細

● GNU GPLv3ライセンスの下でリリースされました。

● Qtクロスプラットフォームアプリケーションフレームワークを使用してC ++で記述されています。

● Qtを使用しているため、iOSまたはAndroid向けにビルドしてタブレットで実行できます。 ただし、これは行われていません。

● PIPPのコードの一部を再利用します。

まだ作業中です！

サポートされている言語

日本語はありません。

（英語の他に6ヵ国語のみ）

英語以外の翻訳を作成する時間を提供してくれたすべてのボランティアに感謝します。

SER Playerを新しい言語に翻訳するボランティアはいつでもありがたいです。 これは単に英語のテキストのリストを母国語に翻訳することを含み、プログラミングの経験は必要ありません。 手伝いたい場合は、astropipp @ gmail.comまでメールでお問い合わせください。

SERプレーヤーのダウンロード

さまざまなプラットフォーム用のビルド済みバージョンのSER Playerは、以下のリンクからダウンロードできます。 ダウンロードの問題など、これらのバイナリイメージに問題がある場合は、メールでお知らせください。

● Windows (64-bit):SER_Player_Windows_x64_v1.7.2.zip (27.8 MB)

● Windows (32-bit):SER_Player_Windows_x86_v1.7.2.zip (23.7 MB)

これらは圧縮されたWindowsインストーラです。

GitHubのSER Playerプロジェクト

https://github.com/cgarry/ser-player

ここには、ソースコードを含む完全なSER Playerプロジェクトがあります。 また、現在および以前のリリースのビルド済みバージョンもここにあります。

SERファイルの例

● Jupiterモノクロキャプチャ（C14 + ASI174MMカメラ）：Jup_200415_204534_R_F0001-0300.zip（16MB）

● Mars rawカラーキャプチャ（C14 + ASI120MCカメラ）：Mars_150414_002445_OSC_F0001-0500.zip（11.7MB）

SER Playerの評価に使用できるSER形式の非常に短いキャプチャをいくつか示します。

SERファイル形式について

SERフォーマットは当初、Heiko WilkensがLucam Recorderの画像取得ソフトウェア用に考案したものです。 この形式は、惑星、月、および太陽のイメージング用のWebカメラや高速フレームレートカメラからデータをキャプチャするためのAVI形式の代替です。

AVI形式に対するSER形式の利点

● SERファイルは、フォーマットが単純であるため、ソフトウェアで処理するのが簡単です。

● SERファイルは、AVIファイルのようにビデオコーデックに依存しません。

● SERファイルを使用すると、各フレームに正確なタイムスタンプを付けることができます。

● SERファイルは、8ビットを超えるデータをサポートできます。

AVI形式と比較したSER形式の潜在的な欠点は、適切なコーデックを使用してAVIファイルで実現できるロスレス圧縮をサポートしないことです。

ユーザー機能

● v2およびv3 SERファイルの再生。

● 生のカラーキャプチャのディベイヤー。

● ビデオは、メニューオプションを使用して、または単にプレーヤーのサイズを変更してサイズを変更できます。

● 再生は、再生メニューから変更できます。

● フレームは、進むボタンと戻るボタンを使用して一度に1つずつ表示できます。


PIPP使用例

このページには、PIPPの使用例がいくつか掲載されています。 これらの例は、PIPPの簡単な紹介のために提供されています。すべてのPIPPオプションの詳細については、ダウンロードページにあるマニュアルを参照してください。

例1A：生のカラーキャプチャのディベイヤ

● カラーカメラから生のAVIビデオファイルをデベイヤーして、カラーAVIビデオファイルを生成します。

この例では、カラーカメラからのRAWビデオのPIPPディベイヤを示します。 これは、PIPPの機能を穏やかに導入するために設計された、意図的に単純な例です。

この例で使用するソースビデオ（ここをクリック）

このビデオはImaging Source DFK 21AU618.ASカメラからのものです。 これは、カラーに変換するためにベイヤリングを解除する必要があるモノクロビデオです。

まず、WindowsのスタートメニューからPIPPを選択して開始します。

次に、処理されるビデオがソースファイルリストに追加されます。 これは、Windowsエクスプローラウィンドウからファイルをドラッグアンドドロップするか、[ソースファイルの追加]ボタンを使用して実行できます。 ファイルを追加すると、PIPPは次のようになります。

PIPPは、ビデオにベイヤーパターン（GRBG）が含まれていることを自動的に検出し、ベイヤー解除を有効にするよう提案されていることに注意してください。 このベイヤーパターン検出は、惑星のビデオではうまく機能する傾向がありますが、月または太陽のビデオではそれほどうまく機能しない可能性があります。 したがって、通常はポップアップウィンドウで[はい]をクリックして検出された値を受け入れますが、今回は[いいえ]をクリックして手動でディベイヤコントロールを設定します。

[いいえ]をクリックした後、処理オプションは選択されていません。つまり、ここでファイルを処理する場合、出力AVIには入力AVIとまったく同じフレームが含まれます。 これはあまり役に立ちませんが、PIPPはY800コーデックを使用してAVIファイルを作成しないため、この入力ファイルが使用するため、Y800コーデックがインストールされていないWindowsマシンでより適切に処理される可能性があります。

PIPPには、メインウィンドウの右上隅に[テストオプション]ボタンがあります。これは、現在のオプションを使用して簡単なテスト実行を行うように設計されており、完全な処理実行が行われた場合に保存される最初の処理済みフレームを表示します 画像プレビューウィンドウ。 ほとんどの場合、これは非常に迅速なプロセスであり、完全な処理を実行する前に多くの処理オプションを試すことができます。 [テストオプション]ボタンをクリックすると、このウィンドウが開きます

処理オプションが選択されていないため、これはソースAVIファイルの最初のフレームにすぎません。 このフレームサイズは640x480ピクセルで、カメラからのベイヤーパターンを示すモノクロ画像です。 この新しいウィンドウは閉じても開いたままにしてもかまいません。

この例のポイントは、ソースファイルをディベイヤしてカラーAVIファイルを作成することです。 これを行うには、PIPPのメインウィンドウで[入力オプション]タブを選択します。

「Debayer Monochrome Frames」オプションはデフォルトで無効になっていることに注意してください。 これを有効にし、カメラに適切なディベイヤーパターンを選択する必要があります。これを行う最も簡単な方法は、4つのオプションしか選択できないため、推測することです。

したがって、まず、ディベイヤーを有効にし、ディベイヤーパターン（この場合はGRBG）で推測します。

これが正しいかどうかを確認するために、[テストオプション]ボタンをクリックし、PIPPの画像プレビューウィンドウを使用して、画像が正しくベイヤリングされているかどうかを確認します。

現在、ある種のカラー画像がありますが、明らかに正しくありません。

したがって、別のディベイヤーパターンを選択

もう一度[テストオプション]ボタンが押され、結果が画像プレビューウィンドウで確認されます。

今回は色が正しいです。 これで、このカメラの正しいdebayerパターンがわかりました。

オプションが正しく選択されたので、このソースAVIファイルの実際の処理に移ることができます。 これを行うには、PIPPのメインウィンドウで[処理を実行]タブを選択します。

タブには、すでにいくつかの処理が行われていることが示されていることに注意してください。 この理由は、「テストオプション」ボタンが実際に処理を実行するためです。ただし、品質の並べ替えを行わず、1つのフレームのみを出力する特別なボタンです。 「テストオプション」処理の実行によって生成されたすべてのファイルは、実行の完了後に削除されるため、無視できます。

処理を開始するには、「処理の開始」ボタンをクリックします

これでステータスが実行中に変わり、処理が進行中です。 「処理のキャンセル」ボタンを押すと、実行中の処理をいつでもキャンセルできます。 ただし、処理をそのままにしておく必要があります。

完了すると、ウィンドウは次のようになります

出力領域で処理の概要を確認して、処理が期待どおりに進んだことを確認することは価値があります。 この例では、入力と同じように、1699フレームの出力があったため、すべてうまくいきました。

完了すると、PIPPは出力ディレクトリでWindowsエクスプローラーウィンドウを自動的に開きます

出力ディレクトリには、処理された出力AVIファイルとログディレクトリがあります。 この場合、logsディレクトリには、ログテキストファイルと.pof（PIPPオプションファイル）が含まれます。これらは、PIPPによっていつでもロードして、この処理の実行に使用されるオプションを再選択できます。

PIPPが作成した生成された AVIファイル（ここをクリック）

例1B：センタリングとトリミング

● 例1Aプラスとして。

● 惑星が完全にフレームにないフレームはすべて破棄してください。

● 各フレームで惑星を中心に置きます。

● 惑星の周りの各フレームを切り抜きます。

この例は例1Aに基づいており、より便利なモードでPIPPが機能し、惑星が各フレームに完全に存在するかどうかを確認し、惑星の周りの各フレームをトリミングします。 生のビデオも例1Aのようにディベイヤされます。

この例では、例1Aと同じソースビデオ（ここをクリック）を使用しています。

PIPPが起動し、以前のようにソースAVIファイルがソースファイルリストに追加されます。

今回は、ディベイヤーを有効にし、ポップアップウィンドウで[はい]をクリックして正しいベイヤーパターンを選択するというPIPPの提案を受け入れます。

今回は、ビデオをカラーからディベイヤリングするだけでなく、さらに多くの処理を行うため、「Planetary」イメージングの「オプションを最適化」するオプションを選択します。 これらの「最適化オプション：」オプションのいずれかを設定する必要はありませんが、選択したイメージングタイプに適したオプションが他のタブで自動的に選択され、そのタイプのイメージングに適さないオプションが無効になります。 ここでは「Planetary」イメージングを選択していますが、これはこの例で行っていることです。

「処理オプション」タブを見ると、いくつかのオプションが選択されており、それらの色が緑に変わっていることがわかります。 これらは、イメージングタイプを「惑星」に設定することによって設定されたオプションです。

[処理オプション]タブを確認すると、オブジェクトが存在しないフレームを拒否するオプションと、各フレームの中央にオブジェクトを配置するオプションが選択されていることがわかります。 また、448x448ピクセルのデフォルトのトリミングサイズが選択されたトリミングオプションも有効になります。

次に、[テストオプション]ボタンをクリックして、画像プレビューウィンドウを使用して、選択したオプションの効果を確認します。

これを見ると、ビデオが正しくベイヤリングされてカラービデオが作成されていることがわかりますが、フレームが小さくトリミングされる可能性があります。

そこで、「処理オプション」タブに戻り、「切り取り幅」と「切り取り高さ」の値を448から350に減らします。

次に、[オプションのテスト]ボタンをクリックして、画像プレビューウィンドウを使用して、オプションが正しいことを確認します

それがまさに私たちが望んでいることなので、処理に移ります。

「処理を実行」タブを選択し、「処理を開始」ボタンをクリックします

処理が完了したときの結果です。 この時点で、サマリーを確認し、何らかの理由でフレームが破棄されていないことを確認しました。

いつものように、処理の実行が正常に完了すると、PIPPは出力ディレクトリでWindows Explorerウィンドウを開きます

この例で生成されたAVIビデオ（ここをクリック）

ビデオがカラービデオにベイヤリングされ、惑星が各フレームの中央に配置され、各フレームがトリミングされていることに注意してください。 この生成されたAVIは、選択したスタッキングソフトウェアを使用してスタックできるようになりました。これは、ビデオのサイズが小さく、惑星がフレーム全体で不思議に思っていないためです。

例1C：品質の選択

● 例1Bプラスとして

● フレームを品質順に並べ替え、最高の1000フレームのみを保持します。

この例では、例1bをさらに段階的に進め、出力フレームフィルタリングを品質別に追加します。 この時点までのすべての例では、元のビデオでの順序で画像を出力しました。この例では、品質順に画像を並べ替え、最高の1000フレームのみを保持します。 サンプルのソースビデオファイルには1699フレームしか含まれておらず、この手法では、低品質のフレームを破棄できるため、これより多くのフレームを含むファイルでより良い結果が得られます。 ただし、この例は原則をよく示しています。

この例では、例1Aおよび1Bと同じソースビデオ（ここをクリック）を使用しています。

このビデオはImaging Source DFK 21AU618.ASカメラからのものです。 これは、カラーに変換するためにディベイヤする必要がある1699フレームのモノクロビデオです。

これはより包括的な例であり、PIPPはフレームデータをスタックする前にハードに作業できます。 この例では、各PIPPのタブを順番に実行して、それぞれに必要なオプションを選択します。 これは、おそらくPIPPを使用する最良の方法です。

「ソースファイル」タブから始める前と同様に、ソースファイルリストにソースファイルを追加し、惑星イメージング用に最適化するチェックボックスを選択します。

[入力オプション]タブで、カメラに適切なディベイヤーパターンを選択します

[処理オプション]タブで、いくつかのオプションが事前に選択されているのがわかりますが、キャプチャに合わせてトリミングサイズを350x350ピクセルに縮小しています

次に[品質]タブに進みます。これらの例で使用されたのはこれが初めてです。 品質推定はデフォルトでは有効になりません。これは、品質タブが最初に選択されたときの状態です。

品質タブで、品質推定を有効にし、フレーム数をデフォルトの1200から1000に変更しました。他のオプションはデフォルト値のままにしました。

次は「出力オプション」タブです。 例ではこれまで見ていないので、今回は簡単に見ていきます。

このタブでは、オプションを変更する必要がないため、すべてをデフォルト設定のままにしておきます。 処理を実行する前に、[テストオプション]ボタンをクリックして結果がどうなるかを常に確認します。

画像プレビューウィンドウが表示されます

この「テストオプション」の実行は、「品質オプション」または「出力オプション」タブの何の影響も受けないことに注意してください。 しかし、すべてが順調に進んでいるため、処理を実行する準備ができている最後のタブに進むことができます。

「処理を実行」タブで「処理を開始」ボタンをクリックして処理の実行を開始します。 品質推定が有効になっていない前の例にはなかった、品質によるフレームのソートの進行状況バーがあることに注意してください。

処理が完了したら、出力領域の要約をチェックして、問題が発生していないかどうかを確認する必要があります。 この場合、1699の入力フレーム、699フレームが品質によって破棄され、1000フレームが必要に応じて出力されていることがわかります。

いつものように、PIPPは出力ディレクトリでWindows Explorerウィンドウを開きます

これが結果の AVIビデオ（ここをクリック）です。 ビデオがベイヤリングされ、惑星が中央に配置され、フレームがクロップされているだけでなく、フレームが並べ替えられており、最もシャープなフレームが最初で、シャープでないフレームが最後になっています。 また、最高の1000フレームのみが保持されています

上記のビデオのストリーミングバージョンでビデオフレームの品質の変化を確認するのは簡単ではないので、比較できるように、静止画としてのビデオのフレームをいくつか示します。

フレーム1〜3、ビデオの最高のフレーム

フレーム998〜1000、ビデオ内で最も品質の低いフレーム。 これらのフレームは最初の3つのフレームよりも品質が低いですが、スタックに使用するのに十分であることに注意してください

品質推定の威力をさらに示すために、実際に拒否され、最終的なビデオの一部ではない最悪の3つのフレームを次に示します。

この例を完了するために、生成されたAVIビデオがAutoStakkertを使用してスタックされた後の最終的な画像を次に示します。 2、Registax 6で処理されたウェーブレットとPhotoshopで調整された曲線。

例2：オフセットを使用したトリミング

● カラーカメラから生のAVIビデオファイルをデベイヤーして、カラーAVIビデオファイルを生成します。

● 惑星が完全にフレームにないフレームはすべて破棄してください。

● 各フレームで惑星を中心に置きます。

● フレーム内に2つの月を維持するために、惑星を中心にオフセットして各フレームをトリミングします。

● フレームを品質順に並べ替え、最高の1000フレームのみを保持します。

この例では、異なるソースビデオを使用し、フレームをトリミングして、2つの木星の月が各フレームに残るようにします。

エウロパ、ジュピター、イオのソースビデオ（ここをクリック）

このビデオはImaging Source DFK 21AU618.ASカメラからのものです。 これは、カラーに変換するためにベイヤリングを解除する必要があるモノクロビデオです。

これは前の例とは異なるソースビデオであり、両方の月を画像に残す場合は、トリミングするときにオフセットが必要です。

いつものように、「ソースファイル」タブから始めて、ビデオファイルをソースファイルリストに追加します

このファイルには6288フレームがあり、前の例よりもはるかに多いことに注意してください。

オプションを選択する前に、[テストオプション]ボタンをクリックして、PIPPの画像プレビューウィンドウにソースファイルの最初のフレームを表示し、トリミング値の決定に役立てます。

次に、惑星イメージングのオプションを最適化するためのチェックボックスを選択します

[処理オプション]タブに移動すると、デフォルトの惑星オプションが選択されています。

ただし、以前の画像プレビューウィンドウから、標準の450x450ピクセルクロップがこのキャプチャのニーズに合わないことがわかります。 そこで、作物の幅と高さをより適切なものに変更します

もう一度[テストオプション]ボタンをクリックして、新しいトリミングオプションを確認します

クロップのサイズはほぼ正しいですが、画像を左にシフトする必要があります。 Xオフセットボックスに-50ピクセルのシフトを入れてみましょう

もう一度[テストオプション]ボタンをクリックして、新しいオプションを確認します

おっと！ 惑星は間違った方法で移動しました。

惑星を反対方向にシフトする必要があるため、Xオフセットを-50から+50ピクセルに変更します。

さらに、「Test Options」ボタンをもう一度クリックして、新しいオプションを確認します

見た目はかなり良くなっていますが、少し左に少しずらすとうまくいくと思います。

Xオフセットを50ピクセルから60ピクセルに増やします

そして驚いたことに、更新されたオプションを確認するために、もう一度[テストオプション]ボタンをクリックします。

ビンゴ、それは十分に近いです！ それはソートされた切り抜きオプションですが、画像はまだベイヤを取り除く必要があります。

[入力オプション]タブで、カメラに適切なディベイヤーパターンを選択します

最後にもう一度[テストオプション]ボタンをクリックして、更新されたオプションを確認します

これで画像が適切にフレーム化され、ディベイヤされました。

次に、品質ソートを有効にする必要があります。 そこで、[品質オプション]タブに移動して、品質の見積もりを有効にし、フレーム数を1500に変更します。

次に、「出力オプション」タブに移動します

[出力オプション]タブのオプションを変更する必要はありません。

「Do Processing」タブに移動し、「Start Processing」ボタンをクリックして処理の実行を開始します

処理は完了するまで実行されます

概要を調べると、入力フレームの数は当初6288フレームと報告されていましたが、ファイルには実際には6000フレームが含まれていることがわかりました。 実際には、AVIファイルが実際に含むよりも多くのフレームを持っていると主張することは非常に一般的ですが、これは問題ではありません。

処理が完了すると、PIPPはWindowsエクスプローラーウィンドウで出力ディレクトリを開きます

PIPPが生成した AVIビデオ（ここをクリック）です

このビデオには、ソースビデオからの最高品質の1500フレームが含まれており、品質順にソートされています。

この生成されたAVIファイルをRegistax 6ですばやくスタックし、少し後処理すると、最終的な画像は次のようになります。

例3：フルディスクソーラーイメージング

● Canon DSLRカメラからのフルサイズのソーラー（生CR2）画像のディレクトリから始めます。

● 画像に太陽が完全に含まれていないフレームを破棄します

● 各画像の中心に太陽を置きます。

● 太陽の周りの各画像を切り抜きます。

● 各画像をカラーからモノクロに変換します。

● 合計ピクセル値の順に画像を並べ替えて、雲の影響を受ける画像をリストの最後に配置します。

● 処理した画像をTIFF画像として書き出します。

これは、PIPPを使用してフルディスクソーラーイメージングを支援する例です。 この例では、Canon DSLRカメラを備えた80mm屈折望遠鏡で撮影した画像を使用しています。

[警告]　望遠鏡の前面を完全に覆うソーラーフィルターを使用せずに、太陽の画像/表示を試みないでください。

この例で使用されているイメージング手法は、この優れたチュートリアルの手法を変更したものです。シンプルな白色光の太陽イメージングのチュートリアル

これまでのチュートリアルに従うと、約100程度のフルフレームDSLRイメージが作成されます。 この例ではJPEG画像ではなく生のCR2フレームを使用しているため、JPEG画像を使用すると品質が大幅に低下することに注意してください。

これは、個々の画像を撮影しているイメージングリグの写真です。 この場合、130枚の画像がキャプチャされ、そのうちのいくつかはクラウドの影響を受けました。

ここに表示される画像は、ページに収まるようにサイズが縮小されていますが、実際のサイズは4272 x 2848ピクセルです。 最初のタスクは通常、このような適切なフレームを識別することです。

次に、これらのような雲の影響を受けるすべてのフレームを削除します。

PIPPを使用しない場合、これはすべての画像を検査することによって手動で行われます。100以上の画像では少し時間がかかる場合があります。

次の段階は、Registaxまたは他のスタッキングソフトウェアを使用して、すべての適切なイメージをスタックすることです。 ここで発生する可能性があるいくつかの問題があります。

● Registaxは、太陽がさまざまな画像のさまざまな位置にある画像を整列させるのに苦労する可能性があります。

● そのような大きな画像の処理は非常に遅くなるか、完全に失敗することさえあります。

PIPPができること

PIPPを使用すると、次のことをすばやく達成でき、処理が高速化されます。

● 各画像の中心に太陽を置きます。

● 太陽の周りで画像をトリミングして、画像のサイズを小さくします。

● Sunが存在しないすべてのイメージを破棄します。

● 画像をモノクロに変換します（ファイルサイズを1/3に減らします）。

● 全体の明るさの順に画像を並べ替えます。そうすると、雲のある画像がリストの最後に降格され、削除の選択がはるかに簡単になります。

● 処理した画像を.tif画像ファイルとして書き出し、積み重ねの準備をします。

まず、PIPPを開始し、すべての.CR2ファイルをソースファイルリストに追加して、「Solar / Lunar Full Discの最適化オプション」イメージングオプションを選択します。

まず、「入力オプション」タブを調べます。 ここでオプションを変更する必要はありませんが、Canon CR2ファイルには専用のコントロールグループがあり、各ファイルを開くときに適用される処理を詳細に制御できることに注意してください。

次に、処理タブを見て、最初のタブで「月/太陽フルディスクの最適化オプション」オプションが選択されているため、さまざまなオプションがすでに変更されていることを確認します。 基本的にこれらのオプションは、オブジェクトの検出、オブジェクトのセンタリング、1200 x 1200のクロップサイズの設定を可能にします。また、カラー画像はモノクロに変換されます。

これらのデフォルトオプションの適切さを確認するには、[テストオプション]ボタンをクリックします。 PIPPの画像プレビューウィンドウが開きます

このプレビューは、デフォルトの1200 x 1200クロップサイズがはるかに小さいことを示しており、太陽の円盤のごく一部しか設定していない。 したがって、以下に示すように、作物のサイズを大きくします。 このページでは、このタイプのイメージングに役立つもう1つのコントロールは「ヒストグラムストレッチ」ですが、この例では使用しません。

[テストオプション]ボタンをもう一度クリックすると、更新されたオプションがどのように機能するかが表示されます。

それは完璧な作物サイズのようです、それは最初の推測にとって幸運であり、より多くの試行錯誤が通常必要です。

[ソースファイル]タブの[ソーラー/ルナフルディスクの最適化オプション]イメージングオプションで設定された他のオプションを簡単に見てみましょう。 まず、[品質オプション]タブ

フレーム数に制限なく品質推定が有効になっており、選択された品質アルゴリズムは「Total Pixel Value Quality Algorithm」です。 これらのオプションは、太陽の前にある雲が総ピクセル値の減少を引き起こすという単純な原則に基づいて機能するため、生成される画像は、影響を受ける雲の少ないものから影響を受ける雲の多い順に並べられます。

次に、「出力オプション」タブを見てみましょう。

ここでは、「出力形式」オプションがTIFに変更されていることがわかります。 これは、画像が合計ピクセル値の順に並べ替えられていても、雲のある画像は手動で削除する必要があるため、個々の画像の方が1つのビデオよりも望ましいからです。

次のステップは、「処理を実行」タブに移動し、「処理を開始」ボタンをクリックすることです

ここで処理が実行されています。 完了すると、次のようになります

そして、ビットマップ画像のディレクトリが作成されます。 生成された画像リストの最初は、サムネイルとしてこのように見えます。

これらの画像はすべてクラウドフリーであることに注意してください。

画像リストの最後はこのようにサムネイルとして表示されます

これらはクラウドの影響を受けており、簡単に選択して削除できる画像です。

この例を完了するために、このページの上部にあるチュートリアルにリンクされているチュートリアルで説明されているのと同様のプロセスに従って処理が完了したときの最終結果を次に示します。 誰の好みにも合わないかもしれないいくつかの偽色が追加されていることに注意してください。 これは、このページに収まるようにサイズ変更されたフルイメージです。フルサイズバージョンを表示するには、イメージをクリックしてください。

例4：国際宇宙ステーションのビデオ処理

● ISSパスをキャプチャしたビデオを処理する例。

この例で使用されているキャプチャビデオは、http://www.skyinspector.co.uk/homeのMartin Lewisが撮影したものです。 マーティンのWebサイトには、計画、キャプチャ、処理を含むISSイメージングのすべての側面を網羅した優れたISSイメージングチュートリアルがあります。http://www.skyinspector.co.uk/Imaging-the-ISS%282449273%29.htm。 この例では、PIPPの処理の一部を取り上げています。

ISSのイメージングは、惑星、月、太陽のイメージングとは非常に異なる課題を提示します。 この例は、ISSを含むキャプチャビデオのすべてのフレームを選択するためにPIPPを使用し、他のフレームを破棄して、選択したフレームを元のフレーム番号をファイル名としてビットマップイメージとして保存する方法を示しています。 ISSイメージングでは、通常、高品質の処理は使用されません。

ISSパス中に撮影されたキャプチャビデオ（ここをクリック）

これらのタイプのキャプチャでは、ISSはほとんどのフレームに存在せず、フレームの短いバーストにのみ存在することに注意してください。

この例では、まず[ソースファイル]タブでソースファイルをソースファイルリストに追加し、ISSイメージングのオプションを最適化するチェックボックスをオンにします。

このビデオがディベイヤを必要とするカラーカメラからの生のビデオである場合、これは入力オプションタブで行われます。 ただし、これはモノクロビデオなので、このタブはスキップできます。

次に、「処理オプション」タブに移動して、オプションが正しいことを確認します

[ソースファイル]タブの[ISSイメージングのオプションを最適化する]チェックボックスで変更されたオプションは、色が紫に変更されているため、どのオプションが変更されたかは明らかです。 オブジェクトが含まれていないフレームを拒否するオプションが有効になっており、オブジェクトを各フレームの中央に配置するオプションも有効になっていることに注意してください。 50はISSのすべてのインスタンスを取得するには少し大きすぎるため、最小オブジェクトサイズは50から10に削減されました。 ISSにはすべての惑星の端にある勾配とは異なり、ハードエッジがあるため、「オブジェクトにハードエッジがある」オプションが有効になっています。 最後に、クロップサイズが300x300ピクセルに縮小されました。

これらのデフォルトのISSオプションは問題なく、そのまま受け入れることができます。

次に、[出力オプション]タブに移動します。

[ソースファイル]タブで選択された[ISSのオプションを最適化する]チェックボックスが緑色に変更されたため、オプションが変更されていることに注意してください。 これで、出力タイプがAVIビデオからTIFF画像に変更されたことがわかります。 また、イメージフレームの再番号付けが無効になっていることにも注意してください。 これらのオプションは、私たちが達成しようとしていることに対して正しいものです。

処理に移る前に、[テストオプション]ボタンをクリックして、画像プレビューウィンドウをチェックして、選択したオプションが修正されていることを確認することをお勧めします。 これが結果です

品質は低いですが、ISSがフレーム上にある場合、PIPPは最初のフレームを正しく識別しました。

次に、処理タブに移動します。

「テストオプション」の実行の概要を見ると、フレーム内にオブジェクトがなかったために354フレームが拒否され、オブジェクトが部分的にしかフレーム内になかったために2フレームが拒否されたことがわかります。 これは、ISSが最初にビデオに表示されるまでに数秒かかるため、入力ビデオを調べたときに予想されます。

これで、「処理の開始」ボタンをクリックして、実際の処理を開始する準備ができました。

処理が完了すると、PIPPは次のようになります。

この例では、元の4707フレームから、ISSがまったく含まれていない3505フレームが検出され、フレームの一部のみがISSで193が検出された、オブジェクトのサイズが最小サイズを下回っている3が検出されたことがわかります。 ISSが完全にフレーム内にある状態で1006フレームが見つかりました。 これらの1006フレームはビットマップとして出力されました。

出力ディレクトリでは、元のソースファイルに基づいて名前が付けられたサブディレクトリに、1006の選択されたフレームが含まれています。 このディレクトリは次のようになります。

これで、MartinのISSイメージングチュートリアルで説明されているように、これらのイメージをグループに分割してスタックする準備ができました。

少し面白くするために、これは、[出力オプション]タブで出力タイプがTIFFではなくAVIに設定されている場合に生成されるビデオ（ここをクリック）です。 ISSが各フレームの中央に配置され、ISSが存在しないすべてのフレームが拒否されていることに注意してください。

例5：フルディスク月面イメージング

これは、フルディスクソーラーイメージングの例と非常によく似ています。

● Canon DSLRカメラからのフルサイズの月面（生CR2）画像のディレクトリから始めます。

● 画像に月が完全に含まれていないフレームを破棄します。

● 各画像で月の中心を合わせます。

● 月の周りの各画像を切り抜きます。

● 各画像をカラーからモノクロに変換します。

● 最も品質の低い20枚の画像を破棄して、画像を品質順に並べ替えます。

● 処理した画像をTIFF画像として書き出します。

2013年4月25日更新

この例では、PIPPのv2.1.4を使用していますが、これは現在少し古いものであり、その後、設計にいくつかの変更が加えられています。 時間があるときにこの例を更新して、RegiStax 6にも処理ステップを含める予定です。

それまでの間、画像のキャプチャからRegiStax 6から結果を取得するまでのプロセスをカバーする、フルディスクの月面イメージングに関するこの優れたチュートリアルを読むことをお勧めします。

http://stargazerslounge.com/topic/184192-full-disc-lunar-imaging-with-a-dslr/

さて、前の例に戻って...

これは、PIPPを使用して完全なディスク月面イメージングを支援する例です。 この例では、Canon DSLRカメラとx2 barlowを備えた80 mm屈折望遠鏡で撮影した画像を使用しています。

イメージングセッションの結果、以下に示すような120のフルフレームDLSR画像が生成されました。 個々の画像は実際には4272 x 2848ピクセルです。このWebページでは、下の画像のサイズが縮小されています。

まず、PIPPを開始するには、120個のCR2ファイルをすべてソースファイルリストに追加し、[Solar / Lunar Full Discの最適化オプション]イメージングボックスを選択します。

タブに沿って作業を続けるため、次に[入力オプション]タブを確認します。 CR2ファイルにはいくつかの詳細なコントロールがありますが、通常どおり、デフォルト値は処理のニーズに適しています。

したがって、「処理オプション」タブに進みます。 一部のオプションは、最初のタブで「太陽/月面フルディスクの最適化オプション」イメージングコントロールが選択されているため変更されていることに注意してください。これらのオプションの色は緑色に変更されています。 基本的に、オブジェクトの検出が有効になり、オブジェクトのセンタリングとクロッピングが行われ、デフォルトのクロップ値が追加されています。

また、「カラーをモノクロに変換」コントロールが有効になっているため、カラーイメージがモノクロに変換され、ファイルサイズがカラーイメージの1/3に縮小されます。 必要に応じて、このオプションを無効にして、月で素晴らしい結果を生成できるカラー画像を使用できます。 ただし、この例では有効のままにして、モノクロ画像で作業します。

次に、[テストオプション]ボタンをクリックして画像プレビューウィンドウを表示し、これまでの設定の効果を確認します。 作物の面積が小さすぎて、修正する必要があることはすぐにわかります。

そこで、「クロップの幅」と「クロップの高さ」を1200から2500に増やします。

次に、[テストオプション]ボタンをクリックして、変更したクロップの値がどのように機能するかを確認します。 切り取りの高さは正しいが、切り取りの幅が大きすぎることがわかります。

そこで、クロップ幅を2500から2000に減らします。

さらに、[テストオプション]ボタンをクリックして、変更したトリミング幅の値がどのように機能するかを確認します。 作物の値は良さそうですが、月はフレームの右側から少し離れすぎています。

これを修正するために、画像プレビューウィンドウからゲスト化された150のXオフセットを追加します。

もう一度[テストオプション]ボタンをクリックし、画像プレビューウィンドウで結果を確認します。 今回は、切り取りと配置がかなり理想的に見えます。

Registaxは画像がすべて同じ明るさであれば画像をより適切に処理するので、ヒストグラムを70％に拡大できるようにします。 これにより、すべてのフレームの最大ピクセルが最大値の70％になることが保証されます。これにより、スタッキングが完了すると、作業に余裕ができます。

そして、もう一度[テストオプション]ボタンをクリックして、この最後の変更による影響を確認します。 画像は明るくなりましたが、明るすぎません。 [処理オプション]タブにこれ以上変更を加える必要はありません。

そこで、[品質オプション]タブに移動します。 合計ピクセル値でフレームを並べ替えるように品質オプションが設定されていることがわかります。 これは、雲の影響を受けたフレームを検出するための優れたオプションですが、このイメージングセッション中に空のどこにも雲がなかったため、これは不要です。 品質推定を無効にすることもできますが、代わりにそれを使用して、最高品質の（最もシャープな）フレームを選択します。 これは、変更を加える前の[品質オプション]タブです。

最高品質のフレームを選択するには、「品質アルゴリズム選択」コントロールを変更して「デフォルトPIPP品質アルゴリズム」を選択します。 これらのタイプの画像の品質の違いはごくわずかであるため（主に見栄えが良かっただけでなく、このタイプの画像では長い焦点距離を使用していないため）、「最小および最大サブサンプル値」を両方とも2に変更します 、2ピクセルx 2ピクセルの正方形間のコントラスト差を使用して品質アルゴリズムが適用されるようにします。 また、（元の120フレームから）最高の100フレームのみを保持するため、20フレームは破棄されます。

Registaxもこれを行うことができるため、この品質の選択は厳密に必要ではありませんが、これは私にとってはうまくいき、Registaxが処理する必要のあるフレームの数を減らします。

品質オプションが完成したら、「出力オプション」タブに進みます。 このタブでは、最初のタブで「太陽/月光フルディスクの最適化オプション」が選択されているため、「出力フォーマット」がTIFに設定されています。 これはこのタイプのイメージングに最適なので、このタブに変更を加える必要はありません。

そこで、「Do Processing」タブに移動し、「Start Processing」ボタンをクリックして処理の実行を開始します。

処理の実行が完了すると、処理タブは次のようになります。 120の入力フレームから、品質によって20フレームが破棄され、100フレームが出力されたことに注意してください。 これは期待されたものです。

TIFF画像のディレクトリが作成され、積み重ねることができます。

各画像は次のようになります。このWebページのサイズが縮小されていることに注意してください（画像をクリックしてフルサイズバージョンを開きます）。

これらの100枚のTIFF画像は積み重ねられ、Registax 6を使用してウェーブレットが適用された後、Photoshopを使用していくつかのカーブ微調整が適用されました。 いつものように、ここでは手順について詳しく説明しません。私がこれについて優れたチュートリアルを作成したよりもはるかに優れていると感じている人がいるからです。 ただし、ここに最終的な画像があり、このページに表示するためにサイズが縮小されています（画像をクリックしてフルサイズバージョンを開きます）。

例6：惑星の時間経過アニメーション

この例では、連続してキャプチャされた一連の処理済み画像を取り、ビデオストリーミングWebサイトにアップロードするためのAVIアニメーションを生成します。

この例は、実際に積み重ねる前に画像データを前処理することではなく、複数の完成した画像を結合して、共有するためにインターネットにアップロードするアニメーションビデオを生成することです。

この例では、2時間のカラービデオキャプチャが4時間以上にわたって5分ごとに行われ、結果として50個のAVIファイルが生成されました。 これらのファイルはすべて、まったく同じ処理アクションで処理され、次に示すように50個の類似した画像が生成されました。

以下は、50枚の画像のうち3枚です。最終的なアニメーションビデオの生成に使用される素材を表示するためにフルサイズで表示されています。

最初のタスクは、PIPPを起動し、すべての画像をソースファイルリストに追加することです

ビデオファイルではなく画像ファイルがソースファイルリストに追加されたため、「結合モード」が選択されたことを示すダイアログがポップアップ表示されることに注意してください。 これが必要な操作なので、[OK]ボタンをクリックするとダイアログが閉じます。

次に、アニメーションに表示する順序でファイルがリストにあることを確認します。 順序が間違っている場合は、タイトルバーのフィールドをクリックしてリストを並べ替えることができます。ここでは、[ファイル名]フィールドをクリックして、ファイルをファイル名で並べ替えます。 フィールドをもう一度クリックすると、順序が逆になります。 いずれかのフィールドをクリックしても目的の順序を設定できない場合は、ファイルをクリックして選択し、上または下ボタンを使用して、ファイルをリストの上下に移動できます。

ファイルを追加し、正しい順序で、「惑星アニメーションのオプションを最適化」するオプションを有効にします。 これにより、PIPPは惑星のアニメーションを生成するために次のタブで有用なオプションを選択します。

このオプションを選択したら、関連するタブを調べて、自動的に選択されたオプションがニーズに適していることを確認します。

何も変更されていないか、変更する必要があるため、「入力オプション」タブはスキップします。 したがって、「処理オプション」タブに直接移動し、惑星アニメーションを生成するために自動的に変更されたオプションの色が緑に変更されていることに注意してください。

自動的に設定されたオプションを見ると、惑星を検出して中心に置くオプションが選択されていることがわかります。つまり、PIPPがこれを処理するので、入力画像は惑星を同じ位置に置く必要さえありません。この機能が必要ない場合は、おそらく画像がすでに並んでいる可能性があるため、ここで無効にすることができます。

また、「自動最小ピクセル値」オプションが無効になっており、「最小ピクセル値」20が選択されていることにも注意してください。これは、自動最小ピクセル値関数を使用するよりも明るく完成した画像でうまく機能し、惑星のより良い中心化をもたらすために行われます。

ヒストグラムストレッチオプションが有効になり、アニメーションのすべてのフレームが同じ明るさになります。 「R、G、Bチャネルを個別にストレッチする」オプションは無効になっているため、処理された画像のカラーバランスは変更されません。すべての画像がすでに同じ明るさの場合、ヒストグラムストレッチオプションを無効にすることができます。

これらのオプションは目的を達成するために問題ないため、[テストオプション]ボタンをクリックして画像プレビューウィンドウを開き、選択したオプションの結果を確認します。

次に確認するタブは、[アニメーションオプション]タブです。 このタブの唯一の用途は、このタイプのアニメーションを生成することであり、このタブのコントロールにより、フレームを順方向、逆方向に再生し、ループで繰り返すことができます。 順方向および逆方向再生の最後のフレームを繰り返して、遅延のように見せることもできます。 これはすべて、AVIファイルにフレームを複数回追加することによって実現されるため、使用されるリピートが多いほど、結果のAVIファイルは大きくなりますが、MPEG-4コーデックはデータを圧縮するのに優れているため、これはそれほど問題ではありません。 。

デフォルトでは、アニメーションは順方向に再生され、最後のフレームが20回繰り返されます。これは、選択した10フレーム/秒で2秒間の休止です。

少し面白くするために、逆再生を有効にし、逆再生の最後のフレームを5回繰り返します。 これにより、リバース再生の最後に0.5秒間効果的に一時停止します。 whoシーケンスは5回繰り返されますが、最後の繰り返しでは逆再生が行われないため、アニメーションは最初のフレームではなく最後のフレームで終了します。

ここで「出力オプション」タブに移動します。 繰り返しますが、いくつかのオプションは自動的に設定されているため、色が緑に変更されています。 基本的に、AVIコーデックはFMP4コーデックに変更され、AVIファイルの1秒あたりの出力フレームは10に設定されています。アニメーションにフレームが多くない場合、1秒あたり10フレームは少し速すぎるかもしれませんが、 この例では50フレームなので、10 fpsifで問題なく、スムーズなアニメーションが得られます。

変更を加えるために、MPEG-4エンコーディングの品質を6から8に上げます。

最後に、「Do Processing」タブに移動し、「Start Processing」ボタンをクリックします。

処理は非常に迅速に完了します。この場合、わずか3秒で完了したことがわかります。

完了すると、エクスプローラウィンドウが開き、生成されたAVIファイルが表示されます。

生成されるAVIファイルのサイズはわずか1.4MBです。 メールで共有するのに十分なほど小さく、YouTubeまたはお気に入りのビデオストリーミングWebサイトにアップロードして共有するのに十分なほど小さい。

ストリーミングのためにGoogleドキュメントにアップロードされた後のアニメーションビデオ（ここをクリック）です。

例7：アーカイブ用のAVIの処理

この例では、Ut Videoコーデックを使用してサンプル動画を圧縮し、結果を比較します。

プラネタリーイメージングは、多くのイメージャがアーカイブしたいAVIファイルの形式で大量のデータを生成します。この例では、このデータのサイズを小さくして、必要なハードドライブ容量を減らしています。 この特定の例では、品質を損なうことなくキャプチャファイルを圧縮し、元のデータはすべて保持されます。

この例では、次の4つのAVIファイルを処理して、達成可能な圧縮についてのアイデアを提供します。

●　テストビデオ1

ファイル名：jupiter 05_12_2010 21_23_33.avi

ファイルサイズ：901095 KB

フレーム：2000

コーデック：I420

カメラ：SPC900

これは、SPC900NC Webカメラを使用した基本的な惑星のキャプチャ（ここをクリック）を表しています。

●　テストビデオ2

ファイル名：jupiter 11-11-10 23-25-56.avi

ファイルサイズ：1803152 KB

フレーム：6017

コーデック：Y800

カメラ：DFK 21AU618.AS

これはカラーカメラからの生のキャプチャ（ここをクリック）です。 色を回復するには、ビデオをディベイヤする必要があります。

●　テストビデオ3

ファイル名：Mars_R_25_02_2012_004437.avi

ファイルサイズ：1200120 KB

フレーム：4000

コーデック：DIB

カメラ：DMK 21AU618.AS

これは、赤いフィルターを使用したモノラルカメラからのキャプチャ（ここをクリック）です。

●　テストビデオ4

ファイル名：moon 12-02-01 20-26-06.avi

ファイルサイズ：1,800,151 KB

フレーム：6000

コーデック：DIB

カメラ：DMK 21AU618.AS

これは、モノカメラを使った月のクローズアップ（ここをクリック）です。

最初の段階では、PIPPを起動し、アーカイブするすべてのファイルを「ソースファイルリスト」に追加します。 ファイルは同じディレクトリにある必要はなく、各AVIファイルの圧縮バージョンはソースファイルと同じディレクトリに生成されることに注意してください。

次のステップは、「AVIアーカイブの最適化オプション」セレクターを有効にすることです。

ULRGコーデックを使用するようにすべてのAVIファイルを変換するオプションを設定するために必要なのは、これだけです。

完全を期すために、「出力オプション」タブを見て、「AVIアーカイブの最適化オプション」の選択による変更を確認します。

まず、[ソースファイルディレクトリを使用]オプションが有効になっていることに注意してください。 つまり、新しく生成される各AVIファイルは、個別のディレクトリではなく、対応するソースファイルの隣に生成されます。

次に、「出力ファイル名のサフィックス」がデフォルトの「_pipp」から「_ulrg」に変更されたことに注意してください。これにより、生成されたAVIファイルがULRGコーデックを使用していることがわかります。

最後に、「出力形式」がAVIに変更され、「AVIコーデック」が「ULRG（Utビデオロスレス圧縮）」に変更されていることに注意してください。

実際に処理を行うには、[処理を実行]タブに移動し、[処理を開始]ボタンをクリックします。

数分待った後、変換が完了します。

そして、PIPPは、新しく作成されたAVIファイルを含むExplorerウィンドウを開きます。 これは実際には、新しく生成されたAVIファイルに_ulrgがサフィックスとして追加された元のソースファイルディレクトリです。

エクスプローラーウィンドウで元のAVIファイルを選択して削除できるようになり、ファイルの圧縮バージョンが残ります。

元のファイルサイズと圧縮ファイルサイズの比較

ファイル名 | オリジナルサイズ | 圧縮サイズ | 元のサイズの(％)
jupiter 05_12_2010 21_23_33.avi | 901,095 KB | 259,452 KB | 29.8 %
jupiter 11-11-10 23-25-56.avi | 1,803,152 KB | 878,140 KB | 48.7 %
Mars_R_25_02_2012_004437.avi | 1,200,120 KB | 533,981 KB | 44.5 %
moon 12-02-01 20-26-06.avi | 1,800,151 KB | 578,751 KB | 32.2 %

これはロスレス圧縮を使用しており、元のAVIファイルからデータが失われていないことに注意してください。

このアーカイブデータの処理に関しては、AutoStakkertの最新バージョンと同様に、Ut Videoコーデックがコンピューターにインストールされている場合、RegiStax 6はこれらのファイルを直接処理できます。 ただし、PIPPは常に使用でき、未加工の「DIB」コーデックを使用してAVIファイルに変換したり、ほとんどのツールが標準として想定しているSERファイルに変換したりできます。 Ut Videoコーデックは、http：//umezawa.dyndns.info/archive/utvideo/からダウンロードできます。

例8：月/太陽表面ビデオ処理

びくびくした月面ビデオ安定化の例。

この例は、ジャンプする月面のビデオを処理するPIPPを示していますが、太陽面のビデオでも同じ操作を実行できます。 このプロセスの目的は、スタッキングソフトウェアで処理するにはジャンプが大きすぎるビデオのフレームを安定させることです。 私の経験では、RegiStax 6とAutoStakkert！2の両方が実際にこれらのタイプのびくびくしたビデオを非常にうまく処理します。実際、どちらのプログラムもこの例で使用されているビデオを問題なく処理します。 ただし、スタッキングソフトウェアが動作しなくなる、奇妙で面倒なビデオにこの手法を利用できるのは価値があると思います。

スタッキングソフトウェアで問題を引き起こす可能性のある表面ビデオの例

● 望遠鏡のマウントをぶつけたり蹴ったりしたために非常に急にジャンプした表面ビデオ。

● 記録中に一時停止された表面ビデオ。

● 2つ以上のビデオを結合して作成されたビデオを表示します。

明らかに、これらの状況を回避する価値はありますが、この機能は、単にそれを削除するのではなく、ビデオデータから何かを救うことができる場合があります。

これは、この例で使用されるソースビデオ（ここをクリック）です。 ビデオが絶え間なく吹き飛ばされていることに注意してください。多くの場合、私たちがイメージしようとしている機能をフレームから取り出しています。

このビデオを共有してくれたSteve Curling（SGLのBlazar）に感謝します。

通常どおり、PIPPが起動し、ビデオファイルが画像ファイルリストに追加されます。

次に、「太陽/月のクローズアップに最適なオプション」オプションを選択して、今回のイメージングに適したオプションを選択します。

太陽/月のクローズアップイメージングのオプションを最適化すると、処理オプションタブにいくつかの変更が加えられます。 最適化オプションの選択により変更されたオプションは、緑色のテキストラベルで識別できます。

「モノクロ変換」が有効になっていますが、これはカラービデオにのみ影響することに注意してください。 ただし、主な注意点は、「フレーム安定化モード」が「表面機能」に変更され、「表面安定化」コントロールのセットが表示され、「表面安定化を有効にする」コントロールがチェックされていることです。

PIPPの画像プレビューウィンドウに切り替えると、「アンカー機能ボックス」（AFB）が画像上に表示されていることがわかります。 ユーザーは、PIPPがビデオを安定させるために使用するフレームの「位置合わせ機能」の周りにAFBを配置する必要があります。 適切な位置合わせ機能には、明るい領域と暗い領域があり、後続のフレームで一意に一致できるように区別する必要があります。

コントロールハンドル（小さな四角）をドラッグして、AFBを配置します。 中央のコントロールハンドルは、サイズを変更せずにAFB全体を移動します。コーナーのコントロールハンドルは、AFBのサイズを変更して、選択した配置機能に一致させることができます。 AFBが大きいほど、処理に時間がかかる場合があることに注意してください。

AFBが設定されたので、ビデオを処理して、現在のオプションが結果に与える影響を確認します。

これを行うには、「処理を実行」タブに移動し、「処理を開始」ボタンを押します。

処理が完了したときの結果です。 この時点で、出力領域で要約の詳細を確認します。

ここでは、AFBが見つからなかったため、1433の入力フレームから44が破棄されたことがわかります。

この処理から生成されたビデオ（ここをクリック）は次のとおりです。

アンカーフィーチャが最初のフレームと同じ位置に移動するように各フレームがシフトされ、使用可能なデータがない各フレームに黒い境界線が表示されていることがわかります。 黒い境界線は積み重ねられた画像にアーティファクトを作成する傾向があるため、このビデオは積み重ねにはあまり役に立ちません。

スタッキングに適したビデオを作成するには、「関心領域」（AOI）も使用する必要があります。 AOIを使用して、フレームが拒否されないようにするために存在する必要がある領域を指定できます。また、AOIを使用して、ビデオをトリミングする領域を指定することもできます。 この例では、完全なAOIがないフレームを拒否し、最終的なビデオをAOIのサイズにトリミングします。 これは、生成されたビデオに黒い枠がないことを意味しますが、より多くのフレームが拒否されます。

「関心領域の有効化」コントロールにチェックを付け続けます。

これで、PIPPの画像プレビューウィンドウには、青い「関心領域」と「アンカー機能ボックス」も表示されます。 ここで、コーナーのコントロールハンドルをドラッグして、AOIのサイズと位置を変更する必要があります。 AOIを大きくしすぎると、完全なAOIを含むフレームが少なくなるため、多くのフレームが破棄される可能性があります。

これは、最終的なビデオに表示したいフレームの部分を選択するためにAOIのサイズと位置が変更された後の画像プレビューウィンドウです。

[Show AFB / AOI]コントロールのチェックを外すと、出力ビデオに表示されるのと同じように、出力フレームのみが表示されます。

[処理オプション]タブをもう一度見ると、[画像プレビュー]ウィンドウでAOIを設定するアクションにより、[対象領域]コントロールグループの詳細が更新されていることがわかります。 イメージプレビューウィンドウで設定された「アンカー機能ブロック」についても同様です。

次に、[処理を実行]タブに移動し、[処理を開始]ボタンをクリックして、選択したオプションを使用して安定したビデオを生成します。

いつものように、出力領域で要約の詳細を確認する必要があります。 この場合、AFBが見つからなかったため、1433個の入力フレームから以前と同様に44個のフレームが破棄されていることがわかります。これに加えて、完全なAOIが含まれていないため、余分な664個のフレームが破棄されました。 この結果、出力ビデオには725フレームしか含まれませんが、これは明らかに入力ビデオと選択したAOIに依存します。

これは生成されたビデオ（ここをクリック）です

このビデオは黒いバーなしで安定化されますが、余分なフレームは破棄されます。 このビデオは、処理のスタッキングフェーズに進むのに適しています。


チュートリアル

高解像度の惑星と月の写真を作成―Viktor Schmidt

https://astro-viktorianer.blogspot.com/2018/01/hochauflosende-planeten-und-mondfotos.html

キャプチャから最終画像までのすべての側面をカバーする素晴らしいガイド。 ガイドはドイツ語で書かれていますが、Chromeブラウザーを使用して問題なく英語で表示できました。

Viktorは「Sternfreunde im FEZ e.V.」の会長です。 天文学クラブ（https://www.sifez.de/）は、子供や若者の間で天文学への関心を高め、知識の伝達を促進するために活動しています。


フィードバック

PIPPに関するフィードバックは大歓迎です。 新しいグラフィックバージョンのPIPPでは、コードが大幅に書き直されているため、多くのバグを見つける必要があります。 バグを見つけたら、詳細をメールで送ってください。

また、PIPPの機能を長期にわたって拡張することを目的としており、ユーザーからのフィードバックが開発の方向付けに大きく役立つため、新機能のアイデアも興味深いものです。

コメントやフィードバックはastropipp@gmail.comに送信してください。